summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-23 16:48:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-23 16:48:33 +0000
commit5a8c5e2356110efb77210ca8462432ab1c6fb3db (patch)
treeebe0909d58d3b1e81acd22a36905641cd5263da8 /net-im/pyicq-t
parentRemove old. (diff)
downloadgentoo-2-5a8c5e2356110efb77210ca8462432ab1c6fb3db.tar.gz
gentoo-2-5a8c5e2356110efb77210ca8462432ab1c6fb3db.tar.bz2
gentoo-2-5a8c5e2356110efb77210ca8462432ab1c6fb3db.zip
Cleanup old. Add missing die. Fixes bug #471542.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-im/pyicq-t')
-rw-r--r--net-im/pyicq-t/ChangeLog7
-rw-r--r--net-im/pyicq-t/files/pyicq-t-0.8-initd23
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild78
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild52
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r3.ebuild51
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild4
6 files changed, 8 insertions, 207 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index 43ae4e5f2614..7c0a54a12bfc 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/pyicq-t
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.32 2014/11/23 16:46:54 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.33 2014/11/23 16:48:33 mrueg Exp $
+
+ 23 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -files/pyicq-t-0.8-initd,
+ -pyicq-t-0.8.1.5-r1.ebuild, -pyicq-t-0.8.1.5-r2.ebuild,
+ -pyicq-t-0.8.1.5-r3.ebuild, pyicq-t-0.8.1.5-r4.ebuild:
+ Cleanup old. Add missing die. Fixes bug #471542.
23 Nov 2014; Manuel Rüger <mrueg@gentoo.org> pyicq-t-0.8.1.5-r4.ebuild:
Mark stable on x86. Based on build testing by Myckel Habets.
diff --git a/net-im/pyicq-t/files/pyicq-t-0.8-initd b/net-im/pyicq-t/files/pyicq-t-0.8-initd
deleted file mode 100644
index 782b410232a8..000000000000
--- a/net-im/pyicq-t/files/pyicq-t-0.8-initd
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/files/pyicq-t-0.8-initd,v 1.3 2011/08/21 17:41:16 hanno Exp $
-
-depend() {
- need net
- use jabber-server
-}
-
-start() {
- ebegin "Starting ICQ Jabber Transport"
- start-stop-daemon --start --pidfile /var/run/jabber/pyicq-t.pid -u jabber -g jabber \
- --exec /usr/bin/python INSPATH/pyicq-t.py -- \
- -b -c /etc/jabber/pyicq-t.xml -l /var/log/jabber/pyicq-t.log
- eend $?
-}
-
-stop() {
- ebegin "Stopping ICQ Jabber Transport"
- start-stop-daemon --stop --quiet --pidfile /var/run/jabber/pyicq-t.pid
- eend $?
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild
deleted file mode 100644
index 07102a73a9de..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r1.ebuild,v 1.5 2014/08/05 18:34:14 mrueg Exp $
-
-EAPI="5"
-PYTHON_DEPEND="2"
-inherit eutils python
-
-MY_P="${P/pyicq-t/pyicqt}"
-
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://code.google.com/p/pyicqt/"
-SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-core-2.2.0
- >=dev-python/twisted-words-0.1.0
- >=dev-python/twisted-web-0.5.0
- webinterface? ( >=dev-python/nevow-0.4.1 )
- >=dev-python/imaging-1.1"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python26-warnings.diff"
-}
-
-src_install() {
- local inspath
-
- inspath=$(python_get_sitedir)/${PN}
- insinto ${inspath}
- doins -r data src tools
- newins PyICQt.py ${PN}.py
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- fperms 755 "$(python_get_sitedir)/${PN}/pyicq-t.py"
- sed -i \
- -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- "${ED}/etc/jabber/${PN}.xml"
-
- newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
- sed -i -e "s:INSPATH:${inspath}:" "${ED}/etc/init.d/${PN}"
- python_convert_shebangs ${PYTHON_ABI} "${ED}$(python_get_sitedir)/${PN}/pyicq-t.py"
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-
- elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
- elog "Please edit it and the configuration of your Jabber server to match."
-
- ewarn "If you are storing user accounts in MySQL and are upgrading from a "
- ewarn "version older than 0.8.1, then you will need to run the following "
- ewarn "command to create some new tables:"
- ewarn " mysql -u user_name -p pyicqt < $(python_get_sitedir)/${PN}/tools/db-setup.mysql"
-
- elog "These instructions along with a list of new config variables are "
- elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild
deleted file mode 100644
index 3e99c977fd55..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r2.ebuild,v 1.2 2014/08/05 18:34:14 mrueg Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils python-single-r1
-
-MY_P="${P/pyicq-t/pyicqt}"
-
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://code.google.com/p/pyicqt/"
-SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-core-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-words-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/twisted-web-0.5.0[${PYTHON_USEDEP}]
- webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-python26-warnings.diff"
- "${FILESDIR}/${P}-pillow-imaging.patch"
-)
-
-src_install() {
- python_moduleinto ${PN}
- cp PyICQt.py pyicq-t.py || die
- python_domodule pyicq-t.py data tools src
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- fperms 755 "$(python_get_sitedir)/${PN}/pyicq-t.py"
- sed -i \
- -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- "${ED}/etc/jabber/${PN}.xml"
-
- newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
- sed -i -e "s:INSPATH:$(python_get_sitedir):" "${ED}/etc/init.d/${PN}"
- python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r3.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r3.ebuild
deleted file mode 100644
index 741888a12b5e..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8.1.5-r3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r3.ebuild,v 1.2 2014/08/05 18:34:14 mrueg Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils python-single-r1
-
-MY_P="${P/pyicq-t/pyicqt}"
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://code.google.com/p/pyicqt/"
-SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- dev-python/twisted-core[${PYTHON_USEDEP}]
- dev-python/twisted-words[${PYTHON_USEDEP}]
- dev-python/twisted-web[${PYTHON_USEDEP}]
- webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python26-warnings.diff"
- epatch "${FILESDIR}/${P}-pillow-imaging.patch"
-}
-
-src_install() {
- python_moduleinto ${PN}
- cp PyICQt.py ${PN}.py || die
- python_domodule ${PN}.py data tools src
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- fperms 755 "$(python_get_sitedir)/${PN}/${PN}.py"
- sed -i \
- -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- "${ED}/etc/jabber/${PN}.xml"
-
- newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
- sed -i -e "s:INSPATH:$(python_get_sitedir)/${PN}:" "${ED}/etc/init.d/${PN}"
- python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild
index ee7b6bbfb2b0..b93a9eee97a7 100644
--- a/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild
+++ b/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild,v 1.3 2014/11/23 16:46:54 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild,v 1.4 2014/11/23 16:48:33 mrueg Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -43,7 +43,7 @@ src_install() {
sed -i \
-e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
-e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- "${ED}/etc/jabber/${PN}.xml"
+ "${ED}/etc/jabber/${PN}.xml" || die
newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
systemd_dounit "${FILESDIR}/${PN}.service"