summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2010-01-10 10:25:27 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2010-01-10 10:25:27 +0000
commit354b8beeb1e4e044971b626db007f4de32ec4b9c (patch)
treeb5659b35c1af454df12f5fe1a077346ef40eae13 /net-im/pyicq-t
parentFix compiling with java6 and non ISO-8859-1 locales. (diff)
downloadgentoo-2-354b8beeb1e4e044971b626db007f4de32ec4b9c.tar.gz
gentoo-2-354b8beeb1e4e044971b626db007f4de32ec4b9c.tar.bz2
gentoo-2-354b8beeb1e4e044971b626db007f4de32ec4b9c.zip
Removed old pyicq-t ebuilds
(Portage version: 2.1.7.5/cvs/Linux x86_64)
Diffstat (limited to 'net-im/pyicq-t')
-rw-r--r--net-im/pyicq-t/ChangeLog9
-rw-r--r--net-im/pyicq-t/files/pyicq-t-0.8-twisted-2.5.patch15
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild71
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8.1.ebuild75
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8a.ebuild66
-rw-r--r--net-im/pyicq-t/pyicq-t-0.8b.ebuild64
6 files changed, 7 insertions, 293 deletions
diff --git a/net-im/pyicq-t/ChangeLog b/net-im/pyicq-t/ChangeLog
index 5c61ad1ce431..62b8711a1061 100644
--- a/net-im/pyicq-t/ChangeLog
+++ b/net-im/pyicq-t/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/pyicq-t
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.17 2009/10/03 17:30:43 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/ChangeLog,v 1.18 2010/01/10 10:25:27 griffon26 Exp $
+
+ 10 Jan 2010; Maurice van der Pot <griffon26@gentoo.org>
+ -files/pyicq-t-0.8-twisted-2.5.patch, -pyicq-t-0.8.1.ebuild,
+ -pyicq-t-0.8.1.1.ebuild, -pyicq-t-0.8a.ebuild, -pyicq-t-0.8b.ebuild:
+ Removed old ebuilds.
03 Oct 2009; Markus Meier <maekke@gentoo.org> pyicq-t-0.8.1.5.ebuild:
amd64/x86 stable, bug #287378
diff --git a/net-im/pyicq-t/files/pyicq-t-0.8-twisted-2.5.patch b/net-im/pyicq-t/files/pyicq-t-0.8-twisted-2.5.patch
deleted file mode 100644
index f38b73d13fd8..000000000000
--- a/net-im/pyicq-t/files/pyicq-t-0.8-twisted-2.5.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -ruN pyicq-t-0.8/src/main.py pyicq-t-0.8-fixed/src/main.py
---- pyicq-t-0.8/src/main.py 2006-09-30 21:44:21.000000000 +0200
-+++ pyicq-t-0.8-fixed/src/main.py 2007-04-28 14:37:15.000000000 +0200
-@@ -89,7 +89,10 @@
- import signal
- signal.signal(signal.SIGHUP, reloadConfig)
- # Load scripts for PID and daemonizing
-- from twisted.scripts import twistd
-+ try:
-+ from twisted.scripts import _twistd_unix as twistd
-+ except:
-+ from twisted.scripts import twistd
-
- selectWarning = "Unable to install any good reactors (kqueue, cf, epoll, poll).\nWe fell back to using select. You may have scalability problems.\nThis reactor will not support more than 1024 connections +at a time. You may silence this message by choosing 'select' or 'default' as your reactor in the transport config."
- if config.reactor and len(config.reactor) > 0:
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild
deleted file mode 100644
index 77ce2750cfb3..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.1.ebuild,v 1.3 2009/03/09 14:12:41 armin76 Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils multilib python
-
-MY_P="${P/pyicq-t/pyicqt}"
-
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://code.google.com/p/pyicqt/"
-SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-2.2.0
- >=dev-python/twisted-words-0.1.0
- >=dev-python/twisted-web-0.5.0
- webinterface? ( >=dev-python/nevow-0.4.1 )
- >=dev-python/imaging-1.1"
-
-src_install() {
- local inspath
-
- python_version
- inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
- insinto ${inspath}
- doins -r data src tools
- newins PyICQt.py ${PN}.py
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- dosed \
- "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- /etc/jabber/${PN}.xml
- dosed \
- "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- /etc/jabber/${PN}.xml
-
- newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
- dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
- elog "Please edit it and the configuration of your Jabber server to match."
-
- ewarn "If you are storing user accounts in MySQL and are upgrading from a "
- ewarn "version older than 0.8.1, then you will need to run the following "
- ewarn "command to create some new tables:"
- ewarn " mysql -u user_name -p pyicqt < /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tools/db-setup.mysql"
-
- elog "These instructions along with a list of new config variables are "
- elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.ebuild
deleted file mode 100644
index d7a0c8cff7e5..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8.1.ebuild,v 1.1 2008/12/19 18:00:44 griffon26 Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils multilib python
-
-MY_P="${P/pyicq-t/pyicqt}"
-
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://code.google.com/p/pyicqt/"
-SRC_URI="http://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-2.2.0
- >=dev-python/twisted-words-0.1.0
- >=dev-python/twisted-web-0.5.0
- webinterface? ( >=dev-python/nevow-0.4.1 )
- >=dev-python/imaging-1.1"
-
-src_unpack() {
- unpack ${A} && cd "${S}" || die "unpack failed"
-}
-
-src_install() {
- local inspath
-
- python_version
- inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
- insinto ${inspath}
- doins -r data src tools
- newins PyICQt.py ${PN}.py
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- dosed \
- "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- /etc/jabber/${PN}.xml
- dosed \
- "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- /etc/jabber/${PN}.xml
-
- newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
- dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
- elog "Please edit it and the configuration of your Jabber server to match."
-
- ewarn "If you are storing user accounts in MySQL and are upgrading from a "
- ewarn "version older than 0.8.1, then you will need to run the following "
- ewarn "command to create some new tables:"
- ewarn " mysql -u user_name -p pyicqt < /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/tools/db-setup.mysql"
-
- elog "These instructions along with a list of new config variables are "
- elog "available at: http://code.google.com/p/pyicqt/wiki/Upgrade"
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8a.ebuild b/net-im/pyicq-t/pyicq-t-0.8a.ebuild
deleted file mode 100644
index 262afb62c264..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8a.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8a.ebuild,v 1.4 2008/05/29 17:39:42 hawking Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils multilib python
-
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://pyicq-t.blathersource.org/"
-SRC_URI="http://www.blathersource.org/download.php/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-2.2.0
- >=dev-python/twisted-words-0.1.0
- >=dev-python/twisted-web-0.5.0
- webinterface? ( >=dev-python/nevow-0.4.1 )
- >=dev-python/imaging-1.1"
-
-src_unpack() {
- unpack ${A} && cd "${S}" || die "unpack failed"
-
- epatch "${FILESDIR}/${PN}-0.8-twisted-2.5.patch"
-}
-
-src_install() {
- local inspath
-
- python_version
- inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
- insinto ${inspath}
- doins -r data src tools
- newins PyICQt.py ${PN}.py
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- dosed \
- "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- /etc/jabber/${PN}.xml
- dosed \
- "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- /etc/jabber/${PN}.xml
-
- newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
- dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
- elog "Please edit it and the configuration of your Jabber server to match."
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8b.ebuild b/net-im/pyicq-t/pyicq-t-0.8b.ebuild
deleted file mode 100644
index 9fb6a31144cd..000000000000
--- a/net-im/pyicq-t/pyicq-t-0.8b.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8b.ebuild,v 1.3 2008/08/17 15:22:50 maekke Exp $
-
-NEED_PYTHON=2.3
-
-inherit eutils multilib python
-
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="http://code.google.com/p/pyicqt/"
-SRC_URI="http://pyicqt.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-2.2.0
- >=dev-python/twisted-words-0.1.0
- >=dev-python/twisted-web-0.5.0
- webinterface? ( >=dev-python/nevow-0.4.1 )
- >=dev-python/imaging-1.1"
-
-src_unpack() {
- unpack ${A} && cd "${S}" || die "unpack failed"
-}
-
-src_install() {
- local inspath
-
- python_version
- inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
- insinto ${inspath}
- doins -r data src tools
- newins PyICQt.py ${PN}.py
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- dosed \
- "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- /etc/jabber/${PN}.xml
- dosed \
- "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- /etc/jabber/${PN}.xml
-
- newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
- dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
- elog "Please edit it and the configuration of your Jabber server to match."
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
-}