summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-23 16:51:53 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-23 16:51:53 +0000
commit77fa5ca160ddb86ca12f13407ea8c44ee36b20f0 (patch)
treeb5fa161f0133b718781e0fb89202c64f50052e22 /net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild
parentCleanup old. Add missing die. Fixes bug #471542. (diff)
downloadgentoo-2-77fa5ca160ddb86ca12f13407ea8c44ee36b20f0.tar.gz
gentoo-2-77fa5ca160ddb86ca12f13407ea8c44ee36b20f0.tar.bz2
gentoo-2-77fa5ca160ddb86ca12f13407ea8c44ee36b20f0.zip
Mark stable on x86. Based on build testing by Myckel Habets. Add missing die. Cleanup old. Fixes bug #471544
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild')
-rw-r--r--net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild b/net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild
deleted file mode 100644
index 263d9688f0c0..000000000000
--- a/net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pyaim-t/pyaim-t-0.8.0.1.ebuild,v 1.6 2014/08/05 18:34:18 mrueg Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit eutils python
-
-MY_P="pyaimt-${PV}"
-DESCRIPTION="Python based jabber transport for AIM"
-HOMEPAGE="http://code.google.com/p/pyaimt/"
-SRC_URI="http://pyaimt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
- >=dev-python/twisted-core-2.2.0
- >=dev-python/twisted-words-0.1.0
- >=dev-python/twisted-web-0.5.0
- webinterface? ( >=dev-python/nevow-0.4.1 )
- >=dev-python/imaging-1.1"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python26-warnings.patch"
-}
-
-src_install() {
- local inspath
-
- inspath=$(python_get_sitedir)/${PN}
- insinto ${inspath}
- doins -r data src tools
- newins PyAIMt.py ${PN}.py
-
- insinto /etc/jabber
- newins config_example.xml ${PN}.xml
- fperms 600 /etc/jabber/${PN}.xml
- fowners jabber:jabber /etc/jabber/${PN}.xml
- dosed \
- "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
- /etc/jabber/${PN}.xml
- dosed \
- "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
- /etc/jabber/${PN}.xml
-
- newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
- dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-
- elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
- elog "Please edit it and the configuration of your Jabber server to match."
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}