summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-02-01 12:25:38 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-02-01 12:25:38 +0000
commit2f72cb818d2767ffff3d7822605b711cc121bacc (patch)
tree141d7e6b227170f02fa765780c04be812396b3f8 /net-im/psi
parentversion bump (diff)
downloadgentoo-2-2f72cb818d2767ffff3d7822605b711cc121bacc.tar.gz
gentoo-2-2f72cb818d2767ffff3d7822605b711cc121bacc.tar.bz2
gentoo-2-2f72cb818d2767ffff3d7822605b711cc121bacc.zip
bziped patch
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/files/vcard-photo-interface.patch740
-rw-r--r--net-im/psi/files/vcard-photo-interface.patch.bz2bin0 -> 4232 bytes
-rw-r--r--net-im/psi/psi-0.9.3-r4.ebuild4
3 files changed, 2 insertions, 742 deletions
diff --git a/net-im/psi/files/vcard-photo-interface.patch b/net-im/psi/files/vcard-photo-interface.patch
deleted file mode 100644
index 22a7e4b79071..000000000000
--- a/net-im/psi/files/vcard-photo-interface.patch
+++ /dev/null
@@ -1,740 +0,0 @@
-diff -Naur psi-0.9.3-orig/src/common.h psi-0.9.3/src/common.h
---- psi-0.9.3-orig/src/common.h 2005-05-17 23:31:38.000000000 +0000
-+++ psi-0.9.3/src/common.h 2005-05-17 23:31:39.000000000 +0000
-@@ -252,6 +252,10 @@
- QString spoofClientName;
- QString spoofClientVersion;
- QString spoofClientOS;
-+
-+ // Last used path remembering
-+ QString lastPath;
-+ QString lastSavePath;
- };
-
- // functions
-diff -Naur psi-0.9.3-orig/src/infodlg.cpp psi-0.9.3/src/infodlg.cpp
---- psi-0.9.3-orig/src/infodlg.cpp 2004-10-03 11:11:35.000000000 +0000
-+++ psi-0.9.3/src/infodlg.cpp 2005-05-17 23:31:39.000000000 +0000
-@@ -27,6 +27,8 @@
- #include<qlineedit.h>
- #include<qmessagebox.h>
- #include<qtextedit.h>
-+#include<qfiledialog.h>
-+#include<qbuffer.h>
- #include"xmpp.h"
- #include"xmpp_vcard.h"
- #include"xmpp_tasks.h"
-@@ -36,6 +38,7 @@
- #include"vcardfactory.h"
- #include"iconwidget.h"
-
-+
- using namespace XMPP;
-
- class InfoDlg::Private
-@@ -78,12 +81,18 @@
-
- connect(pb_refresh, SIGNAL(clicked()), this, SLOT(doRefresh()));
- connect(te_desc, SIGNAL(textChanged()), this, SLOT(textChanged()));
-+ connect(pb_open, SIGNAL(clicked()), this, SLOT(selectPhoto()));
-+ connect(pb_clear, SIGNAL(clicked()), this, SLOT(clearPhoto()));
-
- if(d->type == Self) {
- connect(pb_submit, SIGNAL(clicked()), this, SLOT(doSubmit()));
- }
- else {
- pb_submit->hide();
-+ pb_open->hide();
-+ pb_clear->hide();
-+ //ly_photo->setSpacing(0);
-+ delete ly_photo_buttons;
- setReadOnly(true);
- }
-
-@@ -206,6 +215,14 @@
- le_title->setText( i.title() );
- le_role->setText( i.role() );
- te_desc->setText( i.desc() );
-+
-+ if ( !i.photo().isEmpty() ) {
-+ //printf("There is a picture...\n");
-+ QImage img(i.photo());
-+ label_photo->setPixmap(QPixmap(img));
-+ }
-+ else
-+ clearPhoto();
-
- setEdited(false);
- }
-@@ -218,6 +235,8 @@
- le_email->setEnabled(x);
- le_homepage->setEnabled(x);
- le_phone->setEnabled(x);
-+ pb_open->setEnabled(x);
-+ pb_clear->setEnabled(x);
-
- le_street->setEnabled(x);
- le_ext->setEnabled(x);
-@@ -377,6 +396,17 @@
- list << p;
- v.setPhoneList( list );
- }
-+
-+ if ( label_photo->pixmap() ) {
-+ //printf("Adding a pixmap to the vCard...\n");
-+ QImage image = (label_photo->pixmap())->convertToImage();
-+ QByteArray ba;
-+ QBuffer buffer( ba );
-+ buffer.open( IO_WriteOnly );
-+ image.save( &buffer, "PNG" );
-+
-+ v.setPhoto( ba );
-+ }
-
- if ( !le_street->text().isEmpty() ||
- !le_ext->text().isEmpty() ||
-@@ -419,3 +449,72 @@
- {
- d->te_edited = true;
- }
-+
-+/*!
-+ * Opens a file browser dialog, and if selected, calls the setPreviewPhoto with the consecuent path.
-+ * \see setPreviewPhoto(const QString& path)
-+*/
-+void InfoDlg::selectPhoto()
-+{
-+ while(1) {
-+ if(option.lastPath.isEmpty())
-+ option.lastPath = QDir::homeDirPath();
-+ QString str = QFileDialog::getOpenFileName(option.lastPath, tr("Images (*.png *.xpm *.jpg *.jpeg *.gif *.PNG *.XPM *.JPG *.JPEG *.GIF)"), this, 0, tr("Choose a file"));
-+ if(!str.isEmpty()) {
-+ QFileInfo fi(str);
-+ if(!fi.exists()) {
-+ QMessageBox::information(this, tr("Error"), tr("The file specified does not exist."));
-+ continue;
-+ }
-+ option.lastPath = fi.dirPath();
-+ //printf(QDir::convertSeparators(fi.filePath()));
-+
-+ // put the image in the preview box
-+ setPreviewPhoto(str);
-+ }
-+ break;
-+ }
-+
-+}
-+
-+/*!
-+ * Loads the image from the requested URL, and inserts the resized image into the preview box.
-+ * \param path image file to load
-+*/
-+void InfoDlg::setPreviewPhoto(const QString& path)
-+{
-+ bool loadOK;
-+ QPixmap pixmap;
-+ loadOK = pixmap.load(path);
-+
-+ if(loadOK) {
-+ const int MAXSIZE = 128;
-+ const int width = (int) MAXSIZE*((float)pixmap.width()/pixmap.height());
-+ printf("%i width\n%i height\n",width,MAXSIZE);
-+
-+ // copy the pixmap in the image
-+ QImage i = pixmap.convertToImage();
-+
-+ // resize the image and put it into the pixmap
-+ pixmap.convertFromImage(i.smoothScale(width,MAXSIZE,QImage::ScaleMax));
-+
-+ // put the image in the box
-+ label_photo->setPixmap(pixmap);
-+ // printf("%i\n",(label_photo->pixmap())->width());
-+
-+ // activate the te_edited variable in the private: the image was changed
-+ d->te_edited = true;
-+ }
-+}
-+
-+/*!
-+ * Clears the preview image box and marks the te_edited signal in the private.
-+*/
-+void InfoDlg::clearPhoto()
-+{
-+ // this will cause the pixmap disappear
-+ label_photo->setText(tr("Picture not\navailable"));
-+
-+ // the picture changed, so notify there are some changes done
-+ d->te_edited = true;
-+}
-diff -Naur psi-0.9.3-orig/src/infodlg.h psi-0.9.3/src/infodlg.h
---- psi-0.9.3-orig/src/infodlg.h 2003-10-22 11:40:37.000000000 +0000
-+++ psi-0.9.3/src/infodlg.h 2005-05-17 23:31:39.000000000 +0000
-@@ -51,6 +51,8 @@
- void jt_finished();
- void doSubmit();
- void textChanged();
-+ void selectPhoto();
-+ void clearPhoto();
-
- private:
- class Private;
-@@ -62,6 +64,9 @@
- void setReadOnly(bool);
- bool edited();
- void setEdited(bool);
-+ void setPreviewPhoto(const QString& str);
-+ inline int min(int a, int b)
-+ { return (a<b)?a:b; }
- };
-
- #endif
-diff -Naur psi-0.9.3-orig/src/psi_profiles.cpp psi-0.9.3/src/psi_profiles.cpp
---- psi-0.9.3-orig/src/psi_profiles.cpp 2005-05-17 23:31:38.000000000 +0000
-+++ psi-0.9.3/src/psi_profiles.cpp 2005-05-17 23:31:39.000000000 +0000
-@@ -677,6 +677,10 @@
- prefs.replyInAuthReq = true;
- prefs.defaultReplyWithoutQuoting = true;
-
-+ // Last used path remembering
-+ prefs.lastPath = QDir::homeDirPath();
-+ prefs.lastSavePath = QDir::homeDirPath();
-+
- // Avatars
- prefs.avatarsEnabled = true;
- prefs.avatarsChatdlgEnabled = true;
-@@ -842,6 +846,8 @@
- p_misc.appendChild(textTag(doc, "jidComplete", prefs.jidComplete));
- p_misc.appendChild(textTag(doc, "grabUrls", prefs.grabUrls));
- p_misc.appendChild(textTag(doc, "messageEvents", prefs.messageEvents));
-+ p_misc.appendChild(textTag(doc, "lastPath", prefs.lastPath));
-+ p_misc.appendChild(textTag(doc, "lastSavePath", prefs.lastSavePath));
- p_misc.appendChild(textTag(doc, "autoCopy", prefs.autoCopy));
- }
- {
-@@ -1558,6 +1564,8 @@
- readBoolEntry(tag, "grabUrls", &prefs.grabUrls);
- readBoolEntry(tag, "smallChats", &prefs.smallChats);
- readBoolEntry(tag, "messageEvents", &prefs.messageEvents);
-+ readEntry(tag, "lastPath", &prefs.lastPath);
-+ readEntry(tag, "lastSavePath", &prefs.lastSavePath);
- readBoolEntry(tag, "autoCopy", &prefs.autoCopy);
- }
-
-diff -Naur psi-0.9.3-orig/src/ui_info.ui psi-0.9.3/src/ui_info.ui
---- psi-0.9.3-orig/src/ui_info.ui 2003-07-23 21:42:25.000000000 +0000
-+++ psi-0.9.3/src/ui_info.ui 2005-05-17 23:31:39.000000000 +0000
-@@ -1,4 +1,4 @@
--<!DOCTYPE UI><UI version="3.1" stdsetdef="1">
-+<!DOCTYPE UI><UI version="3.3" stdsetdef="1">
- <class>InfoUI</class>
- <widget class="QDialog">
- <property name="name">
-@@ -12,6 +12,12 @@
- <height>337</height>
- </rect>
- </property>
-+ <property name="minimumSize">
-+ <size>
-+ <width>129</width>
-+ <height>129</height>
-+ </size>
-+ </property>
- <property name="caption">
- <string>User Info</string>
- </property>
-@@ -39,6 +45,227 @@
- <attribute name="title">
- <string>General</string>
- </attribute>
-+ <grid>
-+ <property name="name">
-+ <cstring>unnamed</cstring>
-+ </property>
-+ <widget class="QLabel" row="0" column="0">
-+ <property name="name">
-+ <cstring>TextLabel1_2_2</cstring>
-+ </property>
-+ <property name="text">
-+ <string>Full Name</string>
-+ </property>
-+ </widget>
-+ <widget class="QLabel" row="3" column="0">
-+ <property name="name">
-+ <cstring>TextLabel1_3_2_2_2_2</cstring>
-+ </property>
-+ <property name="text">
-+ <string>Phone #</string>
-+ </property>
-+ </widget>
-+ <widget class="QLabel" row="4" column="0">
-+ <property name="name">
-+ <cstring>TextLabel1_2_3_2</cstring>
-+ </property>
-+ <property name="text">
-+ <string>Homepage</string>
-+ </property>
-+ </widget>
-+ <widget class="QLineEdit" row="4" column="1">
-+ <property name="name">
-+ <cstring>le_homepage</cstring>
-+ </property>
-+ </widget>
-+ <widget class="QLabel" row="5" column="0">
-+ <property name="name">
-+ <cstring>TextLabel1_2_2_2_2</cstring>
-+ </property>
-+ <property name="text">
-+ <string>E-Mail</string>
-+ </property>
-+ </widget>
-+ <widget class="QLabel" row="1" column="0">
-+ <property name="name">
-+ <cstring>TextLabel1_2</cstring>
-+ </property>
-+ <property name="text">
-+ <string>Nickname</string>
-+ </property>
-+ </widget>
-+ <widget class="QLineEdit" row="3" column="1">
-+ <property name="name">
-+ <cstring>le_phone</cstring>
-+ </property>
-+ </widget>
-+ <widget class="QLabel" row="2" column="0">
-+ <property name="name">
-+ <cstring>TextLabel1_3_2_3_2</cstring>
-+ </property>
-+ <property name="text">
-+ <string>Birthday</string>
-+ </property>
-+ </widget>
-+ <widget class="QLineEdit" row="2" column="1">
-+ <property name="name">
-+ <cstring>le_bday</cstring>
-+ </property>
-+ </widget>
-+ <widget class="QLineEdit" row="5" column="1">
-+ <property name="name">
-+ <cstring>le_email</cstring>
-+ </property>
-+ </widget>
-+ <widget class="QLineEdit" row="1" column="1">
-+ <property name="name">
-+ <cstring>le_nickname</cstring>
-+ </property>
-+ </widget>
-+ <widget class="QLineEdit" row="0" column="1" rowspan="1" colspan="2">
-+ <property name="name">
-+ <cstring>le_fullname</cstring>
-+ </property>
-+ </widget>
-+ <widget class="QLayoutWidget" row="1" column="2" rowspan="5" colspan="1">
-+ <property name="name">
-+ <cstring>ly_photo</cstring>
-+ </property>
-+ <vbox>
-+ <property name="name">
-+ <cstring>unnamed</cstring>
-+ </property>
-+ <widget class="QLabel">
-+ <property name="name">
-+ <cstring>label_photo</cstring>
-+ </property>
-+ <property name="sizePolicy">
-+ <sizepolicy>
-+ <hsizetype>1</hsizetype>
-+ <vsizetype>1</vsizetype>
-+ <horstretch>0</horstretch>
-+ <verstretch>0</verstretch>
-+ </sizepolicy>
-+ </property>
-+ <property name="minimumSize">
-+ <size>
-+ <width>129</width>
-+ <height>129</height>
-+ </size>
-+ </property>
-+ <property name="maximumSize">
-+ <size>
-+ <width>32767</width>
-+ <height>32767</height>
-+ </size>
-+ </property>
-+ <property name="frameShape">
-+ <enum>PopupPanel</enum>
-+ </property>
-+ <property name="frameShadow">
-+ <enum>Raised</enum>
-+ </property>
-+ <property name="lineWidth">
-+ <number>1</number>
-+ </property>
-+ <property name="margin">
-+ <number>2</number>
-+ </property>
-+ <property name="scaledContents">
-+ <bool>false</bool>
-+ </property>
-+ <property name="alignment">
-+ <set>AlignCenter</set>
-+ </property>
-+ </widget>
-+ <widget class="QLayoutWidget">
-+ <property name="name">
-+ <cstring>ly_photo_buttons</cstring>
-+ </property>
-+ <hbox>
-+ <property name="name">
-+ <cstring>unnamed</cstring>
-+ </property>
-+ <widget class="QPushButton">
-+ <property name="name">
-+ <cstring>pb_open</cstring>
-+ </property>
-+ <property name="sizePolicy">
-+ <sizepolicy>
-+ <hsizetype>1</hsizetype>
-+ <vsizetype>0</vsizetype>
-+ <horstretch>0</horstretch>
-+ <verstretch>0</verstretch>
-+ </sizepolicy>
-+ </property>
-+ <property name="text">
-+ <string>&amp;Open...</string>
-+ </property>
-+ <property name="accel">
-+ <string>Alt+O</string>
-+ </property>
-+ <property name="autoDefault">
-+ <bool>false</bool>
-+ </property>
-+ <property name="flat">
-+ <bool>false</bool>
-+ </property>
-+ </widget>
-+ <widget class="QPushButton">
-+ <property name="name">
-+ <cstring>pb_clear</cstring>
-+ </property>
-+ <property name="sizePolicy">
-+ <sizepolicy>
-+ <hsizetype>1</hsizetype>
-+ <vsizetype>0</vsizetype>
-+ <horstretch>0</horstretch>
-+ <verstretch>0</verstretch>
-+ </sizepolicy>
-+ </property>
-+ <property name="text">
-+ <string>&amp;Clear</string>
-+ </property>
-+ <property name="accel">
-+ <string>Alt+C</string>
-+ </property>
-+ <property name="autoDefault">
-+ <bool>false</bool>
-+ </property>
-+ <property name="flat">
-+ <bool>false</bool>
-+ </property>
-+ </widget>
-+ </hbox>
-+ </widget>
-+ </vbox>
-+ </widget>
-+ <spacer row="6" column="1">
-+ <property name="name">
-+ <cstring>spacer34</cstring>
-+ </property>
-+ <property name="orientation">
-+ <enum>Vertical</enum>
-+ </property>
-+ <property name="sizeType">
-+ <enum>Expanding</enum>
-+ </property>
-+ <property name="sizeHint">
-+ <size>
-+ <width>20</width>
-+ <height>60</height>
-+ </size>
-+ </property>
-+ </spacer>
-+ </grid>
-+ </widget>
-+ <widget class="QWidget">
-+ <property name="name">
-+ <cstring>tab</cstring>
-+ </property>
-+ <attribute name="title">
-+ <string>Work</string>
-+ </attribute>
- <vbox>
- <property name="name">
- <cstring>unnamed</cstring>
-@@ -51,7 +278,7 @@
- </property>
- <widget class="QLayoutWidget">
- <property name="name">
-- <cstring>Layout4</cstring>
-+ <cstring>Layout8</cstring>
- </property>
- <grid>
- <property name="name">
-@@ -63,89 +290,63 @@
- <property name="spacing">
- <number>6</number>
- </property>
-- <widget class="QLineEdit" row="1" column="1">
-- <property name="name">
-- <cstring>le_nickname</cstring>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="5" column="1">
-- <property name="name">
-- <cstring>le_email</cstring>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="7" column="1">
-- <property name="name">
-- <cstring>le_phone</cstring>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="6" column="1">
-+ <widget class="QLineEdit" row="2" column="1">
- <property name="name">
-- <cstring>le_homepage</cstring>
-+ <cstring>le_title</cstring>
- </property>
- </widget>
-- <widget class="QLabel" row="4" column="0">
-+ <widget class="QLabel" row="0" column="0">
- <property name="name">
-- <cstring>TextLabel1_3_2_3_2</cstring>
-+ <cstring>TextLabel1_2_2_2_3</cstring>
- </property>
- <property name="text">
-- <string>Birthday</string>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="4" column="1">
-- <property name="name">
-- <cstring>le_bday</cstring>
-+ <string>Company</string>
- </property>
- </widget>
-- <widget class="QLabel" row="6" column="0">
-+ <widget class="QLabel" row="2" column="0">
- <property name="name">
-- <cstring>TextLabel1_2_3_2</cstring>
-+ <cstring>TextLabel1_3_2_2_2_3_2</cstring>
- </property>
- <property name="text">
-- <string>Homepage</string>
-+ <string>Position</string>
- </property>
- </widget>
-- <widget class="QLabel" row="0" column="0">
-+ <widget class="QLineEdit" row="0" column="1">
- <property name="name">
-- <cstring>TextLabel1_2_2</cstring>
-- </property>
-- <property name="text">
-- <string>Full Name</string>
-+ <cstring>le_orgName</cstring>
- </property>
- </widget>
-- <widget class="QLabel" row="7" column="0">
-+ <widget class="QLabel" row="1" column="0">
- <property name="name">
-- <cstring>TextLabel1_3_2_2_2_2</cstring>
-+ <cstring>TextLabel1_2_3_3</cstring>
- </property>
- <property name="text">
-- <string>Phone #</string>
-+ <string>Department</string>
- </property>
- </widget>
-- <widget class="QLabel" row="5" column="0">
-+ <widget class="QLineEdit" row="1" column="1">
- <property name="name">
-- <cstring>TextLabel1_2_2_2_2</cstring>
-- </property>
-- <property name="text">
-- <string>E-Mail</string>
-+ <cstring>le_orgUnit</cstring>
- </property>
- </widget>
-- <widget class="QLineEdit" row="0" column="1">
-+ <widget class="QLineEdit" row="3" column="1">
- <property name="name">
-- <cstring>le_fullname</cstring>
-+ <cstring>le_role</cstring>
- </property>
- </widget>
-- <widget class="QLabel" row="1" column="0">
-+ <widget class="QLabel" row="3" column="0">
- <property name="name">
-- <cstring>TextLabel1_2</cstring>
-+ <cstring>TextLabel1_3_2_2_2_4</cstring>
- </property>
- <property name="text">
-- <string>Nickname</string>
-+ <string>Role</string>
- </property>
- </widget>
- </grid>
- </widget>
- <spacer>
- <property name="name">
-- <cstring>Spacer5</cstring>
-+ <cstring>Spacer7</cstring>
- </property>
- <property name="orientation">
- <enum>Vertical</enum>
-@@ -183,6 +384,18 @@
- <property name="name">
- <cstring>Layout5</cstring>
- </property>
-+ <property name="minimumSize">
-+ <size>
-+ <width>0</width>
-+ <height>0</height>
-+ </size>
-+ </property>
-+ <property name="maximumSize">
-+ <size>
-+ <width>32767</width>
-+ <height>32767</height>
-+ </size>
-+ </property>
- <grid>
- <property name="name">
- <cstring>unnamed</cstring>
-@@ -289,110 +502,6 @@
- <cstring>tab</cstring>
- </property>
- <attribute name="title">
-- <string>Work</string>
-- </attribute>
-- <vbox>
-- <property name="name">
-- <cstring>unnamed</cstring>
-- </property>
-- <property name="margin">
-- <number>11</number>
-- </property>
-- <property name="spacing">
-- <number>6</number>
-- </property>
-- <widget class="QLayoutWidget">
-- <property name="name">
-- <cstring>Layout8</cstring>
-- </property>
-- <grid>
-- <property name="name">
-- <cstring>unnamed</cstring>
-- </property>
-- <property name="margin">
-- <number>0</number>
-- </property>
-- <property name="spacing">
-- <number>6</number>
-- </property>
-- <widget class="QLineEdit" row="2" column="1">
-- <property name="name">
-- <cstring>le_title</cstring>
-- </property>
-- </widget>
-- <widget class="QLabel" row="0" column="0">
-- <property name="name">
-- <cstring>TextLabel1_2_2_2_3</cstring>
-- </property>
-- <property name="text">
-- <string>Company</string>
-- </property>
-- </widget>
-- <widget class="QLabel" row="2" column="0">
-- <property name="name">
-- <cstring>TextLabel1_3_2_2_2_3_2</cstring>
-- </property>
-- <property name="text">
-- <string>Position</string>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="0" column="1">
-- <property name="name">
-- <cstring>le_orgName</cstring>
-- </property>
-- </widget>
-- <widget class="QLabel" row="1" column="0">
-- <property name="name">
-- <cstring>TextLabel1_2_3_3</cstring>
-- </property>
-- <property name="text">
-- <string>Department</string>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="1" column="1">
-- <property name="name">
-- <cstring>le_orgUnit</cstring>
-- </property>
-- </widget>
-- <widget class="QLineEdit" row="3" column="1">
-- <property name="name">
-- <cstring>le_role</cstring>
-- </property>
-- </widget>
-- <widget class="QLabel" row="3" column="0">
-- <property name="name">
-- <cstring>TextLabel1_3_2_2_2_4</cstring>
-- </property>
-- <property name="text">
-- <string>Role</string>
-- </property>
-- </widget>
-- </grid>
-- </widget>
-- <spacer>
-- <property name="name">
-- <cstring>Spacer7</cstring>
-- </property>
-- <property name="orientation">
-- <enum>Vertical</enum>
-- </property>
-- <property name="sizeType">
-- <enum>Expanding</enum>
-- </property>
-- <property name="sizeHint">
-- <size>
-- <width>0</width>
-- <height>20</height>
-- </size>
-- </property>
-- </spacer>
-- </vbox>
-- </widget>
-- <widget class="QWidget">
-- <property name="name">
-- <cstring>tab</cstring>
-- </property>
-- <attribute name="title">
- <string>About</string>
- </attribute>
- <vbox>
-@@ -438,7 +547,7 @@
- </property>
- <property name="sizeHint">
- <size>
-- <width>149</width>
-+ <width>190</width>
- <height>16</height>
- </size>
- </property>
-@@ -508,8 +617,5 @@
- <layoutdefaults spacing="6" margin="11"/>
- <includehints>
- <includehint>busywidget.h</includehint>
-- <includehint>iconwidget.h</includehint>
-- <includehint>iconwidget.h</includehint>
-- <includehint>iconwidget.h</includehint>
- </includehints>
- </UI>
diff --git a/net-im/psi/files/vcard-photo-interface.patch.bz2 b/net-im/psi/files/vcard-photo-interface.patch.bz2
new file mode 100644
index 000000000000..98f22fdc660e
--- /dev/null
+++ b/net-im/psi/files/vcard-photo-interface.patch.bz2
Binary files differ
diff --git a/net-im/psi/psi-0.9.3-r4.ebuild b/net-im/psi/psi-0.9.3-r4.ebuild
index 8db9f3c6d525..3c069e42060e 100644
--- a/net-im/psi/psi-0.9.3-r4.ebuild
+++ b/net-im/psi/psi-0.9.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.9.3-r4.ebuild,v 1.15 2006/01/03 02:16:08 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.9.3-r4.ebuild,v 1.16 2006/02/01 12:25:38 humpback Exp $
inherit eutils qt3
@@ -176,7 +176,7 @@ src_unpack() {
epatch ${PATCHDIR}/checkboxes-sound-options.diff
epatch ${PATCHDIR}/psi-history_lug.patch
epatch ${PATCHDIR}/psi-cli-v2_gentoo.diff
- epatch ${FILESDIR}/vcard-photo-interface.patch
+ epatch ${FILESDIR}/vcard-photo-interface.patch.bz2
epatch ${PATCHDIR}/psi-history-deletion-bugfix.patch
# from http://tleilax.if.pw.edu.pl/~myak/