summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-12-27 11:47:01 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-12-27 11:47:01 +0000
commit85ef27b548a53fea82565d822f37fd4f49dc109b (patch)
treeb4f133ff013284ab30bea339730edd19be562b25 /net-im/psi/psi-0.9.2-r1.ebuild
parentstable on ppc: 74479 (Manifest recommit) (diff)
downloadgentoo-2-85ef27b548a53fea82565d822f37fd4f49dc109b.tar.gz
gentoo-2-85ef27b548a53fea82565d822f37fd4f49dc109b.tar.bz2
gentoo-2-85ef27b548a53fea82565d822f37fd4f49dc109b.zip
Some cleaning of the ebuild to use proper CXXFLAGS
Diffstat (limited to 'net-im/psi/psi-0.9.2-r1.ebuild')
-rw-r--r--net-im/psi/psi-0.9.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-im/psi/psi-0.9.2-r1.ebuild b/net-im/psi/psi-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..78482fd6c6b5
--- /dev/null
+++ b/net-im/psi/psi-0.9.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.9.2-r1.ebuild,v 1.1 2004/12/27 11:47:01 humpback Exp $
+
+IUSE="kde ssl crypt"
+RESTRICT="nomirror"
+QV="2.0"
+SRC_URI="mirror://sourceforge/psi/${P}.tar.bz2"
+DESCRIPTION="QT 3.x Jabber Client, with Licq-like interface"
+HOMEPAGE="http://psi.affinix.com"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~hppa ~amd64"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6c >=app-crypt/qca-tls-1.0 )
+ crypt? ( >=app-crypt/gnupg-1.2.2 )
+ >=x11-libs/qt-3"
+
+src_compile() {
+ use kde || myconf="${myconf} --disable-kde"
+ ./configure --prefix=/usr $myconf || die
+ # for CXXFLAGS from make.conf
+ qmake psi.pro \
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
+ QMAKE_RPATH=
+
+ addwrite "$HOME/.qt"
+ addwrite "$QTDIR/etc/settings"
+ emake || die
+}
+
+src_install() {
+ dodoc README TODO
+ make INSTALL_ROOT="${D}" install
+ #this away the docs will also be installed in the standard gentoo dir
+ for i in roster system emoticons; do
+ newdoc ${S}/iconsets/${i}/README README.${i}
+ done;
+ newdoc certs/README README.certs
+}