summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-04-08 17:41:28 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-04-08 17:41:28 +0000
commit9beb0e1a7c002487f80c7c960ac7ba29bc96272c (patch)
treecdd28f2662dbe5d28b9b16c375de9d482188338e /net-im/prosody
parentVersion bump and remove old. (diff)
downloadgentoo-2-9beb0e1a7c002487f80c7c960ac7ba29bc96272c.tar.gz
gentoo-2-9beb0e1a7c002487f80c7c960ac7ba29bc96272c.tar.bz2
gentoo-2-9beb0e1a7c002487f80c7c960ac7ba29bc96272c.zip
Version bump prosody to 0.8.0 (bug 352382).
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/ChangeLog8
-rw-r--r--net-im/prosody/files/prosody-0.8.0-cfg.lua.patch36
-rw-r--r--net-im/prosody/metadata.xml1
-rw-r--r--net-im/prosody/prosody-0.8.0.ebuild69
4 files changed, 113 insertions, 1 deletions
diff --git a/net-im/prosody/ChangeLog b/net-im/prosody/ChangeLog
index 444634d35119..aa8c87f403f9 100644
--- a/net-im/prosody/ChangeLog
+++ b/net-im/prosody/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/prosody
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.9 2011/03/22 20:59:44 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.10 2011/04/08 17:41:27 djc Exp $
+
+*prosody-0.8.0 (08 Apr 2011)
+
+ 08 Apr 2011; Dirkjan Ochtman <djc@gentoo.org> +prosody-0.8.0.ebuild,
+ +files/prosody-0.8.0-cfg.lua.patch, metadata.xml:
+ Version bump to 0.8.0 (bug 352382).
22 Mar 2011; Ulrich Mueller <ulm@gentoo.org> prosody-0.6.2.ebuild,
prosody-0.7.0.ebuild:
diff --git a/net-im/prosody/files/prosody-0.8.0-cfg.lua.patch b/net-im/prosody/files/prosody-0.8.0-cfg.lua.patch
new file mode 100644
index 000000000000..6444a6b2655a
--- /dev/null
+++ b/net-im/prosody/files/prosody-0.8.0-cfg.lua.patch
@@ -0,0 +1,36 @@
+diff --git a/prosody.cfg.lua.dist b/prosody.cfg.lua.dist
+index e513b11..08ebca6 100644
+--- a/prosody.cfg.lua.dist
++++ b/prosody.cfg.lua.dist
+@@ -105,6 +105,8 @@ ssl = {
+ -- default provider stores passwords in plaintext. If you do not trust your
+ -- server please see http://prosody.im/doc/modules/mod_auth_internal_hashed
+ -- for information about using the hashed backend.
++-- See http://prosody.im/doc/authentication for other possibilities including
++-- Cyrus SASL.
+
+ authentication = "internal_plain"
+
+@@ -123,12 +125,19 @@ authentication = "internal_plain"
+ -- Logging configuration
+ -- For advanced logging see http://prosody.im/doc/logging
+ log = {
+- info = "prosody.log"; -- Change 'info' to 'debug' for verbose logging
+- error = "prosody.err";
+- -- "*syslog"; -- Uncomment this for logging to syslog
++ info = "/var/log/jabber/prosody.log"; -- Change 'info' to 'debug' for verbose logging
++ error = "/var/log/jabber/prosody.err";
++ -- "*syslog"; -- Uncomment this for logging to syslog; needs mod_posix
+ -- "*console"; -- Log to the console, useful for debugging with daemonize=false
+ }
+
++-- Pidfile, used by prosodyctl and the init.d script
++pidfile = "/var/run/jabber/prosody.pid"
++
++-- User and group, used for daemon
++prosody_user = "jabber"
++prosody_group = "jabber"
++
+ ----------- Virtual hosts -----------
+ -- You need to add a VirtualHost entry for each domain you wish Prosody to serve.
+ -- Settings under each VirtualHost entry apply *only* to that host.
diff --git a/net-im/prosody/metadata.xml b/net-im/prosody/metadata.xml
index 9b63785cf637..9794ef0bd411 100644
--- a/net-im/prosody/metadata.xml
+++ b/net-im/prosody/metadata.xml
@@ -10,5 +10,6 @@
</maintainer>
<use>
<flag name="libevent">Use libevent for event handling</flag>
+ <flag name="sql">Require dev-lua/luadbi for SQL storage plugins</flag>
</use>
</pkgmetadata>
diff --git a/net-im/prosody/prosody-0.8.0.ebuild b/net-im/prosody/prosody-0.8.0.ebuild
new file mode 100644
index 000000000000..cc890988ed8d
--- /dev/null
+++ b/net-im/prosody/prosody-0.8.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.8.0.ebuild,v 1.1 2011/04/08 17:41:27 djc Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 '')
+DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua."
+HOMEPAGE="http://prosody.im/"
+SRC_URI="http://prosody.im/downloads/source/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libevent ssl sql"
+
+DEPEND="net-im/jabber-base
+ >=dev-lang/lua-5.1
+ >=net-dns/libidn-1.1
+ >=dev-libs/openssl-0.9.8"
+RDEPEND="${DEPEND}
+ dev-lua/luasocket
+ ssl? ( dev-lua/luasec )
+ dev-lua/luaexpat
+ dev-lua/luafilesystem
+ sql? ( >=dev-lua/luadbi-0.5 )
+ libevent? ( dev-lua/luaevent )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+JABBER_ETC="/etc/jabber"
+JABBER_SPOOL="/var/spool/jabber"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-${PV}-cfg.lua.patch"
+ sed -i "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = \$(DESTDIR)\$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = \$(PREFIX)/$(get_libdir)/!" Makefile
+ sed -i "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = \$(PREFIX)/$(get_libdir)/!" Makefile
+}
+
+src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
+ ./configure --prefix="/usr" \
+ --sysconfdir="${JABBER_ETC}" \
+ --datadir="${JABBER_SPOOL}" \
+ --with-lua-lib=/usr/$(get_libdir)/lua \
+ --c-compiler="$(tc-getCC)" --linker="$(tc-getCC)" \
+ --cflags="${CFLAGS} -Wall -fPIC" \
+ --ldflags="${LDFLAGS} -shared" \
+ --require-config || die "configure failed"
+}
+
+src_install() {
+ DESTDIR="${D}" emake install || die "make failed"
+ newinitd "${FILESDIR}/${PN}".initd ${PN}
+}
+
+src_test() {
+ cd tests
+ ./run_tests.sh
+}
+
+pkg_postinst() {
+ elog "Please note that the module 'console' has been renamed to 'admin_telnet'."
+}