summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-05-05 13:47:53 +0000
committerDon Seiler <rizzo@gentoo.org>2005-05-05 13:47:53 +0000
commit53404436a07e80c8f1b9019429d6b78d7486495d (patch)
treee09177628e60505ff9870b827915c9e53d2526d7 /net-im/pork/pork-0.99.8.1.ebuild
parentnew upstream version. marked 1.4.4 stable on amd64, ppc and x86 (diff)
downloadgentoo-2-53404436a07e80c8f1b9019429d6b78d7486495d.tar.gz
gentoo-2-53404436a07e80c8f1b9019429d6b78d7486495d.tar.bz2
gentoo-2-53404436a07e80c8f1b9019429d6b78d7486495d.zip
Version bump, closes bug 91505
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'net-im/pork/pork-0.99.8.1.ebuild')
-rw-r--r--net-im/pork/pork-0.99.8.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/pork/pork-0.99.8.1.ebuild b/net-im/pork/pork-0.99.8.1.ebuild
new file mode 100644
index 000000000000..077fbdd5cc40
--- /dev/null
+++ b/net-im/pork/pork-0.99.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pork/pork-0.99.8.1.ebuild,v 1.1 2005/05/05 13:47:53 rizzo Exp $
+
+DESCRIPTION="Console based AIM client that looks like ircII"
+HOMEPAGE="http://dev.ojnk.net/"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc ~amd64"
+IUSE="perl"
+
+DEPEND="perl? ( dev-lang/perl )
+ sys-libs/ncurses"
+
+src_compile() {
+ local myconf=""
+ use perl || myconf="${myconf} --disable-perl"
+ einfo "Configure options: ${myconf}"
+ econf ${myconf} || die "econf failed"
+ emake
+}
+
+src_install() {
+ einstall
+
+ doman doc/pork.1
+ insinto /usr/share/pork/examples
+ doins examples/blist.txt
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README STYLE TODO QUICK_START
+}
+
+pkg_postinst() {
+ einfo "Be aware that the syntax for IRC connections has"
+ einfo "changed. Read ${HOMEPAGE}/stuff/pork.news"
+ einfo "for details."
+}
+