summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-20 20:25:41 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-20 20:25:41 +0000
commitf378a38870d345a2158d893219638ab8245609e5 (patch)
tree281cef5e1ed96b4bf2936a9ed4bf60d22a09c229 /net-im/pidgin
parentAdd "test" USE flag and src_test(). (diff)
downloadgentoo-2-f378a38870d345a2158d893219638ab8245609e5.tar.gz
gentoo-2-f378a38870d345a2158d893219638ab8245609e5.tar.bz2
gentoo-2-f378a38870d345a2158d893219638ab8245609e5.zip
Small cleanup: use += syntax, SLOT deps and terse DYNAMIC_PRPLS handling. bonjour -> zeroconf USE flag change as discussed on -dev. Dependencies: up some versions to match configure.ac, some depend on gtk. Back startup-notification and xscreensaver USE flags. Fixed automagic dep on farsight, bug #295810, thank Alexis Ballier for report. Fixes dep on perl, bug #269741, thank Maksim 'max_posedon' Melnikau for report.
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/ChangeLog13
-rw-r--r--net-im/pidgin/metadata.xml16
-rw-r--r--net-im/pidgin/pidgin-2.6.4-r1.ebuild164
3 files changed, 182 insertions, 11 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 9d03e8c2d473..09726051a252 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.140 2009/10/25 17:00:52 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.141 2009/12/20 20:25:41 pva Exp $
+
+*pidgin-2.6.4-r1 (20 Dec 2009)
+
+ 20 Dec 2009; Peter Volkov <pva@gentoo.org> +pidgin-2.6.4-r1.ebuild,
+ metadata.xml:
+ Small cleanup: use += syntax, SLOT deps and terse DYNAMIC_PRPLS handling.
+ bonjour -> zeroconf USE flag change as discussed on -dev. Dependencies: up
+ some versions to match configure.ac, some depend on gtk. Back
+ startup-notification and xscreensaver USE flags. Fixed automagic dep on
+ farsight, bug #295810, thank Alexis Ballier for report. Fixes dep on perl,
+ bug #269741, thank Maksim 'max_posedon' Melnikau for report.
25 Oct 2009; nixnut <nixnut@gentoo.org> pidgin-2.6.3.ebuild:
ppc stable #289298
diff --git a/net-im/pidgin/metadata.xml b/net-im/pidgin/metadata.xml
index 4d414b6bfbb5..e5295ee3cd10 100644
--- a/net-im/pidgin/metadata.xml
+++ b/net-im/pidgin/metadata.xml
@@ -6,16 +6,12 @@
Pidgin is an instant messaging program for Windows, Linux, BSD, and other Unixes. You can talk to your friends using AIM, ICQ, Jabber/XMPP, MSN Messenger, Yahoo!, Bonjour, Gadu-Gadu, IRC, Novell GroupWise Messenger, QQ, Lotus Sametime, SILC, SIMPLE, and Zephyr.
</longdescription>
<use>
- <flag name='bonjour'>Enable bonjour support</flag>
- <flag name='gadu'>Enable Gadu Gadu protocol support.</flag>
- <flag name='groupwise'>Enable Novell Groupwise protocol support.</flag>
- <flag name='meanwhile'>Enable meanwhile support for Sametime
- protocol.
- </flag>
- <flag name='prediction'>Enable Contact Availability Prediction
- plugin.
- </flag>
- <flag name='qq'>Enable QQ protocol support.</flag>
+ <flag name='bonjour'>Enable bonjour (zeroconf) support</flag>
+ <flag name='gadu'>Enable Gadu Gadu protocol support</flag>
+ <flag name='groupwise'>Enable Novell Groupwise protocol support</flag>
+ <flag name='meanwhile'>Enable meanwhile support for Sametime protocol</flag>
+ <flag name='prediction'>Enable Contact Availability Prediction plugin</flag>
+ <flag name='qq'>Enable QQ protocol support</flag>
<flag name='silc'>Enable SILC protocol support</flag>
<flag name='zephyr'>Enable Zephyr protocol support</flag>
</use>
diff --git a/net-im/pidgin/pidgin-2.6.4-r1.ebuild b/net-im/pidgin/pidgin-2.6.4-r1.ebuild
new file mode 100644
index 000000000000..330cb058e8f6
--- /dev/null
+++ b/net-im/pidgin/pidgin-2.6.4-r1.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.6.4-r1.ebuild,v 1.1 2009/12/20 20:25:41 pva Exp $
+
+EAPI=2
+
+GENTOO_DEPEND_ON_PERL=no
+inherit flag-o-matic eutils toolchain-funcs multilib perl-app gnome2
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://pidgin.im/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86"
+IUSE="dbus debug doc eds gadu gnutls +gstreamer idn meanwhile networkmanager"
+IUSE+=" nls perl silc tcl tk spell qq gadu +gtk sasl startup-notification"
+IUSE+=" ncurses groupwise prediction xscreensaver zephyr zeroconf" # mono"
+
+RDEPEND="
+ >=dev-libs/glib-2.4
+ >=dev-libs/libxml2-2.6.18
+ ncurses? ( sys-libs/ncurses[unicode] )
+ gtk? (
+ >=x11-libs/gtk+-2.4:2
+ x11-libs/libSM
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ startup-notification? ( >=x11-libs/startup-notification-0.5 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ eds? ( gnome-extra/evolution-data-server )
+ prediction? ( >=dev-db/sqlite-3.3:3 ) )
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ >=net-libs/farsight2-0.0.14
+ media-plugins/gst-plugins-meta
+ media-plugins/gst-plugins-gconf )
+ zeroconf? ( net-dns/avahi )
+ dbus? ( >=dev-libs/dbus-glib-0.71
+ >=dev-python/dbus-python-0.71
+ >=sys-apps/dbus-0.90
+ >=dev-lang/python-2.4 )
+ perl? ( >=dev-lang/perl-5.8.2-r1[-build] )
+ gadu? ( net-libs/libgadu[-ssl] )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.11 )
+ meanwhile? ( net-libs/meanwhile )
+ silc? ( >=net-im/silc-toolkit-1.0.1 )
+ zephyr? ( >=app-crypt/mit-krb5-1.3.6-r1[krb4] )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ networkmanager? ( net-misc/networkmanager )
+ idn? ( net-dns/libidn )"
+ # Mono support crashes pidgin
+ #mono? ( dev-lang/mono )"
+
+DEPEND="$RDEPEND
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ dev-util/intltool
+ gtk? ( x11-proto/scrnsaverproto )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+# Enable Default protocols
+DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
+
+# List of plugins
+# app-accessibility/pidgin-festival
+# net-im/librvp
+# x11-plugins/guifications
+# x11-plugins/pidgin-encryption
+# x11-plugins/pidgin-extprefs
+# x11-plugins/pidgin-hotkeys
+# x11-plugins/pidgin-latex
+# x11-plugins/pidgintex
+# x11-plugins/pidgin-libnotify
+# x11-plugins/pidgin-otr
+# x11-plugins/pidgin-rhythmbox
+# x11-plugins/purple-plugin_pack
+# x11-themes/pidgin-smileys
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ einfo
+ elog "You did not pick the ncurses or gtk use flags, only libpurple"
+ elog "will be built."
+ einfo
+ fi
+}
+
+src_prepare() {
+ intltoolize --automake --copy --force
+}
+
+src_configure() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ local myconf
+
+ if use gadu; then
+ DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
+ myconf="${myconf} --with-gadu-includes=."
+ myconf="${myconf} --with-gadu-libs=."
+ fi
+
+ use silc && DYNAMIC_PRPLS+=",silc"
+ use qq && DYNAMIC_PRPLS+=",qq"
+ use meanwhile && DYNAMIC_PRPLS+=",sametime"
+ use zeroconf && DYNAMIC_PRPLS+=",bonjour"
+ use groupwise && DYNAMIC_PRPLS+=",novell"
+ use zephyr && DYNAMIC_PRPLS+=",zephyr"
+
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no --enable-gnutls=yes"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
+ fi
+
+ econf \
+ $(use_enable ncurses consoleui) \
+ $(use_enable nls) \
+ $(use_enable gtk gtkui) \
+ $(use_enable gtk sm) \
+ $(use gtk && use_enable startup-notification) \
+ $(use gtk && use_enable xscreensaver screensaver) \
+ $(use gtk && use_enable prediction cap) \
+ $(use gtk && use_enable eds gevolution) \
+ $(use gtk && use_enable spell gtkspell) \
+ $(use_enable perl) \
+ $(use_enable tk) \
+ $(use_enable tcl) \
+ $(use_enable debug) \
+ $(use_enable dbus) \
+ $(use_enable meanwhile) \
+ $(use_enable gstreamer) \
+ $(use_enable gstreamer farsight) \
+ $(use_enable gstreamer vv) \
+ $(use_enable sasl cyrus-sasl ) \
+ $(use_enable doc doxygen) \
+ $(use_enable networkmanager nm) \
+ $(use_with zephyr krb4) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable idn) \
+ "--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
+ --disable-mono \
+ --x-includes=/usr/include/X11 \
+ ${myconf}
+ #$(use_enable mono) \
+}
+
+src_install() {
+ gnome2_src_install
+ use perl && fixlocalpod
+ dodoc AUTHORS HACKING INSTALL NEWS README ChangeLog
+}