summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-06-03 15:02:53 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-06-03 15:02:53 +0000
commit060c1f12b5ab6928240bc644a71dca40267f2d48 (patch)
tree83da65020b7b5a3b29ea6e692ae8f7735b6224c0 /net-im/naim/naim-0.11.6.7.ebuild
parentarm KEYWORDS (Manifest recommit) (diff)
downloadgentoo-2-060c1f12b5ab6928240bc644a71dca40267f2d48.tar.gz
gentoo-2-060c1f12b5ab6928240bc644a71dca40267f2d48.tar.bz2
gentoo-2-060c1f12b5ab6928240bc644a71dca40267f2d48.zip
Version Bump
Diffstat (limited to 'net-im/naim/naim-0.11.6.7.ebuild')
-rw-r--r--net-im/naim/naim-0.11.6.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-im/naim/naim-0.11.6.7.ebuild b/net-im/naim/naim-0.11.6.7.ebuild
new file mode 100644
index 000000000000..9d9bb6a36ac5
--- /dev/null
+++ b/net-im/naim/naim-0.11.6.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.6.7.ebuild,v 1.1 2004/06/03 15:02:53 humpback Exp $
+
+
+DESCRIPTION="An ncurses based AOL Instant Messenger"
+HOMEPAGE="http://naim.n.ml.org"
+SRC_URI="http://shell.n.ml.org/n/naim/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_compile() {
+ # --enable-profile
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf \
+ --with-pkgdocdir=/usr/share/doc/${PF} \
+ --enable-detach \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS FAQ BUGS README NEWS ChangeLog doc/*.hlp
+}