summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-03 06:59:19 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-03 06:59:19 +0000
commit014513e56ffc73076ae07999b3a22d5e9f706d95 (patch)
tree5b2c862934eca4849e632a3920aa1f09d0776a79 /net-im/minbif
parentFix build with GCC 4.7 (bug #430386). (diff)
downloadgentoo-2-014513e56ffc73076ae07999b3a22d5e9f706d95.tar.gz
gentoo-2-014513e56ffc73076ae07999b3a22d5e9f706d95.tar.bz2
gentoo-2-014513e56ffc73076ae07999b3a22d5e9f706d95.zip
Fix build with GCC 4.7 (bug #440000).
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'net-im/minbif')
-rw-r--r--net-im/minbif/ChangeLog7
-rw-r--r--net-im/minbif/files/minbif-1.0.5-gcc47.patch20
2 files changed, 15 insertions, 12 deletions
diff --git a/net-im/minbif/ChangeLog b/net-im/minbif/ChangeLog
index 20c18fe1cc43..db735e139efc 100644
--- a/net-im/minbif/ChangeLog
+++ b/net-im/minbif/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-im/minbif
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/minbif/ChangeLog,v 1.13 2012/08/21 08:41:43 johu Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/minbif/ChangeLog,v 1.14 2013/03/03 06:59:19 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> files/minbif-1.0.5-gcc47.patch:
+ Fix build with GCC 4.7 (bug #440000).
21 Aug 2012; Johannes Huber <johu@gentoo.org> minbif-1.0.5.ebuild:
Stable for x86, wrt bug #428058
diff --git a/net-im/minbif/files/minbif-1.0.5-gcc47.patch b/net-im/minbif/files/minbif-1.0.5-gcc47.patch
index dc49878ea1e3..8566406a318f 100644
--- a/net-im/minbif/files/minbif-1.0.5-gcc47.patch
+++ b/net-im/minbif/files/minbif-1.0.5-gcc47.patch
@@ -4,8 +4,6 @@ Date: Tue May 8 16:46:35 2012 +0200
fixes for gcc 4.7
-diff --git a/src/im/account.cpp b/src/im/account.cpp
-index f155334..21baa5f 100644
--- a/src/im/account.cpp
+++ b/src/im/account.cpp
@@ -18,6 +18,7 @@
@@ -16,8 +14,6 @@ index f155334..21baa5f 100644
#ifdef HAVE_IMLIB
#include <Imlib2.h>
#endif /* HAVE_IMLIB */
-diff --git a/src/im/request.cpp b/src/im/request.cpp
-index e72cbc9..a247e3b 100644
--- a/src/im/request.cpp
+++ b/src/im/request.cpp
@@ -18,6 +18,7 @@
@@ -28,8 +24,6 @@ index e72cbc9..a247e3b 100644
#include "request.h"
#include "buddy.h"
-diff --git a/src/irc/dcc.cpp b/src/irc/dcc.cpp
-index 6d05034..231122c 100644
--- a/src/irc/dcc.cpp
+++ b/src/irc/dcc.cpp
@@ -23,6 +23,7 @@
@@ -40,8 +34,6 @@ index 6d05034..231122c 100644
#include "dcc.h"
#include "nick.h"
-diff --git a/src/irc/irc.cpp b/src/irc/irc.cpp
-index 5d28acb..116d9db 100644
--- a/src/irc/irc.cpp
+++ b/src/irc/irc.cpp
@@ -246,7 +246,7 @@ Nick* IRC::getNick(string nickname, bool case_sensitive) const
@@ -62,8 +54,6 @@ index 5d28acb..116d9db 100644
for(it = users.begin();
it != users.end() && (!(n = dynamic_cast<ConvNick*>(it->second)) || n->getConversation() != conv);
++it)
-diff --git a/src/server_poll/inetd.cpp b/src/server_poll/inetd.cpp
-index 4f3023d..f747e74 100644
--- a/src/server_poll/inetd.cpp
+++ b/src/server_poll/inetd.cpp
@@ -18,6 +18,7 @@
@@ -74,3 +64,13 @@ index 4f3023d..f747e74 100644
#include "inetd.h"
#include "irc/irc.h"
+--- a/src/sockwrap/sockwrap.cpp
++++ b/src/sockwrap/sockwrap.cpp
+@@ -22,6 +22,7 @@
+ # include "sockwrap_tls.h"
+ #endif
+ #include "core/util.h"
++#include <unistd.h>
+
+ namespace sock
+ {