summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Pasternak <reb@gentoo.org>2006-07-01 11:42:12 +0000
committerKarol Pasternak <reb@gentoo.org>2006-07-01 11:42:12 +0000
commit33075602561b6ef8a36c04f5585c1a347872b195 (patch)
tree284bad08743d1345b207b67bfe0c41e0dfa5308b /net-im/mcabber/mcabber-0.7.8.ebuild
parentRename tetex USE flag to doc, thanks to nattfodd for reporting. Minor ebuild ... (diff)
downloadgentoo-2-33075602561b6ef8a36c04f5585c1a347872b195.tar.gz
gentoo-2-33075602561b6ef8a36c04f5585c1a347872b195.tar.bz2
gentoo-2-33075602561b6ef8a36c04f5585c1a347872b195.zip
New version (0.7.8)
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'net-im/mcabber/mcabber-0.7.8.ebuild')
-rw-r--r--net-im/mcabber/mcabber-0.7.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-im/mcabber/mcabber-0.7.8.ebuild b/net-im/mcabber/mcabber-0.7.8.ebuild
new file mode 100644
index 000000000000..1e3844f67fe3
--- /dev/null
+++ b/net-im/mcabber/mcabber-0.7.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.7.8.ebuild,v 1.1 2006/07/01 11:42:12 reb Exp $
+
+DESCRIPTION="A small Jabber console client that includes features such as SSL
+support, MUC (Multi-User Chat) support, history logging, commands completion,
+and external actions triggers."
+
+HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
+
+SRC_URI="http://www.lilotux.net/~mikael/mcabber/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
+ >=dev-libs/glib-2.0.0"
+
+src_compile() {
+ econf \
+ $(use_with ssl) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc ${S}/mcabberrc.example
+}
+
+pkg_postinst() {
+ einfo "MCabber requires you to create a configuration file in your home directory."
+ einfo "A template of such file was installed as part of the documentation for this software."
+ einfo "This file is intended to be self-documenting."
+ einfo "See the CONFIGURATION FILE and FILES sections of mcabber(1) for more information."
+}