summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 08:38:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 08:38:21 +0000
commit7613214acfbdaa55a3c085ce3dc4974a3de57d7e (patch)
tree043cf9953bbb7ee7ad192eb5e2788f8e62cc5377 /net-im/linpopup
parentExplicitly set empty RDEPEND (diff)
downloadgentoo-2-7613214acfbdaa55a3c085ce3dc4974a3de57d7e.tar.gz
gentoo-2-7613214acfbdaa55a3c085ce3dc4974a3de57d7e.tar.bz2
gentoo-2-7613214acfbdaa55a3c085ce3dc4974a3de57d7e.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im/linpopup')
-rw-r--r--net-im/linpopup/ChangeLog8
-rw-r--r--net-im/linpopup/files/2.1.0-link.patch23
-rw-r--r--net-im/linpopup/linpopup-2.1.0.ebuild52
3 files changed, 82 insertions, 1 deletions
diff --git a/net-im/linpopup/ChangeLog b/net-im/linpopup/ChangeLog
index 0257f8b93564..0bd6b8125c65 100644
--- a/net-im/linpopup/ChangeLog
+++ b/net-im/linpopup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/linpopup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/linpopup/ChangeLog,v 1.16 2009/08/05 07:12:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/linpopup/ChangeLog,v 1.17 2009/08/05 08:38:21 ssuominen Exp $
+
+*linpopup-2.1.0 (05 Aug 2009)
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +files/2.1.0-link.patch, +linpopup-2.1.0.ebuild:
+ Version bump.
05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+files/2.0.4-link.patch, linpopup-2.0.4-r1.ebuild,
diff --git a/net-im/linpopup/files/2.1.0-link.patch b/net-im/linpopup/files/2.1.0-link.patch
new file mode 100644
index 000000000000..5c123ebbe50c
--- /dev/null
+++ b/net-im/linpopup/files/2.1.0-link.patch
@@ -0,0 +1,23 @@
+diff -ur linpopup-2.1.0.orig/Makefile.am linpopup-2.1.0/Makefile.am
+--- linpopup-2.1.0.orig/Makefile.am 2007-09-09 22:50:05.000000000 +0300
++++ linpopup-2.1.0/Makefile.am 2009-08-05 11:35:06.000000000 +0300
+@@ -21,6 +21,5 @@
+ $(mkinstalldirs) $(DATA_FILE); \
+ rm -fR $(DATA_FILE); \
+ touch $(DATA_FILE); \
+- chgrp nobody $(DATA_FILE); \
+- chmod 0666 $(DATA_FILE); \
++ chmod 0600 $(DATA_FILE); \
+ fi
+diff -ur linpopup-2.1.0.orig/src/Makefile.am linpopup-2.1.0/src/Makefile.am
+--- linpopup-2.1.0.orig/src/Makefile.am 2007-09-09 22:39:00.000000000 +0300
++++ linpopup-2.1.0/src/Makefile.am 2009-08-05 11:35:06.000000000 +0300
+@@ -39,8 +39,6 @@
+
+ install-data-local:
+ @$(NORMAL_INSTALL)
+- ln -fs $(PACKAGE) $(DESTDIR)$(bindir)/$(PROGNAME_LNK)
+
+ uninstall-local:
+ @$(NORMAL_UNINSTALL)
+- rm -f $(DESTDIR)$(bindir)/$(PROGNAME_LNK)
diff --git a/net-im/linpopup/linpopup-2.1.0.ebuild b/net-im/linpopup/linpopup-2.1.0.ebuild
new file mode 100644
index 000000000000..32df1cfd4619
--- /dev/null
+++ b/net-im/linpopup/linpopup-2.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linpopup/linpopup-2.1.0.ebuild,v 1.1 2009/08/05 08:38:21 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="GTK+ port of the LinPopUp messaging client for Samba (including Samba 3)"
+HOMEPAGE="http://linpopup2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linpopup2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-link.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO
+ dosym linpopup /usr/bin/LinPopUp || die "dosym failed"
+ newicon pixmaps/icon_256.xpm ${PN}.xpm
+ make_desktop_entry ${PN} LinPopUp ${PN}
+}
+
+pkg_postinst() {
+ echo
+ elog "To be able to receive messages that are sent to you, you will need to"
+ elog "edit your /etc/samba/smb.conf file."
+ elog
+ elog "Add this line to the [global settings] section:"
+ elog
+ elog " message command = /usr/bin/linpopup \"%f\" \"%m\" %s; rm %s"
+ elog
+ elog "PLEASE NOTE that \"%f\" is not the same thing as %f , '%f' or %f"
+ elog "and take care to enter \"%f\" \"%m\" %s exactly as shown above."
+ elog
+ elog "For more information, please refer to the documentation, found in"
+ elog "/usr/share/doc/${P}/"
+ echo
+}