summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-09-28 15:03:35 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-09-28 15:03:35 +0000
commit134749175da3b0a13d6005fb3e6521178618f727 (patch)
tree536f7429b58bf2489f5d6bb8b65332eb64979db9 /net-im/licq
parentStable for HPPA too. (diff)
downloadgentoo-2-134749175da3b0a13d6005fb3e6521178618f727.tar.gz
gentoo-2-134749175da3b0a13d6005fb3e6521178618f727.tar.bz2
gentoo-2-134749175da3b0a13d6005fb3e6521178618f727.zip
Fixed bug #484706 and #486126. Took over maintenance
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/ChangeLog11
-rw-r--r--net-im/licq/files/licq-1.8.0-doxygen.patch43
-rw-r--r--net-im/licq/files/licq-1.8.0-socks5.patch40
-rw-r--r--net-im/licq/licq-1.8.0-r2.ebuild (renamed from net-im/licq/licq-1.7.1.ebuild)19
-rw-r--r--net-im/licq/metadata.xml4
5 files changed, 105 insertions, 12 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index d8b753ad0e41..4e70ffe2284b 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-im/licq
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.126 2013/09/13 13:36:47 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.127 2013/09/28 15:03:35 polynomial-c Exp $
+
+*licq-1.8.0-r2 (28 Sep 2013)
+
+ 28 Sep 2013; Lars Wendler <polynomial-c@gentoo.org> -licq-1.7.1.ebuild,
+ +licq-1.8.0-r2.ebuild, +files/licq-1.8.0-doxygen.patch,
+ +files/licq-1.8.0-socks5.patch, metadata.xml:
+ Fixed compilation with socks5 support (bug #484706) and automagic dependency
+ on doxygen (bug #486126). Thanks to Ben Kohler for providing the doxygen
+ patches. Officially took over maintenance.
13 Sep 2013; Lars Wendler <polynomial-c@gentoo.org> licq-1.7.1.ebuild,
licq-1.8.0-r1.ebuild:
diff --git a/net-im/licq/files/licq-1.8.0-doxygen.patch b/net-im/licq/files/licq-1.8.0-doxygen.patch
new file mode 100644
index 000000000000..12117c96a4a7
--- /dev/null
+++ b/net-im/licq/files/licq-1.8.0-doxygen.patch
@@ -0,0 +1,43 @@
+From b05d42fda3da5d1b42bd89feb3b49516ce7d85b3 Mon Sep 17 00:00:00 2001
+From: Anders Olofsson <flynd@licq.org>
+Date: Fri, 27 Sep 2013 21:55:54 +0200
+Subject: [PATCH] core: Make Doxygen usage optional
+
+Patch by Ben Kohler to solve Gentoo bug 486126.
+---
+ licq/CMakeLists.txt | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/licq/CMakeLists.txt b/licq/CMakeLists.txt
+index 9e84538..f90d9d5 100644
+--- a/licq/CMakeLists.txt
++++ b/licq/CMakeLists.txt
+@@ -12,6 +12,7 @@ include(CheckFileOffsetBits)
+
+ # Options
+ option(ENABLE_NLS "Enable translation of program messages" ON)
++option(USE_DOXYGEN "Build docs via doxygen" OFF)
+ option(USE_FIFO "Use Licq FIFO" ON)
+ option(USE_HEBREW "Include support for hebrew reverse string" OFF)
+ option(USE_OPENSSL "Enable secure communication channels" ON)
+@@ -142,7 +143,7 @@ include(cmake/LicqVersion.cmake)
+ # Doxygen is option
+ find_package(Doxygen)
+
+-if (DOXYGEN_FOUND)
++if (USE_DOXYGEN)
+ if (NOT DOXYGEN_DOT_FOUND)
+ message(SEND_ERROR "Need the dot program to build documentation")
+ endif (NOT DOXYGEN_DOT_FOUND)
+@@ -158,7 +159,7 @@ if (DOXYGEN_FOUND)
+ DEPENDS ${DOXY_CONFIG}
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMENT "Generating doxygen documentation" VERBATIM)
+-endif (DOXYGEN_FOUND)
++endif (USE_DOXYGEN)
+
+ # make uninstall (file added to top binary dir to work with build_all)
+ configure_file(
+--
+1.8.4
+
diff --git a/net-im/licq/files/licq-1.8.0-socks5.patch b/net-im/licq/files/licq-1.8.0-socks5.patch
new file mode 100644
index 000000000000..98cdad87aad4
--- /dev/null
+++ b/net-im/licq/files/licq-1.8.0-socks5.patch
@@ -0,0 +1,40 @@
+From 6b5f463697739be42948a052a03cc706f06c2150 Mon Sep 17 00:00:00 2001
+From: Anders Olofsson <flynd@licq.org>
+Date: Thu, 19 Sep 2013 20:33:16 +0200
+Subject: [PATCH] core: Workaround defines in socks.h
+
+socks.h defines send to Rsend which also affected the name of
+TCPSocket::send().
+
+Fixes Gentoo bug 484706
+---
+ licq/src/socket.cpp | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/licq/src/socket.cpp b/licq/src/socket.cpp
+index 9d4cb3f..c06c266 100644
+--- a/licq/src/socket.cpp
++++ b/licq/src/socket.cpp
+@@ -49,6 +49,10 @@
+ extern "C" {
+ #include <socks.h>
+ }
++#define socket_send Rsend
++#undef send
++#else
++#define socket_send send
+ #endif // SOCKS5
+
+ #ifdef SOCKS5_OPTLEN
+@@ -477,7 +481,7 @@ bool INetSocket::send(Buffer& buf)
+ char* dataPos = buf.getDataStart();
+ while (bytesLeft > 0)
+ {
+- ssize_t bytesSent = ::send(myDescriptor, dataPos, bytesLeft, 0);
++ ssize_t bytesSent = ::socket_send(myDescriptor, dataPos, bytesLeft, 0);
+ if (bytesSent < 0)
+ {
+ if (errno == EINTR)
+--
+1.8.4
+
diff --git a/net-im/licq/licq-1.7.1.ebuild b/net-im/licq/licq-1.8.0-r2.ebuild
index 5f99198c4f44..34df9cb357dd 100644
--- a/net-im/licq/licq-1.7.1.ebuild
+++ b/net-im/licq/licq-1.8.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.7.1.ebuild,v 1.3 2013/09/13 13:36:47 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.8.0-r2.ebuild,v 1.1 2013/09/28 15:03:35 polynomial-c Exp $
EAPI=5
@@ -13,29 +13,25 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc linguas_he nls socks5 ssl xosd aosd jabber qt4 msn ncurses"
+IUSE="debug doc linguas_he nls socks5 ssl xosd aosd jabber qt4 msn"
RDEPEND=">=app-crypt/gpgme-1
jabber? ( net-libs/gloox )
qt4? ( dev-qt/qtgui:4 )
socks5? ( net-proxy/dante )
ssl? ( >=dev-libs/openssl-0.9.5a )
- ncurses? (
- sys-libs/ncurses
- dev-libs/cdk
- )
xosd? ( x11-libs/xosd )
aosd? ( x11-libs/libaosd )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
+ doc? ( app-doc/doxygen[dot] )
nls? ( sys-devel/gettext )
dev-libs/boost"
src_prepare() {
- #epatch "${FILESDIR}"/${PN}-1.5.1-find-libcdk.patch
+ epatch "${FILESDIR}"/${P}-socks5.patch \
+ "${FILESDIR}"/${P}-doxygen.patch
- local licq_plugins="auto-reply rms"
- use ncurses && licq_plugins+=" console"
+ local licq_plugins="auto-reply icq rms"
use msn && licq_plugins+=" msn"
use xosd && licq_plugins+=" osd"
use aosd && licq_plugins+=" aosd"
@@ -58,10 +54,11 @@ pkg_setup() {
src_configure() {
local myopts="-DCMAKE_BUILD_TYPE=$(use debug && echo 'Debug' || echo 'Release')"
mycmakeargs="$myopts
+ $(cmake-utils_use doc USE_DOXYGEN)
$(cmake-utils_use linguas_he USE_HEBREW)
+ $(cmake-utils_use nls ENABLE_NLS)
$(cmake-utils_use socks5 USE_SOCKS5)
$(cmake-utils_use ssl USE_OPENSSL)
- $(cmake-utils_use nls ENABLE_NLS)
-DUSE_FIFO=ON
-DBUILD_PLUGINS=ON"
diff --git a/net-im/licq/metadata.xml b/net-im/licq/metadata.xml
index 8c13b30c5f6c..fb4e811135b2 100644
--- a/net-im/licq/metadata.xml
+++ b/net-im/licq/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-im</herd>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
<longdescription>Licq is an ICQ clone with an extensive plugin system.</longdescription>
<use>