summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-10-30 21:41:03 +0000
committerJohannes Huber <johu@gentoo.org>2013-10-30 21:41:03 +0000
commit7b187db7847e2bc290670a7f3cce1779a0d1dccc (patch)
tree80b44ebc0c3dbab6bd9872b42bd396f32a22c8d9 /net-im/ktp-accounts-kcm
parent+tora-2.1.3-r3: Fix tora.desktop file to pass validation, bug#484198. (diff)
downloadgentoo-2-7b187db7847e2bc290670a7f3cce1779a0d1dccc.tar.gz
gentoo-2-7b187db7847e2bc290670a7f3cce1779a0d1dccc.tar.bz2
gentoo-2-7b187db7847e2bc290670a7f3cce1779a0d1dccc.zip
Adding upstream patches to make modemmanager (net-libs/libmm-qt) optional and to fix build when its installed wrt bug #489890.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'net-im/ktp-accounts-kcm')
-rw-r--r--net-im/ktp-accounts-kcm/ChangeLog9
-rw-r--r--net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-api.patch41
-rw-r--r--net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-optional.patch27
-rw-r--r--net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild18
-rw-r--r--net-im/ktp-accounts-kcm/metadata.xml5
5 files changed, 96 insertions, 4 deletions
diff --git a/net-im/ktp-accounts-kcm/ChangeLog b/net-im/ktp-accounts-kcm/ChangeLog
index 55a1e6218446..a4aba5a70360 100644
--- a/net-im/ktp-accounts-kcm/ChangeLog
+++ b/net-im/ktp-accounts-kcm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/ktp-accounts-kcm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-accounts-kcm/ChangeLog,v 1.19 2013/10/29 21:48:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-accounts-kcm/ChangeLog,v 1.20 2013/10/30 21:41:03 johu Exp $
+
+ 30 Oct 2013; Johannes Huber <johu@gentoo.org>
+ +files/ktp-accounts-kcm-0.7.0-libmm-qt-api.patch,
+ +files/ktp-accounts-kcm-0.7.0-libmm-qt-optional.patch,
+ ktp-accounts-kcm-0.7.0.ebuild, metadata.xml:
+ Adding upstream patches to make modemmanager (net-libs/libmm-qt) optional and
+ to fix build when its installed wrt bug #489890.
29 Oct 2013; Johannes Huber <johu@gentoo.org> -ktp-accounts-kcm-0.6.2.ebuild:
Remove KDE Telepathy 0.6.2.
diff --git a/net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-api.patch b/net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-api.patch
new file mode 100644
index 000000000000..b20536db4605
--- /dev/null
+++ b/net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-api.patch
@@ -0,0 +1,41 @@
+commit ce0b5d9b435f4102aae35b3a3d5e9e6d0cb27154
+Author: Anant Kamath <kamathanant@gmail.com>
+Date: Mon Oct 7 04:15:55 2013 +0530
+
+ Fixed to use ModemManagerQt 0.5.1 API correctly
+
+ BUG: 325377
+
+diff --git a/plugins/pintxo/modem-combobox.cpp b/plugins/pintxo/modem-combobox.cpp
+index db949c4..9e15c0c 100644
+--- a/plugins/pintxo/modem-combobox.cpp
++++ b/plugins/pintxo/modem-combobox.cpp
+@@ -33,8 +33,8 @@ ModemComboBox::ModemComboBox(QWidget* parent) : QComboBox(parent)
+ Q_FOREACH(ModemManager::ModemInterface::Ptr modem, modems) {
+ ModemManager::ModemGsmCardInterface::Ptr simCard = ModemManager::findModemInterface(modem->udi(), ModemManager::ModemInterface::GsmCard).objectCast<ModemManager::ModemGsmCardInterface>();
+ if(!simCard.isNull()) {
+- QString simIdent = simCard->getSimIdentifier();
+- QDBusReply<QString> spn = simCard->getSpn();
++ QString simIdent = simCard->simIdentifier();
++ QDBusReply<QString> spn = simCard->serviceProviderName();
+ addItem(spn.isValid() ? spn.value() : QLatin1String("Unknown modem"));
+ }
+ }
+@@ -51,7 +51,7 @@ QString ModemComboBox::selectedSimIdentifier()
+ if(!modem.isNull()){
+ ModemManager::ModemGsmCardInterface::Ptr simCard = ModemManager::findModemInterface(modems.at(currentIndex())->udi(), ModemManager::ModemInterface::GsmCard).objectCast<ModemManager::ModemGsmCardInterface>();
+ if(!simCard.isNull()) {
+- return simCard->getSimIdentifier();
++ return simCard->simIdentifier();
+ }
+ }
+ return QString();
+@@ -64,7 +64,7 @@ void ModemComboBox::setSelectedModem(const QString &selectedSimIdentifier)
+ Q_FOREACH(ModemManager::ModemInterface::Ptr modem, modems) {
+ ModemManager::ModemGsmCardInterface::Ptr simCard = ModemManager::findModemInterface(modem->udi(), ModemManager::ModemInterface::GsmCard).objectCast<ModemManager::ModemGsmCardInterface>();
+ if(!simCard.isNull()) {
+- QString simIdent = simCard->getSimIdentifier();
++ QString simIdent = simCard->simIdentifier();
+ if (simIdent == selectedSimIdentifier) {
+ setCurrentIndex(i);
+ return;
diff --git a/net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-optional.patch b/net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-optional.patch
new file mode 100644
index 000000000000..54f15344597b
--- /dev/null
+++ b/net-im/ktp-accounts-kcm/files/ktp-accounts-kcm-0.7.0-libmm-qt-optional.patch
@@ -0,0 +1,27 @@
+commit de71c97def75f047ec0dbaabffb8bc698938e84f
+Author: David Edmundson <kde@davidedmundson.co.uk>
+Date: Wed Oct 30 19:19:23 2013 +0100
+
+ Make each plugin optional
+
+diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
+index e270078..e752ef1 100644
+--- a/plugins/CMakeLists.txt
++++ b/plugins/CMakeLists.txt
+@@ -1,8 +1,8 @@
+-add_subdirectory (gabble)
+-add_subdirectory (butterfly)
+-add_subdirectory (idle)
+-add_subdirectory (haze)
+-add_subdirectory (rakia)
+-add_subdirectory (salut)
+-add_subdirectory (sunshine)
+-add_subdirectory (pintxo)
++macro_optional_add_subdirectory (gabble)
++macro_optional_add_subdirectory (butterfly)
++macro_optional_add_subdirectory (idle)
++macro_optional_add_subdirectory (haze)
++macro_optional_add_subdirectory (rakia)
++macro_optional_add_subdirectory (salut)
++macro_optional_add_subdirectory (sunshine)
++macro_optional_add_subdirectory (pintxo)
diff --git a/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild b/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild
index e9daa5434126..083c0468cf96 100644
--- a/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild
+++ b/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild,v 1.1 2013/10/29 20:06:31 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ktp-accounts-kcm/ktp-accounts-kcm-0.7.0.ebuild,v 1.2 2013/10/30 21:41:03 johu Exp $
EAPI=5
@@ -21,12 +21,26 @@ fi
LICENSE="LGPL-2.1"
SLOT="4"
-IUSE="debug"
+IUSE="debug modemmanager"
DEPEND="
>=net-im/ktp-common-internals-${PV}
net-im/telepathy-mission-control
net-libs/telepathy-glib
>=net-libs/telepathy-qt-0.9.3
+ modemmanager? ( net-libs/libmm-qt )
"
RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-libmm-qt-api.patch"
+ "${FILESDIR}/${P}-libmm-qt-optional.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build modemmanager pintxo)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/net-im/ktp-accounts-kcm/metadata.xml b/net-im/ktp-accounts-kcm/metadata.xml
index 8d1e86a9cefb..c5ae96e2c633 100644
--- a/net-im/ktp-accounts-kcm/metadata.xml
+++ b/net-im/ktp-accounts-kcm/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>kde</herd>
+ <herd>kde</herd>
+ <use>
+ <flag name="modemmanager">Enable support for mobile broadband devices</flag>
+ </use>
</pkgmetadata>