summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-11 20:15:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-11 20:15:42 +0000
commit88c914500da915b0d95e29845d8c7d25b2cfab95 (patch)
tree4d0794546200d5d5a7660adc4d22a4cdb0ef8e7a /net-im/kmess
parentold (diff)
downloadgentoo-2-88c914500da915b0d95e29845d8c7d25b2cfab95.tar.gz
gentoo-2-88c914500da915b0d95e29845d8c7d25b2cfab95.tar.bz2
gentoo-2-88c914500da915b0d95e29845d8c7d25b2cfab95.zip
Add a better patch found on http://kmess.org/board/viewtopic.php?p=32892#p32892
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'net-im/kmess')
-rw-r--r--net-im/kmess/ChangeLog10
-rw-r--r--net-im/kmess/files/kmess-2.0.6-follow-location-redirects.patch34
-rw-r--r--net-im/kmess/kmess-2.0.6-r3.ebuild (renamed from net-im/kmess/kmess-2.0.6-r2.ebuild)4
3 files changed, 45 insertions, 3 deletions
diff --git a/net-im/kmess/ChangeLog b/net-im/kmess/ChangeLog
index d4598fcf22ca..525b9cec1646 100644
--- a/net-im/kmess/ChangeLog
+++ b/net-im/kmess/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-im/kmess
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/ChangeLog,v 1.83 2011/11/06 10:33:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/ChangeLog,v 1.84 2011/11/11 20:15:42 hwoarang Exp $
+
+*kmess-2.0.6-r3 (11 Nov 2011)
+
+ 11 Nov 2011; Markos Chandras <hwoarang@gentoo.org>
+ +files/kmess-2.0.6-follow-location-redirects.patch, +kmess-2.0.6-r3.ebuild,
+ -kmess-2.0.6-r2.ebuild:
+ Add a better patch found on
+ http://kmess.org/board/viewtopic.php?p=32892#p32892
*kmess-2.0.6-r2 (06 Nov 2011)
diff --git a/net-im/kmess/files/kmess-2.0.6-follow-location-redirects.patch b/net-im/kmess/files/kmess-2.0.6-follow-location-redirects.patch
new file mode 100644
index 000000000000..fbabdeff44dd
--- /dev/null
+++ b/net-im/kmess/files/kmess-2.0.6-follow-location-redirects.patch
@@ -0,0 +1,34 @@
+Follow Location redirects, MS seems to have moved some accounts to other
+servers. Forum topic reference:
+Connection problem to wlm - http://kmess.org/board/viewtopic.php?f=4&t=20549
+diff -Nur a/src/network/soap/httpsoapconnection.cpp b/src/network/soap/httpsoapconnection.cpp
+--- a/src/network/soap/httpsoapconnection.cpp 2011-02-16 08:16:45.000000000 +0100
++++ b/src/network/soap/httpsoapconnection.cpp 2011-11-08 16:53:29.612517607 +0100
+@@ -456,6 +456,7 @@
+ const QByteArray& replyContents = reply->readAll();
+ const int statusCode = reply->attribute( QNetworkRequest::HttpStatusCodeAttribute ).toInt();
+ const QString error ( reply->attribute( QNetworkRequest::HttpReasonPhraseAttribute ).toString() );
++ QUrl redirectUrl = reply->attribute( QNetworkRequest::RedirectionTargetAttribute ).toUrl();
+
+ #ifdef KMESSDEBUG_HTTPSOAPCONNECTION_GENERAL
+ bool requestSuccess = false;
+@@ -490,13 +491,16 @@
+ #endif
+
+ // Parse the message contents
+- if( currentResponse->isFaultMessage() )
++ if( !redirectUrl.isEmpty() || currentResponse->isFaultMessage() )
+ {
+- // Verify if the server is redirecting us to another server
+ if( currentResponse->getFaultCode() == "psf:Redirect" )
+ {
++ redirectUrl = XmlFunctions::getNodeValue( currentResponse->getFault(), "redirectUrl" );
++ }
++ // Verify if the server is redirecting us to another server
++ if( !redirectUrl.isEmpty() )
++ {
+ const QUrl& originalUrl = currentResponse->getEndPoint();
+- const QUrl redirectUrl( XmlFunctions::getNodeValue( currentResponse->getFault(), "redirectUrl" ) );
+ const QString originalHost( originalUrl.host() );
+ const QString redirectHost( redirectUrl.host() );
+
diff --git a/net-im/kmess/kmess-2.0.6-r2.ebuild b/net-im/kmess/kmess-2.0.6-r3.ebuild
index 3234c41dff57..8243c9cbab18 100644
--- a/net-im/kmess/kmess-2.0.6-r2.ebuild
+++ b/net-im/kmess/kmess-2.0.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/kmess-2.0.6-r2.ebuild,v 1.1 2011/11/06 10:33:05 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kmess/kmess-2.0.6-r3.ebuild,v 1.1 2011/11/11 20:15:42 hwoarang Exp $
EAPI=3
@@ -41,7 +41,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-login-fix.patch
- "${FILESDIR}"/${P}-contact-list.patch
+ "${FILESDIR}"/${P}-follow-location-redirects.patch
)
src_configure() {