summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-04 21:29:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-04 21:29:13 +0000
commit40ad804d65a2fb41438031d1718edec1205031cd (patch)
treebea7f0dd7481e61616e78082c5ad6f1ae523eec0 /net-im/gossip
parentclean up old revisions. (diff)
downloadgentoo-2-40ad804d65a2fb41438031d1718edec1205031cd.tar.gz
gentoo-2-40ad804d65a2fb41438031d1718edec1205031cd.tar.bz2
gentoo-2-40ad804d65a2fb41438031d1718edec1205031cd.zip
bump to 0.31. bug fixes and translation updates. Closes bug #233874.
(Portage version: 2.2_rc3/cvs/Linux 2.6.26-gentoo-mactel x86_64)
Diffstat (limited to 'net-im/gossip')
-rw-r--r--net-im/gossip/ChangeLog7
-rw-r--r--net-im/gossip/gossip-0.31.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/net-im/gossip/ChangeLog b/net-im/gossip/ChangeLog
index f24506c4c646..35b615e205e7 100644
--- a/net-im/gossip/ChangeLog
+++ b/net-im/gossip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gossip
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/ChangeLog,v 1.78 2008/08/03 16:16:40 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/ChangeLog,v 1.79 2008/08/04 21:29:13 eva Exp $
+
+*gossip-0.31 (04 Aug 2008)
+
+ 04 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org> +gossip-0.31.ebuild:
+ bump to 0.31. bug fixes and translation updates. Closes bug #233874.
*gossip-0.30 (03 Aug 2008)
diff --git a/net-im/gossip/gossip-0.31.ebuild b/net-im/gossip/gossip-0.31.ebuild
new file mode 100644
index 000000000000..4d52eaa75b7d
--- /dev/null
+++ b/net-im/gossip/gossip-0.31.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/gossip-0.31.ebuild,v 1.1 2008/08/04 21:29:13 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Lightweight Jabber client for GNOME"
+HOMEPAGE="http://developer.imendio.com/wiki/Gossip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus eds galago gnome-keyring libnotify spell test"
+
+RDEPEND="x11-libs/libXScrnSaver
+ >=dev-libs/glib-2.12.1
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-1.2
+ >=dev-libs/libxml2-2.6.16
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=net-libs/loudmouth-1.4.1
+ eds? ( >=gnome-extra/evolution-data-server-1.2 )
+ spell? ( app-text/aspell
+ >=app-text/iso-codes-1.5 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ galago? ( dev-libs/libgalago )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ gnome-keyring? ( gnome-base/gnome-keyring )"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35
+ x11-proto/scrnsaverproto"
+
+DOCS="AUTHORS README COPYING ChangeLog INSTALL NEWS README CONTRIBUTORS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ ${mydebug}
+ $(use_enable dbus)
+ $(use_enable eds ebook)
+ $(use_enable galago)
+ $(use_enable gnome-keyring)
+ $(use_enable libnotify)
+ $(use_enable spell aspell)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn "If you are upgrading from <net-im/gossip-0.28 any previously registred"
+ ewarn "accounts will be dropped. However history will not be removed."
+}