summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-18 02:24:32 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-18 02:24:32 +0000
commit9e48e45840c2b2fd3af9c3820fd38bdab725064a (patch)
tree4bb331c286355082165fde226552e10b6a5bce7a /net-im/gaim
parentchanged to use java-commons eclass. (diff)
downloadgentoo-2-9e48e45840c2b2fd3af9c3820fd38bdab725064a.tar.gz
gentoo-2-9e48e45840c2b2fd3af9c3820fd38bdab725064a.tar.bz2
gentoo-2-9e48e45840c2b2fd3af9c3820fd38bdab725064a.zip
update encryption plugin
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/files/digest-gaim-0.59.9-r12
-rw-r--r--net-im/gaim/gaim-0.59.9-r1.ebuild73
3 files changed, 81 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index f033626a5788..223a42f3e0b4 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.37 2003/03/07 13:21:28 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.38 2003/03/18 02:24:32 lostlogic Exp $
+
+*gaim-0.59.9-r1 (17 Mar 2003)
+
+ 17 Mar 2003; Brandon Low <lostlogic@gentoo.org> gaim-0.59.9-r1.ebuild:
+ Bump gaim-encryption plugin version.
*gaim-0.59.9 (03 Mar 2003)
diff --git a/net-im/gaim/files/digest-gaim-0.59.9-r1 b/net-im/gaim/files/digest-gaim-0.59.9-r1
new file mode 100644
index 000000000000..20f758f68b4f
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.59.9-r1
@@ -0,0 +1,2 @@
+MD5 ef0aec77daccbc21d34b45955fc44b1c gaim-0.59.9.tar.bz2 1557480
+MD5 239b93bfd94c9e04c47fd3c2ed64fe56 encrypt-1.16.tar.gz 51565
diff --git a/net-im/gaim/gaim-0.59.9-r1.ebuild b/net-im/gaim/gaim-0.59.9-r1.ebuild
new file mode 100644
index 000000000000..d229246f7ef8
--- /dev/null
+++ b/net-im/gaim/gaim-0.59.9-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.59.9-r1.ebuild,v 1.1 2003/03/18 02:24:32 lostlogic Exp $
+
+inherit kde-functions eutils
+
+EV=1.16
+DESCRIPTION="GTK Instant Messenger client"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+HOMEPAGE="http://gaim.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc sparc"
+IUSE="nas nls esd gnome arts perl ssl"
+
+DEPEND="=sys-libs/db-1*
+ esd? ( >=media-sound/esound-0.2.22-r2 )
+ nls? ( sys-devel/gettext )
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ arts? ( >=kde-base/arts-0.9.5 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ( gnome? ( =gnome-base/gnome-panel-1.4* >=media-libs/gdk-pixbuf-0.16.0 ) :
+ ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* ) )
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}/plugins
+ use ssl && {
+ unpack encrypt-${EV}.tar.gz
+ epatch encrypt/patchfile.0.59.5
+ }
+}
+
+src_compile() {
+ local myconf
+ use esd || myconf="--disable-esd"
+ use perl || myconf="${myconf} --disable-perl"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ use arts && set-kdedir 3 || myconf="${myconf} --disable-artsc"
+ use nls || myconf="${myconf} --disable-nls"
+
+ # We always build a standalone version of gaim.
+ # In this build, GNOME is always disabled.
+ cp configure{,.old} # fix for #13533
+ sed -e 's:-I\\$(top_srcdir)::' configure.old > configure
+ econf ${myconf} --disable-gnome || die
+ emake || die
+
+ # if gnome support is enabled (and gtk2 disabled), then build gaim_applet
+ if [ "`use gnome`" ];
+ then
+ # save applet-less version and clean up...
+ cp src/gaim ${S}/gaim || die "standalone version failed to build"
+ make distclean || die
+
+ econf ${myconf} --with-gnome=${GNOME_PATH} --enable-panel || die
+ emake || die "applet failed to build"
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ # if gnome enabled, make sure to install standalone version also
+ if [ "`use gnome`" ]
+ then
+ dobin ${S}/gaim
+ fi
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO
+}