summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKathryn Kulick <gothgirl@gentoo.org>2005-12-29 13:48:45 +0000
committerKathryn Kulick <gothgirl@gentoo.org>2005-12-29 13:48:45 +0000
commit8c39b54a198612c35858426df34238ee0f368aef (patch)
treec7cf3b0f84e5a812d73edad9cc7f2a5e09303578 /net-im/gaim
parentadded xscreensaver use flag for gaim wrt bug#116982 (diff)
downloadgentoo-2-8c39b54a198612c35858426df34238ee0f368aef.tar.gz
gentoo-2-8c39b54a198612c35858426df34238ee0f368aef.tar.bz2
gentoo-2-8c39b54a198612c35858426df34238ee0f368aef.zip
added xscreensaver support wrt bug#116982
(Portage version: 2.0.53)
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/ChangeLog7
-rw-r--r--net-im/gaim/Manifest2
-rw-r--r--net-im/gaim/files/digest-gaim-2.0.0_beta1-r31
-rw-r--r--net-im/gaim/gaim-2.0.0_beta1-r3.ebuild165
4 files changed, 174 insertions, 1 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index ea43e0455178..c288c28d22f6 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.377 2005/12/25 02:58:23 gothgirl Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.378 2005/12/29 13:48:45 gothgirl Exp $
+
+*gaim-2.0.0_beta1-r3 (29 Dec 2005)
+
+ 29 Dec 2005; <gothgirl@gentoo.org> +gaim-2.0.0_beta1-r3.ebuild:
+ added xscreensaver support wrt bug#116982
*gaim-2.0.0_beta1-r2 (25 Dec 2005)
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 68031e15d6b1..4e35eb5bdd9a 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -2,8 +2,10 @@ MD5 2cb254fb3387d42761703a26c1fb98cc ChangeLog 54766
MD5 55807d838af0375bc41eabe3534fdda8 files/digest-gaim-1.5.0 64
MD5 2c4a27af96f02fda96088c16ba7391e2 files/digest-gaim-2.0.0_beta1 69
MD5 2c4a27af96f02fda96088c16ba7391e2 files/digest-gaim-2.0.0_beta1-r2 69
+MD5 2c4a27af96f02fda96088c16ba7391e2 files/digest-gaim-2.0.0_beta1-r3 69
MD5 afc682711efed5d09a9229bd06a7a13b files/gaim-0.76-xinput.patch 644
MD5 375e4842d0812bfba079e1b2539c7b17 gaim-1.5.0.ebuild 4181
MD5 348c84e19e40918c90e05f3f6d0c0a8f gaim-2.0.0_beta1-r2.ebuild 5304
+MD5 b3a463bbb85e698b3f558bfef45cc566 gaim-2.0.0_beta1-r3.ebuild 5341
MD5 12626653ef7113ed485dee81da7dd8e1 gaim-2.0.0_beta1.ebuild 4595
MD5 6727d140d07549b6be4b0ca9886e2514 metadata.xml 414
diff --git a/net-im/gaim/files/digest-gaim-2.0.0_beta1-r3 b/net-im/gaim/files/digest-gaim-2.0.0_beta1-r3
new file mode 100644
index 000000000000..516e20aad34b
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-2.0.0_beta1-r3
@@ -0,0 +1 @@
+MD5 15d2c460112af93ceff4818f29f6c1b8 gaim-2.0.0beta1.tar.bz2 7718029
diff --git a/net-im/gaim/gaim-2.0.0_beta1-r3.ebuild b/net-im/gaim/gaim-2.0.0_beta1-r3.ebuild
new file mode 100644
index 000000000000..d38651ff9d4e
--- /dev/null
+++ b/net-im/gaim/gaim-2.0.0_beta1-r3.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta1-r3.ebuild,v 1.1 2005/12/29 13:48:45 gothgirl Exp $
+
+inherit flag-o-matic eutils toolchain-funcs debug multilib mono
+
+MY_PV=${PV/_beta/beta}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="bonjour dbus nls perl spell nas cjk gnutls silc eds krb4 tcltk debug mono xscreensaver"
+
+RDEPEND="media-libs/libao
+ media-libs/audiofile
+ bonjour? (net-misc/howl)
+ dbus? ( >=sys-apps/dbus-0.35
+ >=dev-lang/python-2.4 )
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ perl? ( >=dev-lang/perl-5.8.2-r1
+ !<perl-core/ExtUtils-MakeMaker-6.17 )
+ spell? ( >=app-text/gtkspell-2.0.2 )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/nss-3.9.2-r2 )
+ silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
+ eds? ( gnome-extra/evolution-data-server )
+ krb4? ( >=app-crypt/mit-krb5-1.3.6-r1 )
+ tcltk? ( dev-lang/tcl
+ dev-lang/tk )
+ startup-notification? ( >=x11-libs/startup-notification-0.5 )
+ mono? ( dev-lang/mono )
+ xscreensaver? (x11-misc/xscreensaver)"
+
+DEPEND="$RDEPEND
+ dev-util/pkgconfig
+ x11-libs/startup-notification
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+# List of plugins
+# app-accessibility/festival-gaim
+# net-im/gaim-blogger
+# net-im/gaim-bnet
+# net-im/gaim-meanwhile
+# net-im/gaim-snpp
+# x11-plugins/autoprofile
+# x11-plugins/gaim-assistant
+# x11-plugins/gaim-encryption
+# x11-plugins/gaim-extprefs
+# x11-plugins/gaim-latex
+# x11-plugins/gaim-otr
+# x11-plugins/gaim-rhythmbox
+# x11-plugins/gaim-xmms-remote
+# x11-plugins/gaimosd
+# x11-plugins/guifications
+
+
+print_gaim_warning() {
+ ewarn
+ ewarn "This is a beta release! Please back up everything in your .gaim"
+ ewarn "directory. We're looking for lots of feedback on this release"
+ ewarn "especially what you love about it and what you hate about it."
+ ewarn
+ ewarn "Again, this is a beta release and should not be used by those"
+ ewarn "with a heart condition, if you are pregnant, or if you are under"
+ ewarn "the age of 8. Side-effects include awesomeness, dumbfoundedness,"
+ ewarn "dry mouth and lava. Consult your doctor to find out if"
+ ewarn "${MY_P} is right for you."
+ ewarn
+ ewarn "If you are merging ${MY_P} from an earlier version, you may need"
+ ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
+ ewarn
+ ewarn "If you experience problems with gaim, file them as bugs with"
+ ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
+ ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
+ ewarn "seek help in #gaim."
+ ewarn
+ ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
+ ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
+ ewarn "backtraces."
+ ewarn
+ ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
+ ewarn
+ einfo
+ einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
+ einfo
+ ebeep 5
+ epause 3
+}
+
+pkg_setup() {
+ print_gaim_warning
+ if use krb4 && ! built_with_use app-crypt/mit-krb5 krb4 ; then
+ eerror
+ eerror You need to rebuild app-crypt/mit-krb5 with USE=krb4 in order to
+ eerror enable krb4 support for the zephyr protocol in gaim.
+ eerror
+ die "Configure failed"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+
+ # -msse2 doesn't play nice on gcc 3.2
+ [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
+
+ local myconf
+ use truespeech && myconf="${myconf} --enable-truespeech"
+ use ao || use audiofile || myconf="${myconf} --disable-audio"
+ use dbus && myconf="${myconf} --enable-dbus"
+ use debug && myconf="${myconf} --enable-debug"
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ use eds || myconf="${myconf} --disable-gevolution"
+ use krb4 && myconf="${myconf} --with-krb4"
+ use tcltk || myconf="${myconf} --disable-tcl --disable-tk"
+ use xscreensaver || myconf="${myconf} --disable-screensaver"
+ use startup-notification || myconf="${myconf} --disable-startup-notification"
+ use mono && myconf="${myconf} --enable-mono"
+
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf="${myconf} --enable-nss=no"
+ myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
+ myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf="${myconf} --enable-gnutls=no"
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/$(get_libdir)/nspr"
+ myconf="${myconf} --with-nss-libs=/usr/$(get_libdir)/nss"
+ fi
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ print_gaim_warning
+}