summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-08-04 00:59:40 +0000
committerDon Seiler <rizzo@gentoo.org>2003-08-04 00:59:40 +0000
commit4cb9f60530119c253fc731a78b425c68f4eb0231 (patch)
tree4ee47df464c19ea251d818aa7a5f4818a6bc17df /net-im/gaim
parentRevision bump to pick up new patch for cjk users. Putting right into stable ... (diff)
downloadgentoo-2-4cb9f60530119c253fc731a78b425c68f4eb0231.tar.gz
gentoo-2-4cb9f60530119c253fc731a78b425c68f4eb0231.tar.bz2
gentoo-2-4cb9f60530119c253fc731a78b425c68f4eb0231.zip
Revision bump to pick up new patch for cjk users. Putting right into stable as only change is for cjk, which was crashing previously.
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/ChangeLog9
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.66-r32
-rw-r--r--net-im/gaim/files/gaim_gtkimcontext_patch.diff31
-rw-r--r--net-im/gaim/gaim-0.66-r3.ebuild70
5 files changed, 107 insertions, 9 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index 077c6739b136..5861ddba6851 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.65 2003/07/31 18:00:48 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.66 2003/08/04 00:59:35 rizzo Exp $
+
+*gaim-0.66-r3 (03 Aug 2003)
+
+ 03 Aug 2003; Don Seiler <rizzo@gentoo.org>; gaim-0.66-r3.ebuild,
+ files/gaim_gtkimcontext_patch.diff:
+ Revision bump to pick up new patch for cjk. Bumping to stable as as
+ only change is the patch.
31 Jul 2003; Don Seiler <rizzo@gentoo.org>; gaim-0.66-r2.ebuild,
metadata.xml:
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 351cced41300..cd79816095c5 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,9 +1,9 @@
MD5 63f5d5add45a34870e61e2e39d70b919 gaim-0.63-r1.ebuild 1835
MD5 563bfa3942598d75f097aaf618e9bfe3 gaim-0.66.ebuild 2163
MD5 c312c7f2f86088e2cbae1c306fb009ee gaim-0.59.9-r1.ebuild 2173
-MD5 00c380b0a716b59b0c7e2c6eca2d3510 gaim-0.66-r3.ebuild 1951
+MD5 03ddde8eee5a72dd8655868c50532004 gaim-0.66-r3.ebuild 1951
MD5 75b5b8d5565abeeca9fdad904cc765d6 gaim-0.65-r1.ebuild 2167
-MD5 333ba40b58cd49417f82c90f77d8d76d ChangeLog 11378
+MD5 eac54ae6fc1bc374bfe8bfbe9d5f4a17 ChangeLog 11378
MD5 769049deda9ae8a4f818bc6b74a5baff metadata.xml 506
MD5 00c380b0a716b59b0c7e2c6eca2d3510 gaim-0.66-r2.ebuild 1951
MD5 07beb4e67f5dd8cafed146e45b919144 files/digest-gaim-0.59.9-r1 128
diff --git a/net-im/gaim/files/digest-gaim-0.66-r3 b/net-im/gaim/files/digest-gaim-0.66-r3
new file mode 100644
index 000000000000..23880debebfc
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.66-r3
@@ -0,0 +1,2 @@
+MD5 80c52fc8c969a65ea7bbd6444142fe5f gaim-0.66.tar.bz2 2744562
+MD5 03d3bdfe9eb1a73c44b0aa097513b10a encrypt-2.02.tar.gz 75136
diff --git a/net-im/gaim/files/gaim_gtkimcontext_patch.diff b/net-im/gaim/files/gaim_gtkimcontext_patch.diff
index a39795283e32..ec548e080c35 100644
--- a/net-im/gaim/files/gaim_gtkimcontext_patch.diff
+++ b/net-im/gaim/files/gaim_gtkimcontext_patch.diff
@@ -1,12 +1,31 @@
---- gtkconv.c Sat May 31 08:08:44 2003
-+++ gtkconv.new.c Thu Jun 26 23:04:46 2003
-@@ -981,6 +981,9 @@
+--- gtkconv.c 2003-07-18 09:57:39.000000000 +0900
++++ gtkconv.c.new 2003-08-03 23:11:17.000000000 +0900
+@@ -1134,12 +1134,28 @@
+ GaimConversation *conv;
+ GaimGtkConversation *gtkconv;
+ GaimGtkWindow *gtkwin;
++ gboolean im_context_retval = FALSE;
++ static guint32 last_event_time;
+
+ conv = (GaimConversation *)data;
+ gtkconv = GAIM_GTK_CONVERSATION(conv);
win = gaim_conversation_get_window(conv);
gtkwin = GAIM_GTK_WINDOW(win);
-+ /* check if the input method handles this keyevent or we can use it */
-+ if (gtk_im_context_filter_keypress(GTK_TEXT_VIEW(gtkconv->entry)->im_context, event) == TRUE) return TRUE;
++ /*
++ * Check if the input method handles this keyevent or we can use it.
++ * We need to check the event time, otherwise the gtk xim module gets into an event loop (bug?)
++ * Maybe this is not the best solution, but it works.
++ */
+
++ if (last_event_time != event->time) {
++ im_context_retval = gtk_im_context_filter_keypress(GTK_TEXT_VIEW(gtkconv->entry)->im_context, event);
++ }
++ last_event_time = event->time;
++ if (im_context_retval == TRUE) {
++ return TRUE;
++ }
++
if (event->keyval == GDK_Escape) {
- if (convo_options & OPT_CONVO_ESC_CAN_CLOSE) {
+ if (gaim_prefs_get_bool("/gaim/gtk/conversations/escape_closes")) {
g_signal_stop_emission_by_name(G_OBJECT(entry), "key_press_event");
diff --git a/net-im/gaim/gaim-0.66-r3.ebuild b/net-im/gaim/gaim-0.66-r3.ebuild
new file mode 100644
index 000000000000..b6945900227c
--- /dev/null
+++ b/net-im/gaim/gaim-0.66-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.66-r3.ebuild,v 1.1 2003/08/04 00:59:35 rizzo Exp $
+
+IUSE="nls perl spell nas ssl cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.02
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc ~alpha ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${P}
+ use ssl && {
+ cd ${S}/plugins
+ unpack encrypt-${EV}.tar.gz
+ cd encrypt
+ epatch patchfile.0.66
+ }
+ use cjk && {
+ cd ${S}/src
+ epatch ${FILESDIR}/gaim_gtkimcontext_patch.diff
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ ewarn
+ fi
+}