summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-02-10 01:19:18 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-02-10 01:19:18 +0000
commitd4d54d0fbddc6e359cadc54fc1f4568bae412fe5 (patch)
tree4a47c15044e04dfc767d975a616065f6f7655567 /net-im/empathy
parentMarked stable on amd64 as per bug 205588. (diff)
downloadgentoo-2-d4d54d0fbddc6e359cadc54fc1f4568bae412fe5.tar.gz
gentoo-2-d4d54d0fbddc6e359cadc54fc1f4568bae412fe5.tar.bz2
gentoo-2-d4d54d0fbddc6e359cadc54fc1f4568bae412fe5.zip
Bump to 0.21.90
- Change "new message" dialog to "new conversation" and make possible to do voip call. (xclaesse). - Try to load dtd and glade files from the srcdir. (xclaesse). - Add a property to have or not groups on EmpathyContactListStore (xclaesse). - Add a features property on EmpathyContactListView to enable/disable each action. (xclaesse). - Add a program to show chat logs (xclaesse). - Add a cancel button on the custom message diaog (xclaesse). - Unset account parameter if user gives an empthy value. (xclaesse). - Show/Hide main window when changing corresponding gcong key. (xclaesse). Bugs fixed: - improve accounts dialog (xclaesse) - New UI for Jabber accounts (xclaesse) - empathy is showing off-line contacts before on-line ones (xclaesse) - Ellipsize error button (xclaesse) - account has to be selected to (un)check its checkbox (Carl-Anton Ingmarsson) - Nickname should be in the main section of the preferences for salut accounts (Marco Barisione) - Do not be automatically set published name for new salut accounts (Marco Barisione) - Empathy HEAD doesn't build (Guillaume Desmottes) (Portage version: 2.1.4.1)
Diffstat (limited to 'net-im/empathy')
-rw-r--r--net-im/empathy/ChangeLog29
-rw-r--r--net-im/empathy/empathy-0.21.90.ebuild68
2 files changed, 96 insertions, 1 deletions
diff --git a/net-im/empathy/ChangeLog b/net-im/empathy/ChangeLog
index bdcc13ac539a..7d21de76a3b2 100644
--- a/net-im/empathy/ChangeLog
+++ b/net-im/empathy/ChangeLog
@@ -1,6 +1,33 @@
# ChangeLog for net-im/empathy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/ChangeLog,v 1.14 2008/01/16 22:11:15 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/ChangeLog,v 1.15 2008/02/10 01:19:18 dang Exp $
+
+*empathy-0.21.90 (10 Feb 2008)
+
+ 10 Feb 2008; Daniel Gryniewicz <dang@gentoo.org> +empathy-0.21.90.ebuild:
+ Bump to 0.21.90
+ - Change "new message" dialog to "new conversation" and make possible to do
+ voip call. (xclaesse).
+ - Try to load dtd and glade files from the srcdir. (xclaesse).
+ - Add a property to have or not groups on EmpathyContactListStore (xclaesse).
+ - Add a features property on EmpathyContactListView to enable/disable each
+ action. (xclaesse).
+ - Add a program to show chat logs (xclaesse).
+ - Add a cancel button on the custom message diaog (xclaesse).
+ - Unset account parameter if user gives an empthy value. (xclaesse).
+ - Show/Hide main window when changing corresponding gcong key. (xclaesse).
+ Bugs fixed:
+ - improve accounts dialog (xclaesse)
+ - New UI for Jabber accounts (xclaesse)
+ - empathy is showing off-line contacts before on-line ones (xclaesse)
+ - Ellipsize error button (xclaesse)
+ - account has to be selected to (un)check its checkbox (Carl-Anton
+ Ingmarsson)
+ - Nickname should be in the main section of the preferences for salut
+ accounts (Marco Barisione)
+ - Do not be automatically set published name for new salut accounts (Marco
+ Barisione)
+ - Empathy HEAD doesn't build (Guillaume Desmottes)
*empathy-0.21.5.2 (16 Jan 2008)
diff --git a/net-im/empathy/empathy-0.21.90.ebuild b/net-im/empathy/empathy-0.21.90.ebuild
new file mode 100644
index 000000000000..94b635217ec9
--- /dev/null
+++ b/net-im/empathy/empathy-0.21.90.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/empathy/empathy-0.21.90.ebuild,v 1.1 2008/02/10 01:19:18 dang Exp $
+
+inherit gnome2 eutils versionator
+
+MAJOR_V="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Empathy Telepathy client"
+HOMEPAGE="http://live.gnome.org/Empathy"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/${MAJOR_V}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python spell test"
+
+RDEPEND=">=dev-libs/dbus-glib-0.51
+ >=dev-libs/glib-2.14.0
+ >=x11-libs/gtk+-2.12.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-panel-2.10
+ >=net-libs/libtelepathy-0.3.1
+ >=net-libs/telepathy-glib-0.7.0
+ >=net-im/telepathy-mission-control-4.55
+ dev-libs/libxml2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-extra/evolution-data-server-1.2
+ spell? (
+ app-text/aspell
+ app-text/iso-codes )
+ python? (
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pygtk-2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.16
+ test? ( >=dev-libs/check-0.9.4 )"
+
+DOCS="CONTRIBUTORS AUTHORS README"
+
+pkg_setup() {
+ # NotHere is too broken to be included by default
+ G2CONF="$(use_enable spell aspell)
+ $(use_enable python)
+ --enable-voip=no
+ --enable-megaphone
+ --disable-nothere
+ --disable-gtk-doc"
+}
+
+src_install() {
+ gnome2_src_install
+ make_desktop_entry "${PN}" "Empathy" \
+ "/usr/share/icons/hicolor/scalable/apps/${PN}.svg" \
+ "Network;InstantMessaging"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ echo
+ elog "Empathy needs telepathy's connection managers to use any protocol."
+ elog "You'll need to install connection managers yourself."
+ elog "MSN: net-voip/telepathy-butterfly"
+ elog "Jabber and Gtalk: net-voip/telepathy-gabble"
+ elog "IRC: net-irc/telepathy-idle"
+}