summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-04-28 18:00:32 +0000
committerMichael Januszewski <spock@gentoo.org>2005-04-28 18:00:32 +0000
commitbb5ec7619cec758102bece6c7b4619be89d8b3bf (patch)
treefaf16a12d40e188f8e749c730ec12cdf6561c9b7 /net-im/ekg/ekg-1.6_rc1-r1.ebuild
parentversion bump - ebuild submitted by David Ranvig via bug #90409 (diff)
downloadgentoo-2-bb5ec7619cec758102bece6c7b4619be89d8b3bf.tar.gz
gentoo-2-bb5ec7619cec758102bece6c7b4619be89d8b3bf.tar.bz2
gentoo-2-bb5ec7619cec758102bece6c7b4619be89d8b3bf.zip
Added support for building ekg with both ui-ncurses and ui-readline.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'net-im/ekg/ekg-1.6_rc1-r1.ebuild')
-rw-r--r--net-im/ekg/ekg-1.6_rc1-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-im/ekg/ekg-1.6_rc1-r1.ebuild b/net-im/ekg/ekg-1.6_rc1-r1.ebuild
new file mode 100644
index 000000000000..878d09ef0ec0
--- /dev/null
+++ b/net-im/ekg/ekg-1.6_rc1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.6_rc1-r1.ebuild,v 1.1 2005/04/28 18:00:32 spock Exp $
+
+inherit eutils
+
+IUSE="ssl ncurses readline zlib python spell threads"
+
+DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
+HOMEPAGE="http://dev.null.pl/ekg/"
+SRC_URI="http://dev.null.pl/ekg/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ia64 ~amd64"
+
+S="${WORKDIR}/${P/_/}"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ spell? ( >=app-text/aspell-0.50.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ekg-1.6_rc1-fpic.patch
+}
+
+src_compile() {
+ local myconf="--enable-ioctld --enable-shared --enable-dynamic"
+ if use ncurses; then
+ myconf="$myconf --enable-force-ncurses"
+ else
+ myconf="$myconf --disable-ui-ncurses"
+ fi
+ use readline && myconf="$myconf --enable-ui-readline"
+ use zlib || myconf="$myconf --disable-zlib"
+ use ssl || myconf="$myconf --disable-openssl"
+ use python && myconf="$myconf --with-python"
+ use spell && myconf="$myconf --enable-aspell"
+ use threads && myconf="$myconf --with-pthread"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc docs/* docs/api/*
+}