summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-08-27 14:46:14 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-08-27 14:46:14 +0000
commit58279c5de42ae24c616565ff9659836e5909bb74 (patch)
tree904fcc1bc1d15268823691565ad707778135010e /net-im/climm
parentMark -sparc since it sigbuses like webkit-gtk (diff)
downloadgentoo-2-58279c5de42ae24c616565ff9659836e5909bb74.tar.gz
gentoo-2-58279c5de42ae24c616565ff9659836e5909bb74.tar.bz2
gentoo-2-58279c5de42ae24c616565ff9659836e5909bb74.zip
Version bump, thanks to notification from upstream
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'net-im/climm')
-rw-r--r--net-im/climm/ChangeLog7
-rw-r--r--net-im/climm/climm-0.6.3.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-im/climm/ChangeLog b/net-im/climm/ChangeLog
index 7c9a70a76b84..a33c92c15885 100644
--- a/net-im/climm/ChangeLog
+++ b/net-im/climm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/climm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/climm/ChangeLog,v 1.9 2008/08/05 16:31:10 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/ChangeLog,v 1.10 2008/08/27 14:46:14 jokey Exp $
+
+*climm-0.6.3 (27 Aug 2008)
+
+ 27 Aug 2008; Markus Ullmann <jokey@gentoo.org> +climm-0.6.3.ebuild:
+ Version bump, thanks to notification from upstream
05 Aug 2008; Thomas Anderson <gentoofan23@gentoo.org> metadata.xml:
Add USE flag description to metadata as per GLEP 56.
diff --git a/net-im/climm/climm-0.6.3.ebuild b/net-im/climm/climm-0.6.3.ebuild
new file mode 100644
index 000000000000..b53af7995107
--- /dev/null
+++ b/net-im/climm/climm-0.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/climm/climm-0.6.3.ebuild,v 1.1 2008/08/27 14:46:14 jokey Exp $
+
+DESCRIPTION="ICQ text-mode client with many features"
+HOMEPAGE="http://www.climm.org/"
+SRC_URI="http://www.climm.org/source/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gloox gnutls otr tcl ssl"
+
+DEPEND="gloox? ( net-libs/gloox )
+ ssl? (
+ || ( gnutls? ( >=net-libs/gnutls-0.8.10 )
+ dev-libs/openssl ) )
+ tcl? ( dev-lang/tcl )
+ otr? ( >=net-libs/libotr-3.0.0 )"
+
+pkg_setup() {
+ if use gloox && ! use ssl ; then
+ eerror "You need to set the ssl flag when you want to use the gloox"
+ eerror "Jabber library"
+ die "Set ssl or unset gloox for ${PN}"
+ fi
+}
+
+src_compile() {
+ local myconf
+ if use ssl ; then
+ if ! use gnutls ; then
+ elog "Using openSSL"
+ myconf="--enable-ssl=openssl"
+ else
+ elog "Using gnutls"
+ myconf="--enable-ssl=gnutls"
+ fi
+ else
+ myconf="--disable-ssl"
+ fi
+
+ econf \
+ $(use_enable gloox) \
+ $(use_enable otr) \
+ $(use_enable ssl) \
+ $(use_enable tcl) \
+ ${myconf} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+}