summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-01-28 06:57:00 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-01-28 06:57:00 +0000
commita622059103bf69968425fff0afcbbc46d41bac5f (patch)
treec6a86fe9e6d05b9b76e2396230445808f5838c57 /net-im/choqok
parentBuilt and tested on ibook G4, closes bug 308763. (diff)
downloadgentoo-2-a622059103bf69968425fff0afcbbc46d41bac5f.tar.gz
gentoo-2-a622059103bf69968425fff0afcbbc46d41bac5f.tar.bz2
gentoo-2-a622059103bf69968425fff0afcbbc46d41bac5f.zip
Version bump, bug 352990 and bug 348456
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/ChangeLog9
-rw-r--r--net-im/choqok/choqok-1.0.ebuild (renamed from net-im/choqok/choqok-0.9.98-r1.ebuild)8
-rw-r--r--net-im/choqok/files/choqok-0.9.98-libindicate.patch29
3 files changed, 11 insertions, 35 deletions
diff --git a/net-im/choqok/ChangeLog b/net-im/choqok/ChangeLog
index 239b1a9a0b7d..580fe246de15 100644
--- a/net-im/choqok/ChangeLog
+++ b/net-im/choqok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/choqok
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.15 2011/01/13 06:59:29 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.16 2011/01/28 06:56:59 tampakrap Exp $
+
+*choqok-1.0 (28 Jan 2011)
+
+ 28 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ -choqok-0.9.98-r1.ebuild, -files/choqok-0.9.98-libindicate.patch,
+ +choqok-1.0.ebuild:
+ Version bump, bug 352990 and bug 348456
*choqok-0.9.98-r1 (13 Jan 2011)
diff --git a/net-im/choqok/choqok-0.9.98-r1.ebuild b/net-im/choqok/choqok-1.0.ebuild
index 0deea5cb11f7..b9ccc0c1667f 100644
--- a/net-im/choqok/choqok-0.9.98-r1.ebuild
+++ b/net-im/choqok/choqok-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/choqok-0.9.98-r1.ebuild,v 1.1 2011/01/13 06:59:29 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/choqok-1.0.ebuild,v 1.1 2011/01/28 06:56:59 tampakrap Exp $
EAPI=3
@@ -8,7 +8,7 @@ KMNAME="extragear/network"
if [[ ${PV} != *9999* ]]; then
KDE_LINGUAS="bg da de en_GB es et fr ja nb nds nl pa pl pt pt_BR sv tr uk zh_CN zh_TW"
- SRC_URI="http://choqok.gnufolks.org/pkgs/${PN}_${PV}.tar.bz2"
+ SRC_URI="http://choqok.gnufolks.org/pkgs/${P}.tar.bz2"
fi
inherit kde4-base
@@ -27,11 +27,9 @@ DEPEND="dev-libs/qjson
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-libindicate.patch" )
-
src_prepare(){
mycmakeargs=(
- $(cmake-utils_use indicate QTINDICATE_ENABLE)
+ $(cmake-utils_use !indicate QTINDICATE_DISABLE)
)
kde4-base_src_prepare
diff --git a/net-im/choqok/files/choqok-0.9.98-libindicate.patch b/net-im/choqok/files/choqok-0.9.98-libindicate.patch
deleted file mode 100644
index ef7ae8d4b47d..000000000000
--- a/net-im/choqok/files/choqok-0.9.98-libindicate.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 2612167..67dda82 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -8,18 +8,19 @@ set(CHOQOK_BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR})
-
- set(CMAKE_MODULE_PATH ${CHOQOK_SOURCE_DIR}/cmake/modules ${CMAKE_MODULE_PATH})
-
-+option(QTINDICATE_ENABLE "Enable support for notifications via indicator")
-+
- find_package(QJson REQUIRED)
- find_package(QCA2 REQUIRED)
- find_package(QtOAuth REQUIRED)
-
--find_package(QtIndicate QUIET)
--
--if(QTINDICATE_FOUND)
-+if(QTINDICATE_ENABLE)
-+ find_package(QtIndicate QUIET)
- message(STATUS "Found libindicate-qt: Will support notifications via indicator")
- set(HAVE_INDICATEQT true)
--else(QTINDICATE_FOUND)
-+else(QTINDICATE_ENABLE)
- message(STATUS "Optional dependency libindicate-qt not found: Won't support notifications via indicator")
--endif(QTINDICATE_FOUND)
-+endif(QTINDICATE_ENABLE)
-
- set(CHOQOK_INCLUDES
- ${KDE4_INCLUDES}