summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-13 10:31:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-13 10:31:30 +0000
commit1e23ba62d8820dd6776d968153f773752f1b344c (patch)
treea3f394ddcc4a184d1b352e8930340ff43f710012 /net-im/choqok
parentRevert to ~ppc wrt #360601 (diff)
downloadgentoo-2-1e23ba62d8820dd6776d968153f773752f1b344c.tar.gz
gentoo-2-1e23ba62d8820dd6776d968153f773752f1b344c.tar.bz2
gentoo-2-1e23ba62d8820dd6776d968153f773752f1b344c.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux i686)
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/ChangeLog7
-rw-r--r--net-im/choqok/choqok-1.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-im/choqok/ChangeLog b/net-im/choqok/ChangeLog
index c979fc83fd4d..61d7c2b5cba5 100644
--- a/net-im/choqok/ChangeLog
+++ b/net-im/choqok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/choqok
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.27 2012/02/18 17:36:08 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.28 2012/03/13 10:31:30 johu Exp $
+
+*choqok-1.3 (13 Mar 2012)
+
+ 13 Mar 2012; Johannes Huber <johu@gentoo.org> +choqok-1.3.ebuild:
+ Version bump.
18 Feb 2012; nixnut <nixnut@gentoo.org> choqok-1.2.ebuild:
~ppc, preparing for #396359
diff --git a/net-im/choqok/choqok-1.3.ebuild b/net-im/choqok/choqok-1.3.ebuild
new file mode 100644
index 000000000000..cb021a8879f6
--- /dev/null
+++ b/net-im/choqok/choqok-1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/choqok-1.3.ebuild,v 1.1 2012/03/13 10:31:30 johu Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fa fi fr ga gl
+ hr hu is ja km lt ms nb nds nl pa pl pt pt_BR ro ru sk sq sv tr ug uk zh_CN
+ zh_TW"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KDE_HANDBOOK="optional"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ KDE_SCM="git"
+ KEYWORDS=""
+fi
+
+inherit kde4-base
+
+DESCRIPTION="Free/Open Source micro-blogging client for KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="ayatana debug"
+
+DEPEND="dev-libs/qjson
+ >=dev-libs/qoauth-1.0.1
+ ayatana? ( dev-libs/libindicate-qt )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ mycmakeargs=(
+ $(cmake-utils_use !ayatana QTINDICATE_DISABLE)
+ )
+
+ kde4-base_src_prepare
+}