summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-18 16:07:22 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-18 16:07:22 +0000
commitcf8e75b613583ca75b9babc0d77805c20f06eea3 (patch)
tree59ee1418a5b7a9b5f9470205f4af8f975a3a5cff /net-ftp
parentx86 stable, bug 348987 (diff)
downloadgentoo-2-cf8e75b613583ca75b9babc0d77805c20f06eea3.tar.gz
gentoo-2-cf8e75b613583ca75b9babc0d77805c20f06eea3.tar.bz2
gentoo-2-cf8e75b613583ca75b9babc0d77805c20f06eea3.zip
Version bump.
(Portage version: 2.2.0_alpha17/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.1.3.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 5144a13d6df8..8adedd8ad467 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.287 2011/01/09 17:06:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.288 2011/01/18 16:07:22 jer Exp $
+
+*lftp-4.1.3 (18 Jan 2011)
+
+ 18 Jan 2011; Jeroen Roovers <jer@gentoo.org> +lftp-4.1.3.ebuild:
+ Version bump.
09 Jan 2011; Raúl Porcel <armin76@gentoo.org> lftp-4.1.1.ebuild:
alpha/ia64/s390/sparc stable wrt #349801
diff --git a/net-ftp/lftp/lftp-4.1.3.ebuild b/net-ftp/lftp/lftp-4.1.3.ebuild
new file mode 100644
index 000000000000..ec29ce209429
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.1.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.1.3.ebuild,v 1.1 2011/01/18 16:07:22 jer Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.0.2.91-lafile.patch"
+ epatch "${FILESDIR}/${PN}-4.0.3-autoconf-2.64.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}