summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-30 16:34:28 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-30 16:34:28 +0000
commitc9519e437df5cc871191831aa729b1c339c7f337 (patch)
treef239b54cce4b6fadaeaaf2f1364572b2045ea357 /net-ftp
parentVersion bump. (diff)
downloadgentoo-2-c9519e437df5cc871191831aa729b1c339c7f337.tar.gz
gentoo-2-c9519e437df5cc871191831aa729b1c339c7f337.tar.bz2
gentoo-2-c9519e437df5cc871191831aa729b1c339c7f337.zip
Added the "implicittls" USE flag as requested by Thomas D. in bug #509190
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog8
-rw-r--r--net-ftp/pure-ftpd/metadata.xml1
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.36-r1.ebuild140
3 files changed, 148 insertions, 1 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index c0b12f9e542c..7d65184ebd4c 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.150 2014/03/03 13:53:27 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.151 2014/04/30 16:34:27 polynomial-c Exp $
+
+*pure-ftpd-1.0.36-r1 (30 Apr 2014)
+
+ 30 Apr 2014; Lars Wendler <polynomial-c@gentoo.org>
+ +pure-ftpd-1.0.36-r1.ebuild, metadata.xml:
+ Added the "implicittls" USE flag as requested by Thomas D. in bug #509190.
03 Mar 2014; Lars Wendler <polynomial-c@gentoo.org> files/pure-ftpd.rc11:
Fixed pidfile location for non-linux systems.
diff --git a/net-ftp/pure-ftpd/metadata.xml b/net-ftp/pure-ftpd/metadata.xml
index 93a7cd163b77..b4871d977734 100644
--- a/net-ftp/pure-ftpd/metadata.xml
+++ b/net-ftp/pure-ftpd/metadata.xml
@@ -13,6 +13,7 @@
<flag name='anonren'>Permit anonymous to rename files</flag>
<flag name='anonres'>Permit anonymous to resume file transfers</flag>
<flag name='charconv'>Enables charset conversion</flag>
+ <flag name='implicittls'>Enable TLS on Port 990</flag>
<flag name='noiplog'>Disables logging of IP addresses</flag>
<flag name='paranoidmsg'>Display paranoid messages instead of normal
ones</flag>
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.36-r1.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.36-r1.ebuild
new file mode 100644
index 000000000000..8d0ab30b06ad
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.36-r1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.36-r1.ebuild,v 1.1 2014/04/30 16:34:28 polynomial-c Exp $
+
+EAPI=5
+inherit eutils confutils flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="Fast, production-quality, standard-conformant FTP server."
+HOMEPAGE="http://www.pureftpd.org/"
+SRC_URI="ftp://ftp.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2
+ http://download.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+
+IUSE="anondel anonperm anonren anonres caps charconv implicittls ldap mysql noiplog pam paranoidmsg postgres resolveids selinux ssl sysquota vchroot xinetd"
+
+REQUIRED_USE="implicittls? ( ssl )"
+
+DEPEND="caps? ( sys-libs/libcap )
+ charconv? ( virtual/libiconv )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ sysquota? ( sys-fs/quota[-rpc] )
+ xinetd? ( virtual/inetd )"
+
+RDEPEND="${DEPEND}
+ net-ftp/ftpbase
+ selinux? ( sec-policy/selinux-ftp )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.28-pam.patch
+}
+
+src_configure() {
+ # adjust max user length to something more appropriate
+ # for virtual hosts. See bug #62472 for details.
+ sed -e "s:# define MAX_USER_LENGTH 32U:# define MAX_USER_LENGTH 127U:" \
+ -i "${S}/src/ftpd.h" || die "sed failed"
+
+ local my_conf=""
+
+ # Let's configure the USE-enabled stuff
+ enable_extension_without "capabilities" "caps"
+ enable_extension_with "rfc2640" "charconv" 0
+ enable_extension_with "ldap" "ldap" 0
+ enable_extension_with "mysql" "mysql" 0
+ enable_extension_with "pam" "pam" 0
+ enable_extension_with "paranoidmsg" "paranoidmsg" 0
+ enable_extension_with "pgsql" "postgres" 0
+ enable_extension_with "tls" "ssl" 0
+ enable_extension_with "implicittls" "implicittls" 0
+ enable_extension_with "virtualchroot" "vchroot" 0
+ enable_extension_with "sysquotas" "sysquota" 0
+ enable_extension_without "inetd" "xinetd"
+
+ # noiplog is a negative flag, we don't want that enabled by default,
+ # so we handle it manually, as confutils can't do that
+ use noiplog && my_conf="${my_conf} --without-iplogging"
+
+ # Those features are only configurable like this, see bug #179375.
+ use anondel && append-cppflags -DANON_CAN_DELETE
+ use anonperm && append-cppflags -DANON_CAN_CHANGE_PERMS
+ use anonren && append-cppflags -DANON_CAN_RENAME
+ use anonres && append-cppflags -DANON_CAN_RESUME
+ use resolveids && append-cppflags -DALWAYS_RESOLVE_IDS
+
+ # Do not auto-use SSP -- let the user select this.
+ export ax_cv_check_cflags___fstack_protector_all=no
+
+ econf \
+ --with-altlog \
+ --with-cookie \
+ --with-diraliases \
+ --with-extauth \
+ --with-ftpwho \
+ --with-language=${PUREFTPD_LANG:=english} \
+ --with-peruserlimits \
+ --with-privsep \
+ --with-puredb \
+ --with-quotas \
+ --with-ratios \
+ --with-throttling \
+ --with-uploadscript \
+ --with-virtualhosts \
+ --enable-largefile \
+ ${my_conf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS CONTACT ChangeLog FAQ HISTORY INSTALL README* NEWS
+
+ newconfd "${FILESDIR}/pure-ftpd.conf_d-3" ${PN}
+
+ if use implicittls ; then
+ sed -i '/^SERVER/s@21@990@' "${ED}"/etc/conf.d/${PN} \
+ || die "Adjusting default server port for implicittls usage failed!"
+ fi
+
+ newinitd "${FILESDIR}/pure-ftpd.rc11" pure-ftpd
+
+ dodir /var/lib/run/${PN}
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/pure-ftpd.xinetd" pure-ftpd
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins pureftpd.schema
+ insinto /etc/openldap
+ insopts -m 0600
+ doins pureftpd-ldap.conf
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog
+ elog "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file!"
+ elog
+ ewarn "It's *really* important to read the README provided with Pure-FTPd!"
+ ewarn "Check out http://download.pureftpd.org/pub/pure-ftpd/doc/README for general info"
+ ewarn "and http://download.pureftpd.org/pub/pure-ftpd/doc/README.TLS for SSL/TLS info."
+ ewarn
+ if use charconv ; then
+ ewarn "Charset conversion is an *experimental* feature!"
+ ewarn "Remember to set a valid charset for your filesystem in the configuration!"
+ fi
+ fi
+}