summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-09-16 16:33:26 +0000
committerJeroen Roovers <jer@gentoo.org>2011-09-16 16:33:26 +0000
commitc06c0a7765322df4fb9a19199963ade464fd055a (patch)
treebc3210b4f4c2aaf9d46157ba5f2ee8993559f410 /net-ftp
parentVersion bump. Removed older version. (diff)
downloadgentoo-2-c06c0a7765322df4fb9a19199963ade464fd055a.tar.gz
gentoo-2-c06c0a7765322df4fb9a19199963ade464fd055a.tar.bz2
gentoo-2-c06c0a7765322df4fb9a19199963ade464fd055a.zip
Version bump.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.3.2.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 328e45601719..9616615d7d9d 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.318 2011/08/28 17:25:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.319 2011/09/16 16:33:26 jer Exp $
+
+*lftp-4.3.2 (16 Sep 2011)
+
+ 16 Sep 2011; Jeroen Roovers <jer@gentoo.org> +lftp-4.3.2.ebuild:
+ Version bump.
28 Aug 2011; Jeroen Roovers <jer@gentoo.org> -lftp-4.2.3.ebuild,
-lftp-4.3.0.ebuild:
diff --git a/net-ftp/lftp/lftp-4.3.2.ebuild b/net-ftp/lftp/lftp-4.3.2.ebuild
new file mode 100644
index 000000000000..c19972c621a8
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.3.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.3.2.ebuild,v 1.1 2011/09/16 16:33:26 jer Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ =sys-devel/libtool-2*
+ app-arch/xz-utils
+ dev-lang/perl
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.0.2.91-lafile.patch"
+ epatch "${FILESDIR}/${PN}-4.0.3-autoconf-2.64.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}