summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-12 15:35:18 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-12 15:35:18 +0000
commitb1a93a1a43bd64c3dc6339ca90864e6b9864c263 (patch)
tree0b7683a9927b753ade395a19e781a448d0d24128 /net-ftp
parentncmpcpp: added myself as co-maintainer (diff)
downloadgentoo-2-b1a93a1a43bd64c3dc6339ca90864e6b9864c263.tar.gz
gentoo-2-b1a93a1a43bd64c3dc6339ca90864e6b9864c263.tar.bz2
gentoo-2-b1a93a1a43bd64c3dc6339ca90864e6b9864c263.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.0.9.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 7c4604445fb4..4a43c23eddb5 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.261 2010/05/25 17:22:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.262 2010/06/12 15:35:18 jer Exp $
+
+*lftp-4.0.9 (12 Jun 2010)
+
+ 12 Jun 2010; Jeroen Roovers <jer@gentoo.org> +lftp-4.0.9.ebuild:
+ Version bump.
*lftp-4.0.8 (25 May 2010)
diff --git a/net-ftp/lftp/lftp-4.0.9.ebuild b/net-ftp/lftp/lftp-4.0.9.ebuild
new file mode 100644
index 000000000000..ef9eb86b9344
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.0.9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.0.9.ebuild,v 1.1 2010/06/12 15:35:18 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.0.2.91-lafile.patch"
+ epatch "${FILESDIR}/${PN}-4.0.3-autoconf-2.64.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}