summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-07-27 15:35:57 +0000
committerJeroen Roovers <jer@gentoo.org>2009-07-27 15:35:57 +0000
commitacf5450a300eb6f29ee80403ced7f9c766c309ec (patch)
tree42617f0e62a000eb8cf71313093384c4ab86391e /net-ftp
parentAdd die statements for sed, remove unneeded $IUSE. (diff)
downloadgentoo-2-acf5450a300eb6f29ee80403ced7f9c766c309ec.tar.gz
gentoo-2-acf5450a300eb6f29ee80403ced7f9c766c309ec.tar.bz2
gentoo-2-acf5450a300eb6f29ee80403ced7f9c766c309ec.zip
Patch to use pkgconfig instead of foo-config so that gnutls is found (bug #278789).
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog9
-rw-r--r--net-ftp/lftp/files/lftp-gnutls.patch19
-rw-r--r--net-ftp/lftp/lftp-3.7.15-r1.ebuild66
3 files changed, 93 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index e8642df0cdcb..5c59bc12048a 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.207 2009/07/27 05:02:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.208 2009/07/27 15:35:57 jer Exp $
+
+*lftp-3.7.15-r1 (27 Jul 2009)
+
+ 27 Jul 2009; Jeroen Roovers <jer@gentoo.org> +lftp-3.7.15-r1.ebuild,
+ +files/lftp-gnutls.patch:
+ Patch to use pkgconfig instead of foo-config so that gnutls is found (bug
+ #278789).
*lftp-3.99.4 (27 Jul 2009)
diff --git a/net-ftp/lftp/files/lftp-gnutls.patch b/net-ftp/lftp/files/lftp-gnutls.patch
new file mode 100644
index 000000000000..4e228915a86d
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-gnutls.patch
@@ -0,0 +1,19 @@
+ Patch kindly provided by Andreas Metzler at
+ http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=529906#10 -JeR
+
+
+--- lftp-3.7.14/configure.ac 2009-05-15 08:22:34.000000000 +0200
++++ lftp.configure.ac 2009-06-13 12:58:39.000000000 +0200
+@@ -266,9 +266,10 @@
+ with_gnutls=no;;
+ esac
+ if test x$with_gnutls = xyes; then
+- AM_PATH_LIBGNUTLS([1.0.0], [
++ PKG_PROG_PKG_CONFIG
++ PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.0], [
+ AC_DEFINE([USE_GNUTLS], 1, [Define to 1 when using GNU TLS library])
+- gnutls_version_code=`echo $libgnutls_config_version | $AWK -F. '{ printf "0x%02X%02X%02X\n",$1,$2,$3 }'`
++ gnutls_version_code=`$PKG_CONFIG --modversion gnutls | $AWK -F. '{ printf "0x%02X%02X%02X\n",$1,$2,$3 }'`
+ AC_DEFINE_UNQUOTED([LFTP_LIBGNUTLS_VERSION_CODE], $gnutls_version_code, [Define to libgnutls version, e.g. 0x010203 for 1.2.3])
+ ])
+ fi
diff --git a/net-ftp/lftp/lftp-3.7.15-r1.ebuild b/net-ftp/lftp/lftp-3.7.15-r1.ebuild
new file mode 100644
index 000000000000..01677399a525
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.7.15-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.7.15-r1.ebuild,v 1.1 2009/07/27 15:35:57 jer Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-gnutls.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}