summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-09-23 23:53:49 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-09-23 23:53:49 +0000
commita7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478 (patch)
tree32d74f827ab1f2ddcebfcf0e55a6e25893063363 /net-ftp
parentVersion bump, closes bug #148518. (diff)
downloadgentoo-2-a7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478.tar.gz
gentoo-2-a7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478.tar.bz2
gentoo-2-a7c0b6cdc65ee47a85af7d8c46b61bf52f3fa478.zip
Cleanup ebuilds. Version bump to 0.3. Fix bugs.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pureadmin/ChangeLog8
-rw-r--r--net-ftp/pureadmin/files/digest-pureadmin-0.33
-rw-r--r--net-ftp/pureadmin/pureadmin-0.2.2.ebuild48
-rw-r--r--net-ftp/pureadmin/pureadmin-0.3.ebuild55
4 files changed, 91 insertions, 23 deletions
diff --git a/net-ftp/pureadmin/ChangeLog b/net-ftp/pureadmin/ChangeLog
index acb9965bd4a2..59fd412c5e12 100644
--- a/net-ftp/pureadmin/ChangeLog
+++ b/net-ftp/pureadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/pureadmin
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.9 2006/09/22 11:11:18 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/ChangeLog,v 1.10 2006/09/23 23:53:49 chtekk Exp $
+
+*pureadmin-0.3 (23 Sep 2006)
+
+ 23 Sep 2006; Luca Longinotti <chtekk@gentoo.org> pureadmin-0.2.2.ebuild,
+ +pureadmin-0.3.ebuild:
+ Cleanup ebuilds. Version bump to 0.3. Fix bugs #70024 and #78748.
22 Sep 2006; Luca Longinotti <chtekk@gentoo.org> metadata.xml:
Set myself as maintainer.
diff --git a/net-ftp/pureadmin/files/digest-pureadmin-0.3 b/net-ftp/pureadmin/files/digest-pureadmin-0.3
new file mode 100644
index 000000000000..32978843b4c1
--- /dev/null
+++ b/net-ftp/pureadmin/files/digest-pureadmin-0.3
@@ -0,0 +1,3 @@
+MD5 f7dc9fc7163b957bbcec1d4b2eec196d pureadmin-0.3.tar.gz 298177
+RMD160 80a81b75051d4d2ff29222883109d42f78bb2cf8 pureadmin-0.3.tar.gz 298177
+SHA256 cec867194ee8c2e647dedf0d3d152c033a1bcdfaf3b1e83869b3ada8d9d3e866 pureadmin-0.3.tar.gz 298177
diff --git a/net-ftp/pureadmin/pureadmin-0.2.2.ebuild b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
index 678f733cb8b3..d996ea30417e 100644
--- a/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
+++ b/net-ftp/pureadmin/pureadmin-0.2.2.ebuild
@@ -1,51 +1,55 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.2.2.ebuild,v 1.1 2005/09/06 22:39:09 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.2.2.ebuild,v 1.2 2006/09/23 23:53:49 chtekk Exp $
inherit eutils
-IUSE="debug gnome doc"
-DESCRIPTION="PureAdmin is a GUI tool used to make the management of PureFTPd a little easier."
-HOMEPAGE="http://purify.sourceforge.net"
+KEYWORDS="amd64 ~ppc x86"
+
+DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
+HOMEPAGE="http://purify.sourceforge.net/"
SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ~ppc"
-DEPEND="sys-libs/glibc
- sys-libs/zlib
- >=x11-libs/gtk+-2.0"
+IUSE="debug doc"
+
+DEPEND=">=gnome-base/libglade-2.0
+ sys-libs/zlib
+ virtual/fam
+ >=x11-libs/gtk+-2.0"
+RDEPEND="${DEPEND}"
src_compile() {
local myconf=""
use debug && myconf="${myconf} --enable-debug"
- econf ${myconf} || die "configure failed"
+ econf ${myconf} || die "econf failed"
emake || die "emake failed"
}
src_install() {
- einstall || die "einstall failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
- # Move the docs to the correct location
- if use doc; then
- dodoc ${D}usr/share/doc/pureadmin/*.txt
- rm -rf ${D}usr/share/doc/pureadmin
+ # Move the docs to the correct location, if we want the docs
+ if use doc ; then
+ dodoc "${D}/usr/share/doc/pureadmin/*.txt"
fi
+ rm -Rf "${D}/usr/share/doc/pureadmin"
- make_desktop_entry pureadmin "Pure-ftp menu config" pureadmin
+ make_desktop_entry pureadmin "Pure-FTPd menu config" pureadmin
}
pkg_postinst() {
- echo
- ewarn "PureAdmin is at an alpha-stage right now and it may break"
- ewarn "your configuration. DO NOT use it for safety critical system"
+ einfo
+ ewarn "PureAdmin is at a beta-stage right now and it may break your"
+ ewarn "configuration. DO NOT use it for safety critical system"
ewarn "or production use!"
- echo
- einfo "You need root-privileges to be able to use PureAdmin as for now."
+ einfo
+ einfo "You need root-privileges to be able to use PureAdmin."
einfo "This will probably change in the future."
- echo
+ einfo
}
diff --git a/net-ftp/pureadmin/pureadmin-0.3.ebuild b/net-ftp/pureadmin/pureadmin-0.3.ebuild
new file mode 100644
index 000000000000..6e709c4cf38d
--- /dev/null
+++ b/net-ftp/pureadmin/pureadmin-0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pureadmin/pureadmin-0.3.ebuild,v 1.1 2006/09/23 23:53:49 chtekk Exp $
+
+inherit eutils
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="PureAdmin is a GUI tool used to make the management of Pure-FTPd a little easier."
+HOMEPAGE="http://purify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug doc"
+
+DEPEND=">=gnome-base/libglade-2.0
+ sys-libs/zlib
+ virtual/fam
+ >=x11-libs/gtk+-2.0"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Move the docs to the correct location, if we want the docs
+ if use doc ; then
+ dodoc "${D}/usr/share/doc/pureadmin/*.txt"
+ fi
+ rm -Rf "${D}/usr/share/doc/pureadmin"
+
+ make_desktop_entry pureadmin "Pure-FTPd menu config" pureadmin
+}
+
+pkg_postinst() {
+ einfo
+ ewarn "PureAdmin is at a beta-stage right now and it may break your"
+ ewarn "configuration. DO NOT use it for safety critical system"
+ ewarn "or production use!"
+ einfo
+ einfo "You need root-privileges to be able to use PureAdmin."
+ einfo "This will probably change in the future."
+ einfo
+}