summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-27 17:34:59 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-27 17:34:59 +0000
commit92440c8d33821c01068cf3aa6f3a8ab79628b0be (patch)
tree8dbe51e8662f75b27ad24a86e5e99a0b279912dc /net-ftp
parentCleanup superseded EAPI1 ebuild. (diff)
downloadgentoo-2-92440c8d33821c01068cf3aa6f3a8ab79628b0be.tar.gz
gentoo-2-92440c8d33821c01068cf3aa6f3a8ab79628b0be.tar.bz2
gentoo-2-92440c8d33821c01068cf3aa6f3a8ab79628b0be.zip
Cleanup superseded EAPI1 ebuild.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/axyftp/ChangeLog10
-rw-r--r--net-ftp/axyftp/axyftp-0.5.1-r2.ebuild43
2 files changed, 50 insertions, 3 deletions
diff --git a/net-ftp/axyftp/ChangeLog b/net-ftp/axyftp/ChangeLog
index 173454759cbe..164ff5032954 100644
--- a/net-ftp/axyftp/ChangeLog
+++ b/net-ftp/axyftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/axyftp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/ChangeLog,v 1.9 2012/10/24 19:21:00 ulm Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/ChangeLog,v 1.10 2014/10/27 17:34:59 mrueg Exp $
+
+*axyftp-0.5.1-r2 (27 Oct 2014)
+
+ 27 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +axyftp-0.5.1-r2.ebuild:
+ Cleanup superseded EAPI1 ebuild.
24 Oct 2012; Ulrich Müller <ulm@gentoo.org> axyftp-0.5.1-r1.ebuild:
Update dependency after package move from x11-libs/openmotif to
@@ -33,4 +38,3 @@
27 Jan 2004; Martin Holzer <mholzer@gentoo.org> axyftp-0.5.1.ebuild:
Initial ebuild. Submitted by Jan Schubert <Jan.Schubert@GMX.li> in #36856
-
diff --git a/net-ftp/axyftp/axyftp-0.5.1-r2.ebuild b/net-ftp/axyftp/axyftp-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..ecc3e0afe556
--- /dev/null
+++ b/net-ftp/axyftp/axyftp-0.5.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/axyftp/axyftp-0.5.1-r2.ebuild,v 1.1 2014/10/27 17:34:59 mrueg Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="GUI FTP client for X Window System (former WXftp)"
+HOMEPAGE="http://freecode.com/projects/axyftp/ http://www.wxftp.seul.org"
+SRC_URI="http://www.wxftp.seul.org/download/${P}.tar.gz"
+
+LICENSE="Artistic LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/motif-2.3:0
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-built-in-function-exit.patch
+}
+
+src_configure(){
+ econf --with-help=/usr/share/doc/${PF}/html \
+ --with-gui=motif
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES README TODO
+ newicon icons/${PN}-ball64.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "AxY FTP" ${PN} "Network;FileTransfer;Motif"
+}