summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-15 14:28:25 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-15 14:28:25 +0000
commit53ea2ef9c21ed8871b5442016bacfdaf8d67d488 (patch)
tree9774c67efef71718648310ec8707289a38f817af /net-ftp
parentStable on alpha, bug 516658 (diff)
downloadgentoo-2-53ea2ef9c21ed8871b5442016bacfdaf8d67d488.tar.gz
gentoo-2-53ea2ef9c21ed8871b5442016bacfdaf8d67d488.tar.bz2
gentoo-2-53ea2ef9c21ed8871b5442016bacfdaf8d67d488.zip
Fix building with USE=-ssl. Replace net-libs/gnutls-2 compatibility patch with upstream patch. Remove patch that no longer applies -9999.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/lftp-4.6.0-gnutls-2-compat.patch36
-rw-r--r--net-ftp/lftp/files/lftp-4.6.0-no-ssl.patch29
-rw-r--r--net-ftp/lftp/lftp-4.6.0.ebuild5
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild3
5 files changed, 63 insertions, 18 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index a10c3e62e724..11d59f12f4d7 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.489 2014/10/14 08:56:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.490 2014/10/15 14:28:25 jer Exp $
+
+ 15 Oct 2014; Jeroen Roovers <jer@gentoo.org> lftp-4.6.0.ebuild,
+ lftp-9999.ebuild, files/lftp-4.6.0-gnutls-2-compat.patch,
+ +files/lftp-4.6.0-no-ssl.patch:
+ Fix building with USE=-ssl. Replace net-libs/gnutls-2 compatibility patch
+ with upstream patch. Remove patch that no longer applies -9999.
14 Oct 2014; Jeroen Roovers <jer@gentoo.org> lftp-4.6.0.ebuild,
+files/lftp-4.6.0-gnutls-2-compat.patch:
diff --git a/net-ftp/lftp/files/lftp-4.6.0-gnutls-2-compat.patch b/net-ftp/lftp/files/lftp-4.6.0-gnutls-2-compat.patch
index 3fe6a9db21d9..4382be08f711 100644
--- a/net-ftp/lftp/files/lftp-4.6.0-gnutls-2-compat.patch
+++ b/net-ftp/lftp/files/lftp-4.6.0-gnutls-2-compat.patch
@@ -1,15 +1,25 @@
+From 21823aa2b496509a7bc9bed2141d06df35d25b63 Mon Sep 17 00:00:00 2001
+From: "Alexander V. Lukyanov" <lavv17f@gmail.com>
+Date: Wed, 15 Oct 2014 08:50:19 +0400
+Subject: [PATCH] lftp_ssl.cc: fixed compilation with gnutls version < 3.0
+
+---
+ src/lftp_ssl.cc | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/lftp_ssl.cc b/src/lftp_ssl.cc
+index 100b90b..8ef8a8d 100644
--- a/src/lftp_ssl.cc
+++ b/src/lftp_ssl.cc
-@@ -560,7 +560,11 @@
- {
- if(res==GNUTLS_E_AGAIN || res==GNUTLS_E_INTERRUPTED)
- return RETRY;
-- else if(res==GNUTLS_E_UNEXPECTED_PACKET_LENGTH || res==GNUTLS_E_PREMATURE_TERMINATION)
-+ else if(res==GNUTLS_E_UNEXPECTED_PACKET_LENGTH
-+#if LFTP_LIBGNUTLS_VERSION_CODE >= 0x030000
-+ || res==GNUTLS_E_PREMATURE_TERMINATION
-+#endif /* LFTP_LIBGNUTLS_VERSION_CODE */
-+ )
- {
- Log::global->Format(7,"gnutls_record_recv: %s Assuming EOF.\n",gnutls_strerror(res));
- return 0;
+@@ -547,6 +547,11 @@ int lftp_ssl_gnutls::do_handshake()
+
+ return DONE;
+ }
++
++#ifndef GNUTLS_E_PREMATURE_TERMINATION // for gnutls < 3.0
++# define GNUTLS_E_PREMATURE_TERMINATION GNUTLS_E_UNEXPECTED_PACKET_LENGTH
++#endif
++
+ int lftp_ssl_gnutls::read(char *buf,int size)
+ {
+ if(error)
diff --git a/net-ftp/lftp/files/lftp-4.6.0-no-ssl.patch b/net-ftp/lftp/files/lftp-4.6.0-no-ssl.patch
new file mode 100644
index 000000000000..885733315c15
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.6.0-no-ssl.patch
@@ -0,0 +1,29 @@
+From db25961b46c591aecaa18e824e57a2af3d379d08 Mon Sep 17 00:00:00 2001
+From: "Alexander V. Lukyanov" <lavv17f@gmail.com>
+Date: Wed, 15 Oct 2014 08:46:09 +0400
+Subject: [PATCH] ftpclass.cc: fixed compilation without SSL (again).
+
+---
+ src/ftpclass.cc | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/ftpclass.cc b/src/ftpclass.cc
+index 130704d..bc148bc 100644
+--- a/src/ftpclass.cc
++++ b/src/ftpclass.cc
+@@ -1610,12 +1610,12 @@ int Ftp::Do()
+
+ if(expect->Has(Expect::FEAT)
+ || expect->Has(Expect::OPTS_UTF8)
+- || expect->Has(Expect::LANG)
+- || expect->Has(Expect::PROT))
++ || expect->Has(Expect::LANG))
+ goto usual_return;
+
+ #if USE_SSL
+- if(expect->Has(Expect::CCC))
++ if(expect->Has(Expect::CCC)
++ || expect->Has(Expect::PROT))
+ goto usual_return;
+ #endif // USE_SSL
+
diff --git a/net-ftp/lftp/lftp-4.6.0.ebuild b/net-ftp/lftp/lftp-4.6.0.ebuild
index 0c2b74cf97f9..37ef6a387065 100644
--- a/net-ftp/lftp/lftp-4.6.0.ebuild
+++ b/net-ftp/lftp/lftp-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.6.0.ebuild,v 1.2 2014/10/14 08:56:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.6.0.ebuild,v 1.3 2014/10/15 14:28:25 jer Exp $
EAPI=5
inherit autotools eutils libtool
@@ -61,7 +61,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-4.3.8-gets.patch \
"${FILESDIR}"/${PN}-4.5.3-autopoint.patch \
"${FILESDIR}"/${PN}-4.5.5-am_config_header.patch \
- "${FILESDIR}"/${PN}-4.6.0-gnutls-2-compat.patch
+ "${FILESDIR}"/${PN}-4.6.0-gnutls-2-compat.patch \
+ "${FILESDIR}"/${PN}-4.6.0-no-ssl.patch
eautoreconf
elibtoolize # for Darwin bundles
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index f57824ed66b8..6eed6f3097a2 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-9999.ebuild,v 1.2 2014/10/13 19:28:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-9999.ebuild,v 1.3 2014/10/15 14:28:25 jer Exp $
EAPI=5
inherit autotools eutils git-r3 libtool
@@ -58,7 +58,6 @@ DOCS=(
src_prepare() {
epatch \
- "${FILESDIR}"/${PN}-4.0.2.91-lafile.patch \
"${FILESDIR}"/${PN}-4.5.3-autopoint.patch \
"${FILESDIR}"/${PN}-4.5.5-am_config_header.patch