summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-03 12:53:16 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-03 12:53:16 +0000
commit5207ecc3ebc74d71607fc9cb7bb801f18e24bc40 (patch)
tree86bcebf99bf0fdd4f31a64bed07ab5cf3c947fbf /net-ftp
parentx86 stable wrt bug #355739 (diff)
downloadgentoo-2-5207ecc3ebc74d71607fc9cb7bb801f18e24bc40.tar.gz
gentoo-2-5207ecc3ebc74d71607fc9cb7bb801f18e24bc40.tar.bz2
gentoo-2-5207ecc3ebc74d71607fc9cb7bb801f18e24bc40.zip
Respect CFLAGS, add transparent support and more fixes, bug #406483 by Bertrand Jacquin. Drop old.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/frox/ChangeLog12
-rw-r--r--net-ftp/frox/files/0.7.18-netfilter-includes.patch16
-rw-r--r--net-ftp/frox/files/0.7.18-respect-CFLAGS.patch15
-rw-r--r--net-ftp/frox/frox-0.7.18-r4.ebuild (renamed from net-ftp/frox/frox-0.7.18-r3.ebuild)51
-rw-r--r--net-ftp/frox/metadata.xml3
5 files changed, 75 insertions, 22 deletions
diff --git a/net-ftp/frox/ChangeLog b/net-ftp/frox/ChangeLog
index 1f960ea4df14..93903d425760 100644
--- a/net-ftp/frox/ChangeLog
+++ b/net-ftp/frox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-ftp/frox
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/frox/ChangeLog,v 1.16 2011/07/20 14:44:12 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/frox/ChangeLog,v 1.17 2012/03/03 12:53:16 pacho Exp $
+
+*frox-0.7.18-r4 (03 Mar 2012)
+
+ 03 Mar 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/0.7.18-netfilter-includes.patch, +files/0.7.18-respect-CFLAGS.patch,
+ +frox-0.7.18-r4.ebuild, -frox-0.7.18-r3.ebuild, metadata.xml:
+ Respect CFLAGS, add transparent support and more fixes, bug #406483 by
+ Bertrand Jacquin. Drop old.
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34534
diff --git a/net-ftp/frox/files/0.7.18-netfilter-includes.patch b/net-ftp/frox/files/0.7.18-netfilter-includes.patch
new file mode 100644
index 000000000000..e40ce52862c9
--- /dev/null
+++ b/net-ftp/frox/files/0.7.18-netfilter-includes.patch
@@ -0,0 +1,16 @@
+--- configure.in.ori 2012-03-01 22:32:17.044450088 +0100
++++ configure.in 2012-03-01 22:36:40.995882948 +0100
+@@ -331,7 +331,12 @@
+ AC_HEADER_STDC
+ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(fcntl.h strings.h sys/ioctl.h sys/time.h syslog.h unistd.h)
+-AC_CHECK_HEADERS(linux/netfilter_ipv4.h, , , [#include <limits.h>])
++AC_CHECK_HEADERS(linux/netfilter_ipv4.h, , ,[
++ #include <limits.h>
++ #include <sys/socket.h>
++ #include <linux/in.h>
++ #include <linux/in6.h>
++])
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
diff --git a/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch b/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch
new file mode 100644
index 000000000000..9fb54ac153cd
--- /dev/null
+++ b/net-ftp/frox/files/0.7.18-respect-CFLAGS.patch
@@ -0,0 +1,15 @@
+--- configure.in 2005-02-04 11:24:55.000000000 +0100
++++ configure.in 2012-03-01 22:56:25.985725178 +0100
+@@ -46,11 +46,9 @@
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+- CFLAGS="$CFLAGS -O2"
+ ;;
+ esac],
+- [AC_MSG_RESULT(no)
+- CFLAGS="$CFLAGS -O2"]
++ [AC_MSG_RESULT(no)]
+ )
+
+ AC_MSG_CHECKING(whether to compile in profiling info)
diff --git a/net-ftp/frox/frox-0.7.18-r3.ebuild b/net-ftp/frox/frox-0.7.18-r4.ebuild
index 8c37d6b2ccd5..e61fb6dd5991 100644
--- a/net-ftp/frox/frox-0.7.18-r3.ebuild
+++ b/net-ftp/frox/frox-0.7.18-r4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/frox/frox-0.7.18-r3.ebuild,v 1.1 2008/04/02 07:56:34 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/frox/frox-0.7.18-r4.ebuild,v 1.1 2012/03/03 12:53:16 pacho Exp $
-inherit eutils
+EAPI=4
+inherit eutils autotools
-IUSE="clamav"
+IUSE="clamav ssl transparent"
MY_P=${P/_/}
S=${WORKDIR}/${MY_P}
@@ -16,28 +17,39 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-DEPEND="clamav? ( >=app-antivirus/clamav-0.80 )"
+DEPEND="clamav? ( >=app-antivirus/clamav-0.80 )
+ ssl? ( dev-libs/openssl )
+ kernel_linux? ( >=sys-kernel/linux-headers-2.6 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
enewgroup ftpproxy
enewuser ftpproxy -1 -1 /var/spool/frox ftpproxy
+
+ use clamav && ewarn "Virus scanner potentialy broken in chroot - see bug #81035"
}
-src_compile() {
+src_prepare () {
+ epatch "${FILESDIR}"/${PV}-respect-CFLAGS.patch
+ epatch "${FILESDIR}"/${PV}-netfilter-includes.patch
+
+ eautoreconf
+}
+src_configure() {
econf \
- --sbindir=/usr/sbin \
- --localstatedir=/var/run \
- --sysconfdir=/etc \
--enable-http-cache --enable-local-cache \
- --enable-transparent-data \
- $(use_enable clamav virus-scan) || die "bad ./configure"
-
- emake || die "compile problem"
+ --enable-procname \
+ --enable-configfile=/etc/frox.conf \
+ $(use_enable !kernel_linux libiptc) \
+ $(use_enable clamav virus-scan) \
+ $(use_enable ssl) \
+ $(use_enable transparent transparent-data) \
+ $(use_enable !transparent ntp)
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR=${D} install
keepdir /var/run/frox
keepdir /var/spool/frox
@@ -63,11 +75,10 @@ src_install() {
cd src
epatch ${FILESDIR}/config-${PV}.patch || die "config patch failed"
- if use clamav; then
- sed -e "s:^# VirusScanner.*:# VirusScanner '\"/usr/bin/clamscan\" \"%s\"':" \
- frox.conf > ${D}/etc/frox.conf.example
- ewarn "Virus scanner potentialy broken in chroot - see bug #81035."
- else
- cp frox.conf ${D}/etc/frox.conf.example
+ cp frox.conf ${D}/etc/frox.conf.example
+ if use clamav ; then
+ sed -i \
+ -e "s:^# VirusScanner.*:# VirusScanner '\"/usr/bin/clamscan\" \"%s\"':" \
+ ${D}/etc/frox.conf.example || die
fi
}
diff --git a/net-ftp/frox/metadata.xml b/net-ftp/frox/metadata.xml
index 1076258a0ce8..8c7655503a2b 100644
--- a/net-ftp/frox/metadata.xml
+++ b/net-ftp/frox/metadata.xml
@@ -4,5 +4,8 @@
<maintainer>
<email>maintainer-needed@gentoo.org</email>
</maintainer>
+<use>
+<flag name="transparent">Enable transparent proxying of data connections</flag>
+</use>
<longdescription></longdescription>
</pkgmetadata>