summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-22 20:26:46 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-22 20:26:46 +0000
commit295f1da41071725ee7e490d635c6129f0baaa685 (patch)
treee7124321d3418333f50bab831f13f0fb1facefaf /net-ftp
parentFix from upstream for missing asm/cmpxchg.h on ia64 #427622 by Tobias Ulmer. (diff)
downloadgentoo-2-295f1da41071725ee7e490d635c6129f0baaa685.tar.gz
gentoo-2-295f1da41071725ee7e490d635c6129f0baaa685.tar.bz2
gentoo-2-295f1da41071725ee7e490d635c6129f0baaa685.zip
Fix fortify errors for real #425184 by Robin Kauffman.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/netkit-tftp/ChangeLog6
-rw-r--r--net-ftp/netkit-tftp/files/netkit-tftp-0.17-overflow.patch55
-rw-r--r--net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild4
3 files changed, 7 insertions, 58 deletions
diff --git a/net-ftp/netkit-tftp/ChangeLog b/net-ftp/netkit-tftp/ChangeLog
index da59722cd6ef..d09bc93d94f3 100644
--- a/net-ftp/netkit-tftp/ChangeLog
+++ b/net-ftp/netkit-tftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/netkit-tftp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/ChangeLog,v 1.25 2012/07/08 17:42:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/ChangeLog,v 1.26 2012/07/22 20:26:46 vapier Exp $
+
+ 22 Jul 2012; Mike Frysinger <vapier@gentoo.org>
+ -files/netkit-tftp-0.17-overflow.patch, netkit-tftp-0.17-r8.ebuild:
+ Fix fortify errors for real #425184 by Robin Kauffman.
*netkit-tftp-0.17-r8 (08 Jul 2012)
diff --git a/net-ftp/netkit-tftp/files/netkit-tftp-0.17-overflow.patch b/net-ftp/netkit-tftp/files/netkit-tftp-0.17-overflow.patch
deleted file mode 100644
index 64925a244ed9..000000000000
--- a/net-ftp/netkit-tftp/files/netkit-tftp-0.17-overflow.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-Index: netkit-tftp-0.17/tftp/tftp.c
-===================================================================
---- netkit-tftp-0.17.orig/tftp/tftp.c
-+++ netkit-tftp-0.17/tftp/tftp.c
-@@ -56,6 +56,7 @@ char tftp_rcsid[] =
- #include <setjmp.h>
- #include <unistd.h>
- #include <string.h>
-+#include <stddef.h>
-
- #include "tftpsubs.h"
-
-@@ -78,7 +79,7 @@ static sigjmp_buf timeoutbuf;
-
-
- static int makerequest(int request, char *name,
-- struct tftphdr *tp, char *mode);
-+ char *hdr, char *mode);
- static void nak(int errnor);
- static void tpacket(const char *s, struct tftphdr *tp, int n);
- static void startclock(void);
-@@ -126,7 +127,7 @@ sendfile(int fd, char *name, char *mode)
- mysignal(SIGALRM, timer);
- do {
- if (firsttrip) {
-- size = makerequest(WRQ, name, dp, mode) - 4;
-+ size = makerequest(WRQ, name, (char*)dp, mode) - 4;
- }
- else {
- /* size = read(fd, dp->th_data, SEGSIZE); */
-@@ -238,7 +239,7 @@ recvfile(int fd, char *name, char *mode)
- mysignal(SIGALRM, timer);
- do {
- if (firsttrip) {
-- size = makerequest(RRQ, name, ap, mode);
-+ size = makerequest(RRQ, name, ackbuf, mode);
- firsttrip = 0;
- } else {
- ap->th_opcode = htons((u_short)ACK);
-@@ -320,12 +321,13 @@ abort:
- }
-
- int
--makerequest(int request, char *name, struct tftphdr *tp, char *mode)
-+makerequest(int request, char *name, char *hdr, char *mode)
- {
- register char *cp;
-+ struct tftphdr *tp = (struct tftphdr*)hdr;
-
- tp->th_opcode = htons((u_short)request);
-- cp = tp->th_stuff;
-+ cp = hdr + offsetof(struct tftphdr, th_stuff);
- strcpy(cp, name);
- cp += strlen(name);
- *cp++ = '\0';
diff --git a/net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild b/net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild
index df3f2330f63b..de3690a04097 100644
--- a/net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild
+++ b/net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild,v 1.1 2012/07/08 17:42:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/netkit-tftp/netkit-tftp-0.17-r8.ebuild,v 1.2 2012/07/22 20:26:46 vapier Exp $
EAPI=4
@@ -37,7 +37,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-tftp-fix-put-zero-size.diff
epatch "${FILESDIR}"/${P}-tftpd-put-fixes.patch
epatch "${FILESDIR}"/${P}-socket-reopen-on-errors.patch
- epatch "${FILESDIR}"/${P}-overflow.patch
+ rm include/arpa/tftp.h || die #425184
}
src_configure() {