summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-03 08:28:18 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-03 08:28:18 +0000
commit1d5a948588b78fab24b498df55cde35f6973627a (patch)
tree3498fcd52c8543d78da88e30d7add002056ec9f3 /net-ftp
parentremove ftp://ftp.digitaltrust.it due to lack of response (diff)
downloadgentoo-2-1d5a948588b78fab24b498df55cde35f6973627a.tar.gz
gentoo-2-1d5a948588b78fab24b498df55cde35f6973627a.tar.bz2
gentoo-2-1d5a948588b78fab24b498df55cde35f6973627a.zip
version bump as per bug #248434 thanks to 7v5w7go9ub0o. noting license change to GPL-3
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog10
-rw-r--r--net-ftp/lftp/lftp-3.7.7.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index aa25b302e0a4..28242e5a9c99 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.163 2008/11/06 11:46:13 dragonheart Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.164 2009/01/03 08:28:18 dragonheart Exp $
+
+*lftp-3.7.7 (03 Jan 2009)
+
+ 03 Jan 2009; Daniel Black <dragonheart@gentoo.org> +lftp-3.7.7.ebuild:
+ version bump as per bug #248434 thanks to 7v5w7go9ub0o. noting license
+ change to GPL-3
06 Nov 2008; Daniel Black <dragonheart@gentoo.org> -lftp-3.5.14.ebuild:
old version purge
diff --git a/net-ftp/lftp/lftp-3.7.7.ebuild b/net-ftp/lftp/lftp-3.7.7.ebuild
new file mode 100644
index 000000000000..40d621258226
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.7.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.7.7.ebuild,v 1.1 2009/01/03 08:28:18 dragonheart Exp $
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}