summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-18 15:15:31 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-18 15:15:31 +0000
commit0e167114eb90e051e0b1286f7637688fa8e72bd0 (patch)
treeb92ac672edaf34848117a97f03c9000af0b0d19c /net-ftp
parentVersion bump. (diff)
downloadgentoo-2-0e167114eb90e051e0b1286f7637688fa8e72bd0.tar.gz
gentoo-2-0e167114eb90e051e0b1286f7637688fa8e72bd0.tar.bz2
gentoo-2-0e167114eb90e051e0b1286f7637688fa8e72bd0.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-4.2.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index a791cd315232..445359b61476 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.297 2011/04/04 16:07:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.298 2011/04/18 15:15:31 jer Exp $
+
+*lftp-4.2.2 (18 Apr 2011)
+
+ 18 Apr 2011; Jeroen Roovers <jer@gentoo.org> +lftp-4.2.2.ebuild:
+ Version bump.
*lftp-4.2.1 (04 Apr 2011)
diff --git a/net-ftp/lftp/lftp-4.2.2.ebuild b/net-ftp/lftp/lftp-4.2.2.ebuild
new file mode 100644
index 000000000000..c8ca6be710b3
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.2.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.2.2.ebuild,v 1.1 2011/04/18 15:15:31 jer Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-4.0.2.91-lafile.patch"
+ epatch "${FILESDIR}/${PN}-4.0.3-autoconf-2.64.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}