summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-10-09 08:45:53 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-10-09 08:45:53 +0000
commit73173e4229f96133b89461106abab24f16aec573 (patch)
tree72c2e5672459c4dafb3f7a6659244031328816ef /net-ftp/yafc
parentJapanese category metadata.xml translation. Thanks goes to Yoshino for the t... (diff)
downloadgentoo-2-73173e4229f96133b89461106abab24f16aec573.tar.gz
gentoo-2-73173e4229f96133b89461106abab24f16aec573.tar.bz2
gentoo-2-73173e4229f96133b89461106abab24f16aec573.zip
version bump
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'net-ftp/yafc')
-rw-r--r--net-ftp/yafc/ChangeLog7
-rw-r--r--net-ftp/yafc/Manifest16
-rw-r--r--net-ftp/yafc/files/digest-yafc-1.1.11
-rw-r--r--net-ftp/yafc/yafc-1.1.1.ebuild42
4 files changed, 53 insertions, 13 deletions
diff --git a/net-ftp/yafc/ChangeLog b/net-ftp/yafc/ChangeLog
index d05bd7a97868..605f8f25121a 100644
--- a/net-ftp/yafc/ChangeLog
+++ b/net-ftp/yafc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/yafc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.14 2005/09/16 23:22:35 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/ChangeLog,v 1.15 2005/10/09 08:45:53 dragonheart Exp $
+
+*yafc-1.1.1 (09 Oct 2005)
+
+ 09 Oct 2005; Daniel Black <dragonheart@gentoo.org> +yafc-1.1.1.ebuild:
+ version bump
16 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/net-ftp/yafc/Manifest b/net-ftp/yafc/Manifest
index 917965a23e6b..57f4d167c765 100644
--- a/net-ftp/yafc/Manifest
+++ b/net-ftp/yafc/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 44011aac929360f02f786a44321d861a yafc-1.0.ebuild 801
-MD5 7012fddb5846c4722d1e2b8192f9bba1 yafc-1.1.ebuild 767
MD5 4adb1fa2e18efe05fd82277f37fe4233 ChangeLog 1663
MD5 fc53f7d8ad4e855bf0cfa4139baae246 files/digest-yafc-1.0 61
MD5 17a81b5b4a16ec89dfe5963c885f96ab files/digest-yafc-1.1 61
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDK1P+LLFUmVNQ7rkRAj3tAJ9LjJdUkNjOTyVstnRjN9c65WkuEACglbg4
-uhZBHWD0+dbBgHP0Vaec/s4=
-=vGjh
------END PGP SIGNATURE-----
+MD5 ef6247904f7210ae0c5c607a8db1e828 files/digest-yafc-1.1.1 63
+MD5 44011aac929360f02f786a44321d861a yafc-1.0.ebuild 801
+MD5 8a5dae46e3ecdb2e0453aa1be7e11e91 yafc-1.1.1.ebuild 1320
+MD5 7012fddb5846c4722d1e2b8192f9bba1 yafc-1.1.ebuild 767
diff --git a/net-ftp/yafc/files/digest-yafc-1.1.1 b/net-ftp/yafc/files/digest-yafc-1.1.1
new file mode 100644
index 000000000000..193fd9078fa7
--- /dev/null
+++ b/net-ftp/yafc/files/digest-yafc-1.1.1
@@ -0,0 +1 @@
+MD5 832d074183a36ee15b47553ed5962fce yafc-1.1.1.tar.bz2 858991
diff --git a/net-ftp/yafc/yafc-1.1.1.ebuild b/net-ftp/yafc/yafc-1.1.1.ebuild
new file mode 100644
index 000000000000..c5c5fe5898e0
--- /dev/null
+++ b/net-ftp/yafc/yafc-1.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1.ebuild,v 1.1 2005/10/09 08:45:53 dragonheart Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Console ftp client with a lot of nifty features"
+HOMEPAGE="http://yafc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yafc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="readline krb4 kerberos sock5"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/kth-krb )
+ socks5? ( net-proxy/dante )"
+RDEPEND=">=net-misc/openssh-3.0
+ ${DEPEND}"
+
+src_compile() {
+ local myconf
+ use krb4 && myconf="${myconf} --with-krb4=/usr/athena" \
+ || myconf="${myconf} --with-krb4=no"
+ use kerberos && myconf="${myconf} --with-krb5=/usr/ --with-gssapi=/usr" \
+ || myconf="${myconf} --with-krb5=no --with-gssapi=no"
+ use socks5 && myconf="${myconf} --with-socks5=/usr" \
+ || myconf="${myconf} --with-socks5=no"
+ use readline && myconf="${myconf} --with-readline=/usr" \
+ || myconf="${myconf} --with-readline=no"
+
+
+ econf $(use_with readline) ${myconf} || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc BUGS NEWS README THANKS TODO *.sample
+}