summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-10-09 12:28:13 +0000
committerSven Wegener <swegener@gentoo.org>2005-10-09 12:28:13 +0000
commit73c30e561b5996c705ad88c6d6ca4ab916ec7a6c (patch)
tree06aa821a14ca04b29f06a3e95d03f8137e1211bf /net-ftp/yafc/yafc-1.1.1.ebuild
parentInitial import of ebuild from gentoo.de. (diff)
downloadgentoo-2-73c30e561b5996c705ad88c6d6ca4ab916ec7a6c.tar.gz
gentoo-2-73c30e561b5996c705ad88c6d6ca4ab916ec7a6c.tar.bz2
gentoo-2-73c30e561b5996c705ad88c6d6ca4ab916ec7a6c.zip
trim whitespace; fix IUSE
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'net-ftp/yafc/yafc-1.1.1.ebuild')
-rw-r--r--net-ftp/yafc/yafc-1.1.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-ftp/yafc/yafc-1.1.1.ebuild b/net-ftp/yafc/yafc-1.1.1.ebuild
index c5c5fe5898e0..de4a0e0d55a9 100644
--- a/net-ftp/yafc/yafc-1.1.1.ebuild
+++ b/net-ftp/yafc/yafc-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1.ebuild,v 1.1 2005/10/09 08:45:53 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/yafc/yafc-1.1.1.ebuild,v 1.2 2005/10/09 12:28:13 swegener Exp $
inherit flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/yafc/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="readline krb4 kerberos sock5"
+IUSE="readline krb4 kerberos socks5"
DEPEND="readline? ( >=sys-libs/readline-4.1-r4 )
kerberos? ( virtual/krb5 )
@@ -21,7 +21,7 @@ RDEPEND=">=net-misc/openssh-3.0
${DEPEND}"
src_compile() {
- local myconf
+ local myconf=""
use krb4 && myconf="${myconf} --with-krb4=/usr/athena" \
|| myconf="${myconf} --with-krb4=no"
use kerberos && myconf="${myconf} --with-krb5=/usr/ --with-gssapi=/usr" \
@@ -31,7 +31,6 @@ src_compile() {
use readline && myconf="${myconf} --with-readline=/usr" \
|| myconf="${myconf} --with-readline=no"
-
econf $(use_with readline) ${myconf} || die "./configure failed"
emake || die "emake failed"
}