summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-11-13 13:00:27 +0000
committerThilo Bangert <bangert@gentoo.org>2008-11-13 13:00:27 +0000
commitfcfe66de1cfecac151761689cab42646124f8172 (patch)
tree18e398528335058fbdcffeeb9fdf45af0da59a1c /net-ftp/twoftpd
parentRun intltoolize (and depend on intltool), reported by Mahmoud Hashemi. (diff)
downloadgentoo-2-fcfe66de1cfecac151761689cab42646124f8172.tar.gz
gentoo-2-fcfe66de1cfecac151761689cab42646124f8172.tar.bz2
gentoo-2-fcfe66de1cfecac151761689cab42646124f8172.zip
add breakrfc patch (togglable through USE flag) which enables control symbols in filenames (bug #240512)
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-ftp/twoftpd')
-rw-r--r--net-ftp/twoftpd/ChangeLog10
-rw-r--r--net-ftp/twoftpd/files/twoftpd-1.21-disable-TELNET_IAC.patch14
-rw-r--r--net-ftp/twoftpd/metadata.xml4
-rw-r--r--net-ftp/twoftpd/twoftpd-1.21-r1.ebuild45
4 files changed, 72 insertions, 1 deletions
diff --git a/net-ftp/twoftpd/ChangeLog b/net-ftp/twoftpd/ChangeLog
index fc443347d5df..c3d856abe960 100644
--- a/net-ftp/twoftpd/ChangeLog
+++ b/net-ftp/twoftpd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-ftp/twoftpd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/ChangeLog,v 1.5 2008/01/25 23:03:22 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/ChangeLog,v 1.6 2008/11/13 13:00:27 bangert Exp $
+
+*twoftpd-1.21-r1 (13 Nov 2008)
+
+ 13 Nov 2008; Thilo Bangert <bangert@gentoo.org>
+ +files/twoftpd-1.21-disable-TELNET_IAC.patch, metadata.xml,
+ +twoftpd-1.21-r1.ebuild:
+ add breakrfc patch (togglable through USE flag) which enables control
+ symbols in filenames (bug #240512)
25 Jan 2008; Thilo Bangert <bangert@gentoo.org> twoftpd-1.21.ebuild:
use emake - dont dodoc COPYING
diff --git a/net-ftp/twoftpd/files/twoftpd-1.21-disable-TELNET_IAC.patch b/net-ftp/twoftpd/files/twoftpd-1.21-disable-TELNET_IAC.patch
new file mode 100644
index 000000000000..2d2a923ecfb0
--- /dev/null
+++ b/net-ftp/twoftpd/files/twoftpd-1.21-disable-TELNET_IAC.patch
@@ -0,0 +1,14 @@
+diff -uNr twoftpd-1.21.orig/main.c twoftpd-1.21/main.c
+--- twoftpd-1.21.orig/main.c 2006-04-19 02:47:56.000000000 +0300
++++ twoftpd-1.21/main.c 2007-12-16 18:06:08.000000000 +0200
+@@ -119,8 +119,8 @@
+ obuf_flush(&outbuf);
+ saw_esc_respond = 0;
+ }
+- else if (*byte == TELNET_IAC)
+- saw_esc = 1;
++// else if (*byte == TELNET_IAC)
++// saw_esc = 1;
+ else if (*byte == LF)
+ break;
+ else
diff --git a/net-ftp/twoftpd/metadata.xml b/net-ftp/twoftpd/metadata.xml
index a9e396315390..acc9fd1201ac 100644
--- a/net-ftp/twoftpd/metadata.xml
+++ b/net-ftp/twoftpd/metadata.xml
@@ -10,4 +10,8 @@
simple, and efficient. None of the commands can cause execution of other programs,
and the normal model of execution does a chroot to the logged in user's
directory immediately after authentication.</longdescription>
+ <use>
+ <flag name='breakrfc'>Break RFC compliance to allow control symbols in
+ filenames (required for some (e.g. cp1251) encodings, use with caution).</flag>
+ </use>
</pkgmetadata>
diff --git a/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild b/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild
new file mode 100644
index 000000000000..ae2774f68354
--- /dev/null
+++ b/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild,v 1.1 2008/11/13 13:00:27 bangert Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple secure efficient FTP server by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/twoftpd/"
+SRC_URI="http://untroubled.org/twoftpd/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="breakrfc"
+
+DEPEND="virtual/libc
+ >=dev-libs/bglibs-1.026
+ >=net-libs/cvm-0.32"
+RDEPEND="sys-apps/ucspi-tcp
+ sys-process/daemontools
+ >=net-libs/cvm-0.32"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use breakrfc && epatch "${FILESDIR}"/${P}-disable-TELNET_IAC.patch
+}
+
+src_compile() {
+ echo "/usr/sbin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS} -I/usr/include/bglibs" > conf-cc
+ echo "$(tc-getCC) -s -L/usr/lib/bglibs" > conf-ld
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/share/man/man1
+
+ emake install install_prefix="${D}" || die "install failed"
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
+ dodoc twoftpd.run twoftpd-log.run
+}