summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-02-12 09:46:37 +0000
committerThilo Bangert <bangert@gentoo.org>2010-02-12 09:46:37 +0000
commit36f1707f987cc46c92ec4193f70a68318e25c9fd (patch)
tree1926364b08d45e9b55e078ed95cb027df6fb469b /net-ftp/twoftpd/twoftpd-1.41.ebuild
parentVersion bump. (diff)
downloadgentoo-2-36f1707f987cc46c92ec4193f70a68318e25c9fd.tar.gz
gentoo-2-36f1707f987cc46c92ec4193f70a68318e25c9fd.tar.bz2
gentoo-2-36f1707f987cc46c92ec4193f70a68318e25c9fd.zip
version bump - dont pre-strip
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-ftp/twoftpd/twoftpd-1.41.ebuild')
-rw-r--r--net-ftp/twoftpd/twoftpd-1.41.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-ftp/twoftpd/twoftpd-1.41.ebuild b/net-ftp/twoftpd/twoftpd-1.41.ebuild
new file mode 100644
index 000000000000..cff1817db111
--- /dev/null
+++ b/net-ftp/twoftpd/twoftpd-1.41.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/twoftpd-1.41.ebuild,v 1.1 2010/02/12 09:46:37 bangert Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Simple secure efficient FTP server by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/twoftpd/"
+SRC_URI="http://untroubled.org/twoftpd/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="breakrfc"
+
+DEPEND=">=dev-libs/bglibs-1.106
+ >=net-libs/cvm-0.96"
+RDEPEND="sys-apps/ucspi-tcp
+ sys-process/daemontools
+ ${DEPEND}"
+
+src_prepare() {
+ use breakrfc && epatch "${FILESDIR}"/${PN}-1.21-disable-TELNET_IAC.patch
+}
+
+src_configure() {
+ echo "/usr/sbin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/$(get_libdir)/bglibs" > conf-bglibs
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_install() {
+ emake install install_prefix="${D}" || die "install failed"
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
+ dodoc twoftpd.run twoftpd-log.run
+}