summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-06-24 12:32:00 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-06-24 12:32:00 +0000
commit0c16bccbbfccf15c90ba40b50a4651168d4a0a95 (patch)
tree5321576378dac5d5f30079e4dec10926d3a9f073 /net-ftp/proftpd
parentForce MAKEOPTS=-j1 since the makefile breaks for parallel builds. This closes... (diff)
downloadgentoo-2-0c16bccbbfccf15c90ba40b50a4651168d4a0a95.tar.gz
gentoo-2-0c16bccbbfccf15c90ba40b50a4651168d4a0a95.tar.bz2
gentoo-2-0c16bccbbfccf15c90ba40b50a4651168d4a0a95.zip
fix vroot issue
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'net-ftp/proftpd')
-rw-r--r--net-ftp/proftpd/ChangeLog6
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.3.03
-rw-r--r--net-ftp/proftpd/proftpd-1.3.0.ebuild45
3 files changed, 26 insertions, 28 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index c39312a99ec1..ee01dbc180d7 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.107 2006/06/23 15:28:34 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.108 2006/06/24 12:32:00 humpback Exp $
+
+ 24 Jun 2006; Gustavo Felisberto <humpback@gentoo.org>;
+ proftpd-1.3.0.ebuild:
+ Updated to fix vroot and ifesession issues. Comments in bug 111668
*proftpd-1.3.0 (23 Jun 2006)
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.3.0 b/net-ftp/proftpd/files/digest-proftpd-1.3.0
index b54252a9e91e..080bbeb3944e 100644
--- a/net-ftp/proftpd/files/digest-proftpd-1.3.0
+++ b/net-ftp/proftpd/files/digest-proftpd-1.3.0
@@ -10,3 +10,6 @@ SHA256 83f220cba64455a2b1701b97ce9896f66a0020b179c50daf4860cdf362464ffe proftpd-
MD5 a81c3ed2d45f7c938416a970fd559703 proftpd-mod-shaper-0.5.6.tar.gz 18099
RMD160 3727e4407728727da4e6546e01b86c6b2cb68657 proftpd-mod-shaper-0.5.6.tar.gz 18099
SHA256 b846b9f4d8601a7ce426afa049b26db4da4ee8226ff61af97b0ca86b2fb8c827 proftpd-mod-shaper-0.5.6.tar.gz 18099
+MD5 bafd6c9ecfdf352641465b866be12f27 proftpd-mod-vroot-0.7.1.tar.gz 5613
+RMD160 b9677793f7cf6075467d7f41e4b8a9dfef89a847 proftpd-mod-vroot-0.7.1.tar.gz 5613
+SHA256 30d58c326bb30c080048662db0c4ffaf28f478fce40452c0c3c217cb5d2124e1 proftpd-mod-vroot-0.7.1.tar.gz 5613
diff --git a/net-ftp/proftpd/proftpd-1.3.0.ebuild b/net-ftp/proftpd/proftpd-1.3.0.ebuild
index 4347ffc10d49..955a93fc4d0c 100644
--- a/net-ftp/proftpd/proftpd-1.3.0.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.0.ebuild
@@ -1,19 +1,23 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.0.ebuild,v 1.1 2006/06/23 15:28:34 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.3.0.ebuild,v 1.2 2006/06/24 12:32:00 humpback Exp $
inherit eutils flag-o-matic toolchain-funcs
IUSE="hardened ipv6 ldap mysql pam postgres shaper softquota ssl tcpd
- selinux sendfile noauthunix authfile ncurses xinetd acl sitemisc rewrite clamav opensslcrypt ifsession radius vroot"
+ selinux sendfile noauthunix authfile ncurses xinetd acl sitemisc rewrite clamav opensslcrypt
+ ifsession radius vroot"
SHAPER_VER="0.5.6"
+VROOT_VER="0.7.1"
+
S=${WORKDIR}/${P}
DESCRIPTION="An advanced and very configurable FTP server"
SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P}.tar.bz2
shaper? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-shaper-${SHAPER_VER}.tar.gz )
- clamav? ( http://www.uglyboxindustries.com/mod_clamav.c http://www.uglyboxindustries.com/mod_clamav.html )"
+ clamav? ( http://www.uglyboxindustries.com/mod_clamav.c http://www.uglyboxindustries.com/mod_clamav.html )
+ vroot? ( http://www.castaglia.org/${PN}/modules/${PN}-mod-vroot-${VROOT_VER}.tar.gz )"
HOMEPAGE="http://www.proftpd.org/
http://www.castaglia.org/proftpd/
http://www.uglyboxindustries.com/open-source.php"
@@ -45,12 +49,17 @@ src_unpack() {
epatch "${FILESDIR}"/mod_sql_mysql.diff
if use shaper; then
unpack ${PN}-mod-shaper-${SHAPER_VER}.tar.gz
- mv mod_shaper/mod_shaper.c contrib/
+ cp mod_shaper/mod_shaper.c contrib/
fi
if use clamav; then
cp "${DISTDIR}"/mod_clamav.c contrib/
cp "${DISTDIR}"/mod_clamav.html doc/
fi
+ if use vroot; then
+ unpack ${PN}-mod-vroot-${VROOT_VER}.tar.gz
+ cp mod_vroot/mod_vroot.c contrib/
+ cp mod_vroot/mod_vroot.html doc/
+ fi
}
src_compile() {
@@ -65,22 +74,16 @@ src_compile() {
use sitemisc && modules="${modules}:mod_site_misc"
use rewrite && modules="${modules}:mod_rewrite"
use clamav && modules="${modules}:mod_clamav"
+ use radius && modules="${modules}:mod_radius"
+ use vroot && modules="${modules}:mod_vroot"
+ use ssl && modules="${modules}:mod_tls"
if use ldap; then
- einfo ldap
modules="${modules}:mod_ldap"
append-ldflags "-lresolv"
fi
- if use ssl; then
- einfo ssl
- # enable mod_tls
- modules="${modules}:mod_tls"
- fi
-
if use opensslcrypt; then
- einfo OpenSSL crypt
- # enable OpenSSL crypt
append-ldflags "-lcrypto"
myconf="${myconf} --with-includes=/usr/include/openssl"
CFLAGS="${CFLAGS} -DHAVE_OPENSSL"
@@ -115,20 +118,8 @@ src_compile() {
fi
fi
- if use ifsession; then
- einfo ifsession
- modules="${modules}:mod_ifsession"
- fi
-
- if use radius; then
- einfo radius
- modules="${modules}:mod_radius"
- fi
-
- if use vroot; then
- einfo radius
- modules="${modules}:mod_vroot"
- fi
+ #This should be the last module
+ use ifsession && modules="${modules}:mod_ifsession"
# bug #30359
use hardened && echo > lib/libcap/cap_sys.c