summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-29 12:15:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-29 12:15:12 +0000
commite81ff0bdd1d31e4391d6b1a165f58cd33ed41e8d (patch)
tree7bdb90721844ea18ecc936de023a73d0602e41fb /net-ftp/oneclickftp
parentadded new version, update live ebuild (diff)
downloadgentoo-2-e81ff0bdd1d31e4391d6b1a165f58cd33ed41e8d.tar.gz
gentoo-2-e81ff0bdd1d31e4391d6b1a165f58cd33ed41e8d.tar.bz2
gentoo-2-e81ff0bdd1d31e4391d6b1a165f58cd33ed41e8d.zip
Patch to compile with Qt-4.7. Bug #338622
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/oneclickftp')
-rw-r--r--net-ftp/oneclickftp/ChangeLog8
-rw-r--r--net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch13
-rw-r--r--net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild10
3 files changed, 26 insertions, 5 deletions
diff --git a/net-ftp/oneclickftp/ChangeLog b/net-ftp/oneclickftp/ChangeLog
index 377125244d4e..39d5d2c4da4d 100644
--- a/net-ftp/oneclickftp/ChangeLog
+++ b/net-ftp/oneclickftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/oneclickftp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/oneclickftp/ChangeLog,v 1.1 2009/12/15 09:10:25 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/oneclickftp/ChangeLog,v 1.2 2010/10/29 12:15:12 hwoarang Exp $
+
+ 29 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ oneclickftp-0.5.1.ebuild, +files/oneclickftp-0.5.1-qt47.patch:
+ Patch to compile with Qt-4.7. Bug #338622
*oneclickftp-0.5.1 (15 Dec 2009)
diff --git a/net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch b/net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch
new file mode 100644
index 000000000000..bea8e32af477
--- /dev/null
+++ b/net-ftp/oneclickftp/files/oneclickftp-0.5.1-qt47.patch
@@ -0,0 +1,13 @@
+Index: oneclickftp-0.5.1/src/ftpwindowimpl.h
+===================================================================
+--- oneclickftp-0.5.1.orig/src/ftpwindowimpl.h
++++ oneclickftp-0.5.1/src/ftpwindowimpl.h
+@@ -38,7 +38,7 @@ class FTPWindowImpl : public QWidget, pu
+ {
+ Q_OBJECT
+ public:
+- FTPWindowImpl(QString Dir, QString Profile, QString ProxyIP = 0, QString ProxyPort = 0);
++ FTPWindowImpl(QString Dir, QString Profile, QString ProxyIP = QString::number(0), QString ProxyPort = QString::number(0));
+ bool Upload(OProfile *ProfiletoUpload, std::vector<OFileConnection*> SelectedFiles);
+ bool Download(OProfile *ProfiletoDownload, std::vector<OFileConnection*> SelectedFiles);
+
diff --git a/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild b/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
index df3ee1ea0381..ef84a83ff296 100644
--- a/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
+++ b/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild,v 1.1 2009/12/15 09:10:25 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/oneclickftp/oneclickftp-0.5.1.ebuild,v 1.2 2010/10/29 12:15:12 hwoarang Exp $
EAPI=2
-inherit eutils qt4
+inherit eutils qt4-r2
DESCRIPTION="The somehow different FTP client"
HOMEPAGE="http://oneclickftp.sourceforge.net/"
@@ -17,6 +17,10 @@ IUSE=""
DEPEND=">=app-crypt/qca-2
x11-libs/qt-gui:4"
+PATCHES=(
+ "${FILESDIR}"/${P}-qt47.patch
+)
+
src_configure() {
eqmake4
}