summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-04 09:25:17 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-04 09:25:17 +0000
commit91fee677b3a372314ae1f37485290421b8ad551d (patch)
tree42852e45b3db3bebb102a5d6405a0002989e1ef4 /net-ftp/ncftp/ncftp-3.2.0.ebuild
parentmodX deps from canna-3.7_p3 (diff)
downloadgentoo-2-91fee677b3a372314ae1f37485290421b8ad551d.tar.gz
gentoo-2-91fee677b3a372314ae1f37485290421b8ad551d.tar.bz2
gentoo-2-91fee677b3a372314ae1f37485290421b8ad551d.zip
Version bump.
(Portage version: 2.1.1_rc1-r3)
Diffstat (limited to 'net-ftp/ncftp/ncftp-3.2.0.ebuild')
-rw-r--r--net-ftp/ncftp/ncftp-3.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-ftp/ncftp/ncftp-3.2.0.ebuild b/net-ftp/ncftp/ncftp-3.2.0.ebuild
new file mode 100644
index 000000000000..ca9100cac702
--- /dev/null
+++ b/net-ftp/ncftp/ncftp-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.2.0.ebuild,v 1.1 2006/09/04 09:25:17 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="An extremely configurable ftp client"
+HOMEPAGE="http://www.ncftp.com/"
+SRC_URI="ftp://ftp.ncftp.com/ncftp/${P}-src.tar.bz2"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i \
+ -e 's:@SFLAG@::' \
+ -e 's:@STRIP@:true:' \
+ Makefile.in */Makefile.in || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc README.txt doc/*.txt
+ dohtml doc/html/*.html
+}