summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-10-13 16:59:11 +0000
committerJeroen Roovers <jer@gentoo.org>2009-10-13 16:59:11 +0000
commitcf96771f6629236597fedc744fab4567aa302703 (patch)
treebb01a6116851d3d6c9483d360a0def60273164db /net-ftp/lftp
parentUpdate dependency after realpath package move, bug 273968. Remove old. (diff)
downloadgentoo-2-cf96771f6629236597fedc744fab4567aa302703.tar.gz
gentoo-2-cf96771f6629236597fedc744fab4567aa302703.tar.bz2
gentoo-2-cf96771f6629236597fedc744fab4567aa302703.zip
Do not install .la files.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog8
-rw-r--r--net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch21
-rw-r--r--net-ftp/lftp/lftp-4.0.2.91-r1.ebuild67
3 files changed, 95 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 14555676454c..1a8cb53597b5 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.235 2009/10/12 00:54:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.236 2009/10/13 16:59:10 jer Exp $
+
+*lftp-4.0.2.91-r1 (13 Oct 2009)
+
+ 13 Oct 2009; Jeroen Roovers <jer@gentoo.org> +lftp-4.0.2.91-r1.ebuild,
+ +files/lftp-4.0.2.91-lafile.patch:
+ Do not install .la files.
*lftp-4.0.2.91 (12 Oct 2009)
diff --git a/net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch b/net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch
new file mode 100644
index 000000000000..5a013b152fd8
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.0.2.91-lafile.patch
@@ -0,0 +1,21 @@
+--- lftp-4.0.2.91.orig/src/Makefile.am 2009-07-29 08:29:10.000000000 +0200
++++ lftp-4.0.2.91/src/Makefile.am 2009-10-13 18:32:26.000000000 +0200
+@@ -18,7 +18,8 @@
+ example_module1_la_SOURCES = example-module1.cc
+ example_module1_la_LDFLAGS = -module -avoid-version -rpath $(pkgverlibdir)
+
+-TASK_MODULES = liblftp-pty.la liblftp-network.la proto-ftp.la proto-http.la proto-file.la proto-fish.la proto-sftp.la
++TASK_MODULES = liblftp-pty.la liblftp-network.la proto-ftp.la proto-http.la proto-file.la proto-fish.la proto-sftp.la liblftp-tasks.la liblftp-jobs.la
++
+ JOB_MODULES = cmd-mirror.la cmd-sleep.la cmd-torrent.la
+ if WITH_MODULES
+ pkgverlib_LTLIBRARIES = $(TASK_MODULES) $(JOB_MODULES)
+@@ -26,8 +27,6 @@
+ TASK_MODULES_STATIC = $(TASK_MODULES)
+ JOB_MODULES_STATIC = $(JOB_MODULES)
+ endif
+-lib_LTLIBRARIES = liblftp-tasks.la liblftp-jobs.la
+-
+ proto_ftp_la_SOURCES = ftpclass.cc ftpclass.h FtpListInfo.cc FtpListInfo.h\
+ FtpDirList.cc FtpDirList.h ftp-opie.c FileCopyFtp.cc FileCopyFtp.h
+ proto_http_la_SOURCES = Http.cc Http.h HttpDir.cc HttpDir.h HttpDirXML.cc
diff --git a/net-ftp/lftp/lftp-4.0.2.91-r1.ebuild b/net-ftp/lftp/lftp-4.0.2.91-r1.ebuild
new file mode 100644
index 000000000000..2478135c4857
--- /dev/null
+++ b/net-ftp/lftp/lftp-4.0.2.91-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.0.2.91-r1.ebuild,v 1.1 2009/10/13 16:59:10 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="ftp://ftp.yar.ru/${PN}/devel/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ >=sys-libs/readline-5.1
+"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl
+ =sys-devel/libtool-2*
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-lafile.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}