summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-03-20 09:45:41 +0000
committerJeroen Roovers <jer@gentoo.org>2009-03-20 09:45:41 +0000
commit7e33a55df6cfd9ac330957e47c11778e19b1ebf6 (patch)
tree54e09b5ea99aa101e033ef8312a0b9792acaa66e /net-ftp/lftp
parentnew release mit-krb5-1.6.3-r5 with new patchset - see bug #262736 (diff)
downloadgentoo-2-7e33a55df6cfd9ac330957e47c11778e19b1ebf6.tar.gz
gentoo-2-7e33a55df6cfd9ac330957e47c11778e19b1ebf6.tar.bz2
gentoo-2-7e33a55df6cfd9ac330957e47c11778e19b1ebf6.zip
Version bump (bug #263093).
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog7
-rw-r--r--net-ftp/lftp/lftp-3.7.10.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 283870c0f99e..171db2f93754 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.166 2009/03/06 00:35:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.167 2009/03/20 09:45:41 jer Exp $
+
+*lftp-3.7.10 (20 Mar 2009)
+
+ 20 Mar 2009; Jeroen Roovers <jer@gentoo.org> +lftp-3.7.10.ebuild:
+ Version bump (bug #263093).
06 Mar 2009; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Add myself as maintainer.
diff --git a/net-ftp/lftp/lftp-3.7.10.ebuild b/net-ftp/lftp/lftp-3.7.10.ebuild
new file mode 100644
index 000000000000..ba59eb5a3be5
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.7.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.7.10.ebuild,v 1.1 2009/03/20 09:45:41 jer Exp $
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+SRC_URI="http://ftp.yars.free.net/pub/source/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ >=sys-libs/readline-5.1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}