summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-02-19 06:53:32 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-02-19 06:53:32 +0000
commit4a4b299f56d127f5ec1c82de435a8cd55c619867 (patch)
tree773f790c024f7cd644bfa0e7df224c5521f561ff /net-ftp/lftp
parentversion bump (diff)
downloadgentoo-2-4a4b299f56d127f5ec1c82de435a8cd55c619867.tar.gz
gentoo-2-4a4b299f56d127f5ec1c82de435a8cd55c619867.tar.bz2
gentoo-2-4a4b299f56d127f5ec1c82de435a8cd55c619867.zip
version bump as per bug #167535 thanks to dev-zero
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog9
-rw-r--r--net-ftp/lftp/files/digest-lftp-3.5.93
-rw-r--r--net-ftp/lftp/lftp-3.5.9.ebuild62
3 files changed, 72 insertions, 2 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 0845938a2bc8..1bee556d3d5c 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/lftp
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.122 2006/12/08 23:02:49 dragonheart Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.123 2007/02/19 06:53:32 dragonheart Exp $
+
+*lftp-3.5.9 (19 Feb 2007)
+
+ 19 Feb 2007; Daniel Black <dragonheart@gentoo.org> +lftp-3.5.9.ebuild:
+ version bump as per bug #167535 thanks to dev-zero
*lftp-3.5.7 (08 Dec 2006)
diff --git a/net-ftp/lftp/files/digest-lftp-3.5.9 b/net-ftp/lftp/files/digest-lftp-3.5.9
new file mode 100644
index 000000000000..fa8b256f1620
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-3.5.9
@@ -0,0 +1,3 @@
+MD5 242aa0b01be79942bb9bcdd2a4b079ba lftp-3.5.9.tar.bz2 1291792
+RMD160 669b11f06b59b43be4cdd2506484141adb1255b0 lftp-3.5.9.tar.bz2 1291792
+SHA256 f1960226d87b97a7bf0d81503adae365846f69f8ee6edacac8ff63524fcd1cd3 lftp-3.5.9.tar.bz2 1291792
diff --git a/net-ftp/lftp/lftp-3.5.9.ebuild b/net-ftp/lftp/lftp-3.5.9.ebuild
new file mode 100644
index 000000000000..bec7701c1b41
--- /dev/null
+++ b/net-ftp/lftp/lftp-3.5.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-3.5.9.ebuild,v 1.1 2007/02/19 06:53:32 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/sftp/http/https client and file transfer program"
+HOMEPAGE="http://lftp.yar.ru/"
+
+#SRC_URI="http://the.wiretapped.net/mirrors/lftp/${P}.tar.bz2"
+# Was a bit too slow and unreliable last time I tried (dragonheart)
+SRC_URI="ftp://lftp.yar.ru/lftp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl gnutls socks5 nls"
+
+RDEPEND=">=sys-libs/ncurses-5.1
+ socks5? (
+ >=net-proxy/dante-1.1.12
+ virtual/pam )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.3 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ virtual/libc
+ !ppc-macos? ( >=sys-libs/readline-5.1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_compile() {
+ local myconf="$(use_enable nls) --enable-packager-mode"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --without-openssl"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --without-gnutls --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-gnutls --without-openssl"
+ fi
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ use ppc-macos && myconf="${myconf} --with-included-readline"
+ econf \
+ --sysconfdir=/etc/lftp \
+ --with-modules \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dodoc BUGS ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}