summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-06 13:58:36 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-06 13:58:36 +0000
commit0748cb942262e8573a25fe1d1ce8c656b47277e9 (patch)
tree91293ae5c131ff5df30d9dcdffad0339b9a5a4d6 /net-ftp/lftp
parentInitial commit. Ebuild based on live ebuild in qt overlay. (diff)
downloadgentoo-2-0748cb942262e8573a25fe1d1ce8c656b47277e9.tar.gz
gentoo-2-0748cb942262e8573a25fe1d1ce8c656b47277e9.tar.bz2
gentoo-2-0748cb942262e8573a25fe1d1ce8c656b47277e9.zip
Fix building against glibc-2.16 by Martin Jansa (bug #425026).
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/ChangeLog6
-rw-r--r--net-ftp/lftp/files/lftp-4.3.8-gets.patch12
-rw-r--r--net-ftp/lftp/lftp-4.3.8.ebuild8
3 files changed, 21 insertions, 5 deletions
diff --git a/net-ftp/lftp/ChangeLog b/net-ftp/lftp/ChangeLog
index 60c4e00616f5..307f219bbcd1 100644
--- a/net-ftp/lftp/ChangeLog
+++ b/net-ftp/lftp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/lftp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.366 2012/07/05 23:58:43 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/ChangeLog,v 1.367 2012/07/06 13:58:36 jer Exp $
+
+ 06 Jul 2012; Jeroen Roovers <jer@gentoo.org> lftp-4.3.8.ebuild,
+ +files/lftp-4.3.8-gets.patch:
+ Fix building against glibc-2.16 by Martin Jansa (bug #425026).
05 Jul 2012; Jeff Horelick <jdhore@gentoo.org> lftp-4.3.7.ebuild:
marked x86 per bug 424922
diff --git a/net-ftp/lftp/files/lftp-4.3.8-gets.patch b/net-ftp/lftp/files/lftp-4.3.8-gets.patch
new file mode 100644
index 000000000000..d5aa369cefeb
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.3.8-gets.patch
@@ -0,0 +1,12 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -702,7 +702,9 @@
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning; besides, C11
+ removed it. */
++#ifdef gets
+ #undef gets
++#endif
+ #if HAVE_RAW_DECL_GETS
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
diff --git a/net-ftp/lftp/lftp-4.3.8.ebuild b/net-ftp/lftp/lftp-4.3.8.ebuild
index c41936b15c3c..d2394ea0ad25 100644
--- a/net-ftp/lftp/lftp-4.3.8.ebuild
+++ b/net-ftp/lftp/lftp-4.3.8.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.3.8.ebuild,v 1.1 2012/07/05 14:25:55 jer Exp $
-
-EAPI="4"
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-4.3.8.ebuild,v 1.2 2012/07/06 13:58:36 jer Exp $
+EAPI=4
inherit autotools eutils
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
@@ -52,7 +51,8 @@ src_prepare() {
epatch \
"${FILESDIR}/${PN}-4.0.2.91-lafile.patch" \
"${FILESDIR}/${PN}-4.0.3-autoconf-2.64.patch" \
- "${FILESDIR}/${PN}-4.3.5-autopoint.patch"
+ "${FILESDIR}/${PN}-4.3.5-autopoint.patch" \
+ "${FILESDIR}/${PN}-4.3.8-gets.patch"
eautoreconf
}