summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-08-02 14:17:59 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-08-02 14:17:59 +0000
commitc292fb7d6b8037ff4db716928efe18cf51470b1e (patch)
tree7d0dd4b46d17baff6fef54a3d8fab67d1a0dcb48 /net-ftp/lftp/files
parentStable on sparc wrt #142102 (diff)
downloadgentoo-2-c292fb7d6b8037ff4db716928efe18cf51470b1e.tar.gz
gentoo-2-c292fb7d6b8037ff4db716928efe18cf51470b1e.tar.bz2
gentoo-2-c292fb7d6b8037ff4db716928efe18cf51470b1e.zip
added patch from upstream. Moved ebuild to use modules mode. Fixed bug #142435 that resulted in automatically stripped executables. Fixed compile problem with USE=socks5
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'net-ftp/lftp/files')
-rw-r--r--net-ftp/lftp/files/lftp-3.5.2-install_data_hook.patch23
-rw-r--r--net-ftp/lftp/files/lftp-3.5.2-noautoflags.patch21
-rw-r--r--net-ftp/lftp/files/lftp-3.5.2-socklib.patch11
3 files changed, 55 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/lftp-3.5.2-install_data_hook.patch b/net-ftp/lftp/files/lftp-3.5.2-install_data_hook.patch
new file mode 100644
index 000000000000..102976d965d6
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-3.5.2-install_data_hook.patch
@@ -0,0 +1,23 @@
+--- src/Makefile.am.orig 2006-07-27 08:14:13.000000000 +0200
++++ src/Makefile.am 2006-07-31 23:54:36.000000000 +0200
+@@ -117,5 +117,7 @@
+ case " $(LDFLAGS) " in *" -s "*) \
+ echo $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so; \
+ $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so;; \
+- esac; else rmdir $(DESTDIR)$(pkgverlibdir) 2>/dev/null || true;
++ esac
++else
++ rmdir $(DESTDIR)$(pkgverlibdir) 2>/dev/null || true;
+ endif
+--- src/Makefile.in.orig 2006-07-31 23:54:41.000000000 +0200
++++ src/Makefile.in 2006-07-31 23:55:08.000000000 +0200
+@@ -1027,7 +1027,8 @@
+ @WITH_MODULES_TRUE@ case " $(LDFLAGS) " in *" -s "*) \
+ @WITH_MODULES_TRUE@ echo $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so; \
+ @WITH_MODULES_TRUE@ $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so;; \
+-@WITH_MODULES_TRUE@ esac; else rmdir $(DESTDIR)$(pkgverlibdir) 2>/dev/null || true;
++@WITH_MODULES_TRUE@ esac
++@WITH_MODULES_FALSE@ rmdir $(DESTDIR)$(pkgverlibdir) 2>/dev/null || true;
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net-ftp/lftp/files/lftp-3.5.2-noautoflags.patch b/net-ftp/lftp/files/lftp-3.5.2-noautoflags.patch
new file mode 100644
index 000000000000..3214d4c66e2c
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-3.5.2-noautoflags.patch
@@ -0,0 +1,21 @@
+--- configure.ac.orig 2006-08-02 16:01:52.000000000 +1000
++++ configure.ac 2006-08-02 17:23:10.000000000 +1000
+@@ -31,6 +31,18 @@
+ [ with_profiling=$withval; ],
+ [ with_profiling=no; ])
+
++AC_ARG_ENABLE([packager-mode],
++ AS_HELP_STRING([--enable-packager-mode],
++ [Change configuration behavior
++ to ease packaging]),
++ [if test x"${enableval}" = xyes
++ then
++ DEFAULT_CXX=no
++ DEFAULT_CFLAGS=no
++ DEFAULT_CXXFLAGS=no
++ DEFAULT_LDFLAGS=no
++ fi])
++
+ if test x$with_debug = xno; then
+ if test x$DEFAULT_CFLAGS = xyes; then
+ CFLAGS="`echo $CFLAGS | sed 's/-g//'`"
diff --git a/net-ftp/lftp/files/lftp-3.5.2-socklib.patch b/net-ftp/lftp/files/lftp-3.5.2-socklib.patch
new file mode 100644
index 000000000000..1e7aec8e6180
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-3.5.2-socklib.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.orig 2006-08-02 13:50:55.000000000 +1000
++++ src/Makefile.am 2006-08-02 13:52:33.000000000 +1000
+@@ -77,7 +77,7 @@
+ StringPool.cc StringPool.h DirColors.cc DirColors.h IdNameCache.cc\
+ IdNameCache.h PatternSet.cc PatternSet.h LocalDir.cc LocalDir.h\
+ mbswidth.c mbswidth.h wcwidth.h
+-liblftp_tasks_la_LIBADD = $(TASK_MODULES_STATIC) $(top_builddir)/lib/liblib.la $(LTLIBINTL) $(LTLIBICONV)
++liblftp_tasks_la_LIBADD = $(TASK_MODULES_STATIC) $(top_builddir)/lib/liblib.la $(LTLIBINTL) $(LTLIBICONV) @SOCKSLIBS@
+
+ liblftp_jobs_la_SOURCES = Job.cc Job.h CmdExec.cc CmdExec.h\
+ commands.cc mgetJob.h mgetJob.cc SysCmdJob.cc SysCmdJob.h rmJob.cc rmJob.h\