summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-05-23 09:49:59 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-05-23 09:49:59 +0000
commit5ebf74a6ad4313ad16a11747d76d4f5750fc333b (patch)
tree05fae891283fd159b38fa32ddc380431a2b5a735 /net-ftp/filezilla
parentMake dev-libs/libpcre optional dependency, econf doesn't need to die, remove ... (diff)
downloadgentoo-2-5ebf74a6ad4313ad16a11747d76d4f5750fc333b.tar.gz
gentoo-2-5ebf74a6ad4313ad16a11747d76d4f5750fc333b.tar.bz2
gentoo-2-5ebf74a6ad4313ad16a11747d76d4f5750fc333b.zip
Version bump, mostly performance improvements and bugfixes
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/ChangeLog7
-rw-r--r--net-ftp/filezilla/filezilla-3.5.0.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index cdd3b2ee00ac..93419dc7a238 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.78 2011/04/26 10:59:43 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.79 2011/05/23 09:49:59 voyageur Exp $
+
+*filezilla-3.5.0 (23 May 2011)
+
+ 23 May 2011; Bernard Cafarelli <voyageur@gentoo.org> +filezilla-3.5.0.ebuild:
+ Version bump, mostly performance improvements and bugfixes
26 Apr 2011; Bernard Cafarelli <voyageur@gentoo.org>
filezilla-3.3.4.1.ebuild, -filezilla-3.3.5.1.ebuild, filezilla-3.4.0.ebuild:
diff --git a/net-ftp/filezilla/filezilla-3.5.0.ebuild b/net-ftp/filezilla/filezilla-3.5.0.ebuild
new file mode 100644
index 000000000000..2cce6fb686f2
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.5.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.5.0.ebuild,v 1.1 2011/05/23 09:49:59 voyageur Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit autotools eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dbus nls test"
+
+RDEPEND=">=app-admin/eselect-wxwidgets-0.7-r1
+ >=dev-db/sqlite-3.7
+ >=dev-libs/tinyxml-2.6.1-r1[-stl]
+ net-dns/libidn
+ >=net-libs/gnutls-2.8.3
+ >=x11-libs/wxGTK-2.8.9:2.8[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3.5.1-debug.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-tinyxml=system \
+ --disable-autoupdatecheck || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}