summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-09-29 15:24:09 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-09-29 15:24:09 +0000
commit56e832fcf0ad3942229144b3aa463650e3b7100c (patch)
tree6313c2a5a3308ed4444ff8382f197c38f7ff0976 /net-ftp/filezilla
parentSparc stable --- Bug #238992 --- tests pass. (diff)
downloadgentoo-2-56e832fcf0ad3942229144b3aa463650e3b7100c.tar.gz
gentoo-2-56e832fcf0ad3942229144b3aa463650e3b7100c.tar.bz2
gentoo-2-56e832fcf0ad3942229144b3aa463650e3b7100c.zip
Version bump, fixes download speedlimits
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/ChangeLog8
-rw-r--r--net-ftp/filezilla/filezilla-3.1.3.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index aad6b9cd8dce..700144980d6e 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.18 2008/09/21 18:58:30 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.19 2008/09/29 15:24:09 voyageur Exp $
+
+*filezilla-3.1.3.1 (29 Sep 2008)
+
+ 29 Sep 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.1.3.1.ebuild:
+ Version bump, fixes download speedlimits
*filezilla-3.1.3 (21 Sep 2008)
diff --git a/net-ftp/filezilla/filezilla-3.1.3.1.ebuild b/net-ftp/filezilla/filezilla-3.1.3.1.ebuild
new file mode 100644
index 000000000000..878801d3fdd8
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.1.3.1.ebuild,v 1.1 2008/09/29 15:24:09 voyageur Exp $
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-dns/libidn
+ >=x11-libs/wxGTK-2.8.6
+ >=app-admin/eselect-wxwidgets-0.7-r1"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4
+ >=sys-devel/gettext-0.11
+ >=net-libs/gnutls-2.0.4"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}